By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,483 Members | 3,229 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,483 IT Pros & Developers. It's quick & easy.

[DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied.

P: n/a
in asp page
im getting this error how can i solve it..
yesterday the codes work but i setup visual studio 6.0 now it doesnt
works..

Jul 19 '05 #1
Share this Question
Share on Google+
33 Replies


P: n/a
What does your connection string look like? Are you connecting to the SQL
Server by its host name? If so, can your server resolve that name? Is
there a firewall in between? Is the server's network cable unplugged?

Ray at work
"Savas Ates" <sa***@indexinteractive.com> wrote in message
news:uQ**************@TK2MSFTNGP15.phx.gbl...
in asp page
im getting this error how can i solve it..
yesterday the codes work but i setup visual studio 6.0 now it doesnt
works..

Jul 19 '05 #2

P: n/a
I have the same problem. We recently moved our ASP app from Windows 2000 to
Windows 2003 Web servers, and when we did this our problems started popping
up. When we moved to the new servers, we also changed the connect strings
from using ODBC DSN's to OLEDB connect strings. To troubleshoot if that was
the cause, we copied the modified app back to the 2000 box, complete with
the new connect strings, and never saw the error happen there. We've tried
adding adding "Network Library=dbmssocn" into our connect strings, but that
didn't help. We added the SQL server to the hosts & lmhosts.sam files, and
did the same on the SQL server (added the web servers to the files) - but
that didn't help. We used the client network utility to enable both TCP/IP
& Named Pipes on the web servers - but that didn't help.

I've seen too many other posts on google to believe that this is an isolated
problem. I've also seen posts that made me believe that this has something
to do with going from Win2000 to Win2003.

The error is very sporadic. We have 100+ users on the app all day long, and
only every once in a while the error happens. If the user hits refresh
right after the error, the connection work just fine.
Please help!

Scott Ivey


"Ray Costanzo [MVP]" <my first name at lane 34 dot commercial> wrote in
message news:%2****************@tk2msftngp13.phx.gbl...
What does your connection string look like? Are you connecting to the SQL
Server by its host name? If so, can your server resolve that name? Is
there a firewall in between? Is the server's network cable unplugged?

Ray at work
"Savas Ates" <sa***@indexinteractive.com> wrote in message
news:uQ**************@TK2MSFTNGP15.phx.gbl...
in asp page
im getting this error how can i solve it..
yesterday the codes work but i setup visual studio 6.0 now it doesnt
works..


Jul 21 '05 #3

P: n/a
Are you connecting to the server by name, external IP, internal IP, ...?

Can you show the connection string that doesn't work and the ODBC parameters
that work?

--
http://www.aspfaq.com/
(Reverse address to reply.)


"Scott Ivey" <si***@online.nospam> wrote in message
news:Os**************@TK2MSFTNGP09.phx.gbl...
I have the same problem. We recently moved our ASP app from Windows 2000 to Windows 2003 Web servers, and when we did this our problems started popping up. When we moved to the new servers, we also changed the connect strings
from using ODBC DSN's to OLEDB connect strings. To troubleshoot if that was the cause, we copied the modified app back to the 2000 box, complete with
the new connect strings, and never saw the error happen there. We've tried adding adding "Network Library=dbmssocn" into our connect strings, but that didn't help. We added the SQL server to the hosts & lmhosts.sam files, and did the same on the SQL server (added the web servers to the files) - but
that didn't help. We used the client network utility to enable both TCP/IP & Named Pipes on the web servers - but that didn't help.

I've seen too many other posts on google to believe that this is an isolated problem. I've also seen posts that made me believe that this has something to do with going from Win2000 to Win2003.

The error is very sporadic. We have 100+ users on the app all day long, and only every once in a while the error happens. If the user hits refresh
right after the error, the connection work just fine.
Please help!

Scott Ivey


"Ray Costanzo [MVP]" <my first name at lane 34 dot commercial> wrote in
message news:%2****************@tk2msftngp13.phx.gbl...
What does your connection string look like? Are you connecting to the SQL Server by its host name? If so, can your server resolve that name? Is
there a firewall in between? Is the server's network cable unplugged?

Ray at work
"Savas Ates" <sa***@indexinteractive.com> wrote in message
news:uQ**************@TK2MSFTNGP15.phx.gbl...
in asp page
im getting this error how can i solve it..
yesterday the codes work but i setup visual studio 6.0 now it doesnt
works..



Jul 21 '05 #4

P: n/a
I've tried the following connect strings...

"Provider=SQLOLEDB;Data Source=revsql01;Initial Catalog=RPM;User
ID=rpmuser;Password=xxxxx"
"Provider=SQLOLEDB;Data Source=revsql01.revonet.local;Initial
Catalog=RPM;User ID=rpmuser;Password=xxxxx"
"Provider=SQLOLEDB;Data Source=revsql01;Initial Catalog=RPM;User
ID=rpmuser;Password=xxxxx;Network Library=dbmssocn"
"Provider=SQLOLEDB;Data Source=revsql01.revonet.local;Initial
Catalog=RPM;User ID=rpmuser;Password=xxxxx;Network Library=dbmssocn"

I'm currently using string #2 above. The ODBC DSN's were system DSN's, and
used the DB name, username, & password as above.

Using #2, I can connect a thousand times successfully, and have 1 error
somewhere in the middle.

The servers are connected to the same Catalyst 2950 switch, and they all
have hard wired hosts files - so I can't imagine that resolving the other
server is a problem.
Scott
"Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
news:eU**************@tk2msftngp13.phx.gbl...
Are you connecting to the server by name, external IP, internal IP, ...?

Can you show the connection string that doesn't work and the ODBC
parameters
that work?

--
http://www.aspfaq.com/
(Reverse address to reply.)


"Scott Ivey" <si***@online.nospam> wrote in message
news:Os**************@TK2MSFTNGP09.phx.gbl...
I have the same problem. We recently moved our ASP app from Windows 2000

to
Windows 2003 Web servers, and when we did this our problems started

popping
up. When we moved to the new servers, we also changed the connect
strings
from using ODBC DSN's to OLEDB connect strings. To troubleshoot if that

was
the cause, we copied the modified app back to the 2000 box, complete with
the new connect strings, and never saw the error happen there. We've

tried
adding adding "Network Library=dbmssocn" into our connect strings, but

that
didn't help. We added the SQL server to the hosts & lmhosts.sam files,

and
did the same on the SQL server (added the web servers to the files) - but
that didn't help. We used the client network utility to enable both

TCP/IP
& Named Pipes on the web servers - but that didn't help.

I've seen too many other posts on google to believe that this is an

isolated
problem. I've also seen posts that made me believe that this has

something
to do with going from Win2000 to Win2003.

The error is very sporadic. We have 100+ users on the app all day long,

and
only every once in a while the error happens. If the user hits refresh
right after the error, the connection work just fine.
Please help!

Scott Ivey


"Ray Costanzo [MVP]" <my first name at lane 34 dot commercial> wrote in
message news:%2****************@tk2msftngp13.phx.gbl...
> What does your connection string look like? Are you connecting to the SQL > Server by its host name? If so, can your server resolve that name? Is
> there a firewall in between? Is the server's network cable unplugged?
>
> Ray at work
>
>
> "Savas Ates" <sa***@indexinteractive.com> wrote in message
> news:uQ**************@TK2MSFTNGP15.phx.gbl...
>> in asp page
>> im getting this error how can i solve it..
>> yesterday the codes work but i setup visual studio 6.0 now it doesnt
>> works..
>>
>>
>>
>
>



Jul 21 '05 #5

P: n/a
> The servers are connected to the same Catalyst 2950 switch, and they all
have hard wired hosts files - so I can't imagine that resolving the other
server is a problem.


For #2, have you tried using an IP address instead of a server name? DNS
(not DSN), WINS etc. can be flaky occasionally, and I'm sure that could
account for 1 in 1000. It could also be the switch going down briefly, or
some other network glitch.

A
Jul 21 '05 #6

P: n/a
I'm going to try going by IP address tonight. Shouldn't using a hosts file
entry override any DNS issues?
Scott

"Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
news:%2****************@TK2MSFTNGP12.phx.gbl...
The servers are connected to the same Catalyst 2950 switch, and they all
have hard wired hosts files - so I can't imagine that resolving the other
server is a problem.


For #2, have you tried using an IP address instead of a server name? DNS
(not DSN), WINS etc. can be flaky occasionally, and I'm sure that could
account for 1 in 1000. It could also be the switch going down briefly, or
some other network glitch.

A

Jul 21 '05 #7

P: n/a
I know that the web browser uses the hosts fle, but I'm not confident ado
will do the same thing. I'm pretty sure SQL Server, at least, will attempt
to use the client network library before it ever looks at the hosts file.
Did you set up anything in the client network library? Are you planning to
change the IP (in other words, is there some big reservation against
changing the IP instead of continuing to kludge a hosts file)?

--
http://www.aspfaq.com/
(Reverse address to reply.)


"Scott Ivey" <si***@online.nospam> wrote in message
news:#S**************@TK2MSFTNGP14.phx.gbl...
I'm going to try going by IP address tonight. Shouldn't using a hosts file entry override any DNS issues?
Scott

"Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
news:%2****************@TK2MSFTNGP12.phx.gbl...
The servers are connected to the same Catalyst 2950 switch, and they all have hard wired hosts files - so I can't imagine that resolving the other server is a problem.


For #2, have you tried using an IP address instead of a server name? DNS (not DSN), WINS etc. can be flaky occasionally, and I'm sure that could
account for 1 in 1000. It could also be the switch going down briefly, or some other network glitch.

A


Jul 21 '05 #8

P: n/a
I have no problem with hardwiring the IP - I don't expect that to change
anytime soon :) I just added 2 aliases for the server (revsq01 &
revsql01.revonet.local) in the client network utility using TCP/IP and
pointing at the IP address of the server instead of the DNS name. Hopefully
this will fix it :)
Scott

"Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
news:uh****************@TK2MSFTNGP09.phx.gbl...
I know that the web browser uses the hosts fle, but I'm not confident ado
will do the same thing. I'm pretty sure SQL Server, at least, will
attempt
to use the client network library before it ever looks at the hosts file.
Did you set up anything in the client network library? Are you planning
to
change the IP (in other words, is there some big reservation against
changing the IP instead of continuing to kludge a hosts file)?

--
http://www.aspfaq.com/
(Reverse address to reply.)


"Scott Ivey" <si***@online.nospam> wrote in message
news:#S**************@TK2MSFTNGP14.phx.gbl...
I'm going to try going by IP address tonight. Shouldn't using a hosts

file
entry override any DNS issues?
Scott

"Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
news:%2****************@TK2MSFTNGP12.phx.gbl...
>> The servers are connected to the same Catalyst 2950 switch, and they all >> have hard wired hosts files - so I can't imagine that resolving the other >> server is a problem.
>
> For #2, have you tried using an IP address instead of a server name? DNS > (not DSN), WINS etc. can be flaky occasionally, and I'm sure that could
> account for 1 in 1000. It could also be the switch going down briefly, or > some other network glitch.
>
> A
>
>



Jul 21 '05 #9

P: n/a
Well, I added the 2 aliases..

revsql01 - TCP/IP - pointed to the SQL IP address, dynamic port number
revsql01.revonet.local - TCP/IP - pointed to the SQL IP address, dynamic
port number

My connect string is "Provider=SQLOLEDB;Data
Source=revsql01.revonet.local;Initial Catalog=RPM;User
ID=rpmuser;Password=xxxxx"

and a half hour later, I'm getting errors. guess that isn't the fix. damn!

I've tried everything I can think of, and still am struggling.

Scott
"Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
news:uh****************@TK2MSFTNGP09.phx.gbl...
I know that the web browser uses the hosts fle, but I'm not confident ado
will do the same thing. I'm pretty sure SQL Server, at least, will
attempt
to use the client network library before it ever looks at the hosts file.
Did you set up anything in the client network library? Are you planning
to
change the IP (in other words, is there some big reservation against
changing the IP instead of continuing to kludge a hosts file)?

--
http://www.aspfaq.com/
(Reverse address to reply.)


"Scott Ivey" <si***@online.nospam> wrote in message
news:#S**************@TK2MSFTNGP14.phx.gbl...
I'm going to try going by IP address tonight. Shouldn't using a hosts

file
entry override any DNS issues?
Scott

"Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
news:%2****************@TK2MSFTNGP12.phx.gbl...
>> The servers are connected to the same Catalyst 2950 switch, and they all >> have hard wired hosts files - so I can't imagine that resolving the other >> server is a problem.
>
> For #2, have you tried using an IP address instead of a server name? DNS > (not DSN), WINS etc. can be flaky occasionally, and I'm sure that could
> account for 1 in 1000. It could also be the switch going down briefly, or > some other network glitch.
>
> A
>
>



Jul 21 '05 #10

P: n/a
> revsql01 - TCP/IP - pointed to the SQL IP address, dynamic port number
revsql01.revonet.local - TCP/IP - pointed to the SQL IP address, dynamic
port number

My connect string is "Provider=SQLOLEDB;Data
Source=revsql01.revonet.local;Initial Catalog=RPM;User
ID=rpmuser;Password=xxxxx"


Is it running on port 1433, or another port?
Jul 21 '05 #11

P: n/a
I haven't changed anything from the default, so yes.

Scott

"Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
news:u1**************@TK2MSFTNGP12.phx.gbl...
revsql01 - TCP/IP - pointed to the SQL IP address, dynamic port number
revsql01.revonet.local - TCP/IP - pointed to the SQL IP address, dynamic
port number

My connect string is "Provider=SQLOLEDB;Data
Source=revsql01.revonet.local;Initial Catalog=RPM;User
ID=rpmuser;Password=xxxxx"


Is it running on port 1433, or another port?

Jul 21 '05 #12

P: n/a
Have you tried connecting with a different user name? And/or using the
shorter server name (not sure what you're gaining from
revsql01.revonet.local, unless you're trying to practice your typing
skills)? And/or using the IP address in the connection string?

--
http://www.aspfaq.com/
(Reverse address to reply.)


"Scott Ivey" <si***@online.nospam> wrote in message
news:et**************@TK2MSFTNGP12.phx.gbl...
I haven't changed anything from the default, so yes.

Scott

"Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
news:u1**************@TK2MSFTNGP12.phx.gbl...
revsql01 - TCP/IP - pointed to the SQL IP address, dynamic port number
revsql01.revonet.local - TCP/IP - pointed to the SQL IP address, dynamic port number

My connect string is "Provider=SQLOLEDB;Data
Source=revsql01.revonet.local;Initial Catalog=RPM;User
ID=rpmuser;Password=xxxxx"


Is it running on port 1433, or another port?


Jul 21 '05 #13

P: n/a
Haven't tried different users. I had the FQDN in the connect string because
I thought that would fix any DNS resolution problems, if that was the
problem. I'm going to try putting the IP address directly in the connect
string tonight - can't do it during the day without causing an application
restart.

Scott

"Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
news:uc**************@TK2MSFTNGP14.phx.gbl...
Have you tried connecting with a different user name? And/or using the
shorter server name (not sure what you're gaining from
revsql01.revonet.local, unless you're trying to practice your typing
skills)? And/or using the IP address in the connection string?

--
http://www.aspfaq.com/
(Reverse address to reply.)


"Scott Ivey" <si***@online.nospam> wrote in message
news:et**************@TK2MSFTNGP12.phx.gbl...
I haven't changed anything from the default, so yes.

Scott

"Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
news:u1**************@TK2MSFTNGP12.phx.gbl...
>> revsql01 - TCP/IP - pointed to the SQL IP address, dynamic port number
>> revsql01.revonet.local - TCP/IP - pointed to the SQL IP address, dynamic >> port number
>>
>> My connect string is "Provider=SQLOLEDB;Data
>> Source=revsql01.revonet.local;Initial Catalog=RPM;User
>> ID=rpmuser;Password=xxxxx"
>
> Is it running on port 1433, or another port?
>
>



Jul 21 '05 #14

P: n/a
The strange thing about it all is that when I copy the entire web directory,
including any connection strings, back to my win2000 server, everything
works fine - no errors ever.
Scott

"Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
news:uc**************@TK2MSFTNGP14.phx.gbl...
Have you tried connecting with a different user name? And/or using the
shorter server name (not sure what you're gaining from
revsql01.revonet.local, unless you're trying to practice your typing
skills)? And/or using the IP address in the connection string?

--
http://www.aspfaq.com/
(Reverse address to reply.)


"Scott Ivey" <si***@online.nospam> wrote in message
news:et**************@TK2MSFTNGP12.phx.gbl...
I haven't changed anything from the default, so yes.

Scott

"Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
news:u1**************@TK2MSFTNGP12.phx.gbl...
>> revsql01 - TCP/IP - pointed to the SQL IP address, dynamic port number
>> revsql01.revonet.local - TCP/IP - pointed to the SQL IP address, dynamic >> port number
>>
>> My connect string is "Provider=SQLOLEDB;Data
>> Source=revsql01.revonet.local;Initial Catalog=RPM;User
>> ID=rpmuser;Password=xxxxx"
>
> Is it running on port 1433, or another port?
>
>



Jul 21 '05 #15

P: n/a
I changed the connect string to use the IP address - and still get the
errors. I don't get it - this just should not be happening. New connect
string is...

"Provider=SQLOLEDB;Data Source=192.168.200.40;Initial Catalog=RPM;User
ID=rpmuser;Password=xxxxx"
MS - are you watching this post??? I'm posting with my MSDN alias - and
we're now at the deadline for resolution for my MSDN Managed Newsgroup
support. I had opened a support incident before posting this, but had
opened it with the Cluster group (since the website is on 2 servers running
NLBS), and they were unable to help me, so I cancelled the ticket. Anyone
have any ideas on which group should handle this?
Thanks,
Scott


"Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
news:uc**************@TK2MSFTNGP14.phx.gbl...
Have you tried connecting with a different user name? And/or using the
shorter server name (not sure what you're gaining from
revsql01.revonet.local, unless you're trying to practice your typing
skills)? And/or using the IP address in the connection string?

--
http://www.aspfaq.com/
(Reverse address to reply.)


"Scott Ivey" <si***@online.nospam> wrote in message
news:et**************@TK2MSFTNGP12.phx.gbl...
I haven't changed anything from the default, so yes.

Scott

"Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
news:u1**************@TK2MSFTNGP12.phx.gbl...
>> revsql01 - TCP/IP - pointed to the SQL IP address, dynamic port number
>> revsql01.revonet.local - TCP/IP - pointed to the SQL IP address, dynamic >> port number
>>
>> My connect string is "Provider=SQLOLEDB;Data
>> Source=revsql01.revonet.local;Initial Catalog=RPM;User
>> ID=rpmuser;Password=xxxxx"
>
> Is it running on port 1433, or another port?
>
>



Jul 21 '05 #16

P: n/a
You should try forcing TCP/IP to be used with the Network Library attribute
in your connection string.:

Network Library=DBMSSOCN;"

Bob Barrows

Scott Ivey wrote:
I changed the connect string to use the IP address - and still get the
errors. I don't get it - this just should not be happening. New
connect string is...

"Provider=SQLOLEDB;Data Source=192.168.200.40;Initial Catalog=RPM;User
ID=rpmuser;Password=xxxxx"
MS - are you watching this post??? I'm posting with my MSDN alias -
and we're now at the deadline for resolution for my MSDN Managed
Newsgroup support. I had opened a support incident before posting
this, but had opened it with the Cluster group (since the website is
on 2 servers running NLBS), and they were unable to help me, so I
cancelled the ticket. Anyone have any ideas on which group should
handle this?

Thanks,
Scott


"Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
news:uc**************@TK2MSFTNGP14.phx.gbl...
Have you tried connecting with a different user name? And/or using
the shorter server name (not sure what you're gaining from
revsql01.revonet.local, unless you're trying to practice your typing
skills)? And/or using the IP address in the connection string?

--
http://www.aspfaq.com/
(Reverse address to reply.)


"Scott Ivey" <si***@online.nospam> wrote in message
news:et**************@TK2MSFTNGP12.phx.gbl...
I haven't changed anything from the default, so yes.

Scott

"Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
news:u1**************@TK2MSFTNGP12.phx.gbl...
> revsql01 - TCP/IP - pointed to the SQL IP address, dynamic port
> number revsql01.revonet.local - TCP/IP - pointed to the SQL IP
> address, dynamic port number
>
> My connect string is "Provider=SQLOLEDB;Data
> Source=revsql01.revonet.local;Initial Catalog=RPM;User
> ID=rpmuser;Password=xxxxx"

Is it running on port 1433, or another port?


--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap so I
don't check it very often. If you must reply off-line, then remove the
"NO SPAM"
Jul 21 '05 #17

P: n/a
I've tried that, but it didn't help. I've also used the Client Network
Utility to force TCP/IP, but that didn't help either.
Scott

"Bob Barrows [MVP]" <re******@NOyahoo.SPAMcom> wrote in message
news:OQ**************@TK2MSFTNGP09.phx.gbl...
You should try forcing TCP/IP to be used with the Network Library
attribute in your connection string.:

Network Library=DBMSSOCN;"

Bob Barrows

Scott Ivey wrote:
I changed the connect string to use the IP address - and still get the
errors. I don't get it - this just should not be happening. New
connect string is...

"Provider=SQLOLEDB;Data Source=192.168.200.40;Initial Catalog=RPM;User
ID=rpmuser;Password=xxxxx"
MS - are you watching this post??? I'm posting with my MSDN alias -
and we're now at the deadline for resolution for my MSDN Managed
Newsgroup support. I had opened a support incident before posting
this, but had opened it with the Cluster group (since the website is
on 2 servers running NLBS), and they were unable to help me, so I
cancelled the ticket. Anyone have any ideas on which group should
handle this?

Thanks,
Scott


"Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
news:uc**************@TK2MSFTNGP14.phx.gbl...
Have you tried connecting with a different user name? And/or using
the shorter server name (not sure what you're gaining from
revsql01.revonet.local, unless you're trying to practice your typing
skills)? And/or using the IP address in the connection string?

--
http://www.aspfaq.com/
(Reverse address to reply.)


"Scott Ivey" <si***@online.nospam> wrote in message
news:et**************@TK2MSFTNGP12.phx.gbl...
I haven't changed anything from the default, so yes.

Scott

"Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
news:u1**************@TK2MSFTNGP12.phx.gbl...
>> revsql01 - TCP/IP - pointed to the SQL IP address, dynamic port
>> number revsql01.revonet.local - TCP/IP - pointed to the SQL IP
>> address, dynamic port number
>>
>> My connect string is "Provider=SQLOLEDB;Data
>> Source=revsql01.revonet.local;Initial Catalog=RPM;User
>> ID=rpmuser;Password=xxxxx"
>
> Is it running on port 1433, or another port?


--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap so I
don't check it very often. If you must reply off-line, then remove the
"NO SPAM"

Jul 21 '05 #18

P: n/a
What happens if you put the code that opens the connection into a .vbs file
and run it from a command prompt when logged on as administrator on the
server?

Have you worked through all of the variations at
http://www.able-consulting.com/MDAC/...erForSQLServer

--
Mark Schupp
Head of Development
Integrity eLearning
www.ielearning.com
"Scott Ivey" <si***@online.nospam> wrote in message
news:eH**************@TK2MSFTNGP10.phx.gbl...
I've tried that, but it didn't help. I've also used the Client Network
Utility to force TCP/IP, but that didn't help either.
Scott

"Bob Barrows [MVP]" <re******@NOyahoo.SPAMcom> wrote in message
news:OQ**************@TK2MSFTNGP09.phx.gbl...
You should try forcing TCP/IP to be used with the Network Library
attribute in your connection string.:

Network Library=DBMSSOCN;"

Bob Barrows

Scott Ivey wrote:
I changed the connect string to use the IP address - and still get the
errors. I don't get it - this just should not be happening. New
connect string is...

"Provider=SQLOLEDB;Data Source=192.168.200.40;Initial Catalog=RPM;User
ID=rpmuser;Password=xxxxx"
MS - are you watching this post??? I'm posting with my MSDN alias -
and we're now at the deadline for resolution for my MSDN Managed
Newsgroup support. I had opened a support incident before posting
this, but had opened it with the Cluster group (since the website is
on 2 servers running NLBS), and they were unable to help me, so I
cancelled the ticket. Anyone have any ideas on which group should
handle this?

Thanks,
Scott


"Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
news:uc**************@TK2MSFTNGP14.phx.gbl...
Have you tried connecting with a different user name? And/or using
the shorter server name (not sure what you're gaining from
revsql01.revonet.local, unless you're trying to practice your typing
skills)? And/or using the IP address in the connection string?

--
http://www.aspfaq.com/
(Reverse address to reply.)


"Scott Ivey" <si***@online.nospam> wrote in message
news:et**************@TK2MSFTNGP12.phx.gbl...
> I haven't changed anything from the default, so yes.
>
> Scott
>
> "Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
> news:u1**************@TK2MSFTNGP12.phx.gbl...
>>> revsql01 - TCP/IP - pointed to the SQL IP address, dynamic port
>>> number revsql01.revonet.local - TCP/IP - pointed to the SQL IP
>>> address, dynamic port number
>>>
>>> My connect string is "Provider=SQLOLEDB;Data
>>> Source=revsql01.revonet.local;Initial Catalog=RPM;User
>>> ID=rpmuser;Password=xxxxx"
>>
>> Is it running on port 1433, or another port?


--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap so I
don't check it very often. If you must reply off-line, then remove the
"NO SPAM"


Jul 21 '05 #19

P: n/a
Then I don't understand why you are seeing DBNETLIB in your error
statement...

Bob Barrows
Scott Ivey wrote:
I've tried that, but it didn't help. I've also used the Client
Network Utility to force TCP/IP, but that didn't help either.
Scott

"Bob Barrows [MVP]" <re******@NOyahoo.SPAMcom> wrote in message
news:OQ**************@TK2MSFTNGP09.phx.gbl...
You should try forcing TCP/IP to be used with the Network Library
attribute in your connection string.:

Network Library=DBMSSOCN;"

Bob Barrows

Scott Ivey wrote:
I changed the connect string to use the IP address - and still get
the errors. I don't get it - this just should not be happening. New
connect string is...

"Provider=SQLOLEDB;Data Source=192.168.200.40;Initial
Catalog=RPM;User ID=rpmuser;Password=xxxxx"
MS - are you watching this post??? I'm posting with my MSDN alias -
and we're now at the deadline for resolution for my MSDN Managed
Newsgroup support. I had opened a support incident before posting
this, but had opened it with the Cluster group (since the website is
on 2 servers running NLBS), and they were unable to help me, so I
cancelled the ticket. Anyone have any ideas on which group should
handle this?

Thanks,
Scott


"Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
news:uc**************@TK2MSFTNGP14.phx.gbl...
Have you tried connecting with a different user name? And/or using
the shorter server name (not sure what you're gaining from
revsql01.revonet.local, unless you're trying to practice your
typing skills)? And/or using the IP address in the connection
string? --
http://www.aspfaq.com/
(Reverse address to reply.)


"Scott Ivey" <si***@online.nospam> wrote in message
news:et**************@TK2MSFTNGP12.phx.gbl...
> I haven't changed anything from the default, so yes.
>
> Scott
>
> "Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
> news:u1**************@TK2MSFTNGP12.phx.gbl...
>>> revsql01 - TCP/IP - pointed to the SQL IP address, dynamic port
>>> number revsql01.revonet.local - TCP/IP - pointed to the SQL IP
>>> address, dynamic port number
>>>
>>> My connect string is "Provider=SQLOLEDB;Data
>>> Source=revsql01.revonet.local;Initial Catalog=RPM;User
>>> ID=rpmuser;Password=xxxxx"
>>
>> Is it running on port 1433, or another port?


--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap so
I don't check it very often. If you must reply off-line, then remove
the "NO SPAM"


--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap so I
don't check it very often. If you must reply off-line, then remove the
"NO SPAM"
Jul 21 '05 #20

P: n/a
DBNETLIB is correct - that is the OLEDB compenent for SQL server, and is
used for TCP/IP connections - isn't it???

Scott

"Bob Barrows [MVP]" <re******@NOyahoo.SPAMcom> wrote in message
news:O3**************@TK2MSFTNGP09.phx.gbl...
Then I don't understand why you are seeing DBNETLIB in your error
statement...

Bob Barrows
Scott Ivey wrote:
I've tried that, but it didn't help. I've also used the Client
Network Utility to force TCP/IP, but that didn't help either.
Scott

"Bob Barrows [MVP]" <re******@NOyahoo.SPAMcom> wrote in message
news:OQ**************@TK2MSFTNGP09.phx.gbl...
You should try forcing TCP/IP to be used with the Network Library
attribute in your connection string.:

Network Library=DBMSSOCN;"

Bob Barrows

Scott Ivey wrote:
I changed the connect string to use the IP address - and still get
the errors. I don't get it - this just should not be happening. New
connect string is...

"Provider=SQLOLEDB;Data Source=192.168.200.40;Initial
Catalog=RPM;User ID=rpmuser;Password=xxxxx"
MS - are you watching this post??? I'm posting with my MSDN alias -
and we're now at the deadline for resolution for my MSDN Managed
Newsgroup support. I had opened a support incident before posting
this, but had opened it with the Cluster group (since the website is
on 2 servers running NLBS), and they were unable to help me, so I
cancelled the ticket. Anyone have any ideas on which group should
handle this?

Thanks,
Scott


"Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
news:uc**************@TK2MSFTNGP14.phx.gbl...
> Have you tried connecting with a different user name? And/or using
> the shorter server name (not sure what you're gaining from
> revsql01.revonet.local, unless you're trying to practice your
> typing skills)? And/or using the IP address in the connection
> string? --
> http://www.aspfaq.com/
> (Reverse address to reply.)
>
>
>
>
> "Scott Ivey" <si***@online.nospam> wrote in message
> news:et**************@TK2MSFTNGP12.phx.gbl...
>> I haven't changed anything from the default, so yes.
>>
>> Scott
>>
>> "Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
>> news:u1**************@TK2MSFTNGP12.phx.gbl...
>>>> revsql01 - TCP/IP - pointed to the SQL IP address, dynamic port
>>>> number revsql01.revonet.local - TCP/IP - pointed to the SQL IP
>>>> address, dynamic port number
>>>>
>>>> My connect string is "Provider=SQLOLEDB;Data
>>>> Source=revsql01.revonet.local;Initial Catalog=RPM;User
>>>> ID=rpmuser;Password=xxxxx"
>>>
>>> Is it running on port 1433, or another port?

--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap so
I don't check it very often. If you must reply off-line, then remove
the "NO SPAM"


--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap so I
don't check it very often. If you must reply off-line, then remove the
"NO SPAM"

Jul 21 '05 #21

P: n/a
I've done that. Also made an ASP page that used the same connect string in
a loop to open & close the connection 250k times, and can't reproduce the
error. All I know is that every connection uses the same connect string
(application variable in asp), and that the errors are sporadic, but
continue to happen on a daily basis, no matter what I change.

Scott

"Mark Schupp" <no****@nospam.com> wrote in message
news:%2****************@tk2msftngp13.phx.gbl...
What happens if you put the code that opens the connection into a .vbs
file
and run it from a command prompt when logged on as administrator on the
server?

Have you worked through all of the variations at
http://www.able-consulting.com/MDAC/...erForSQLServer

--
Mark Schupp
Head of Development
Integrity eLearning
www.ielearning.com
"Scott Ivey" <si***@online.nospam> wrote in message
news:eH**************@TK2MSFTNGP10.phx.gbl...
I've tried that, but it didn't help. I've also used the Client Network
Utility to force TCP/IP, but that didn't help either.
Scott

"Bob Barrows [MVP]" <re******@NOyahoo.SPAMcom> wrote in message
news:OQ**************@TK2MSFTNGP09.phx.gbl...
> You should try forcing TCP/IP to be used with the Network Library
> attribute in your connection string.:
>
> Network Library=DBMSSOCN;"
>
> Bob Barrows
>
> Scott Ivey wrote:
>> I changed the connect string to use the IP address - and still get the
>> errors. I don't get it - this just should not be happening. New
>> connect string is...
>>
>> "Provider=SQLOLEDB;Data Source=192.168.200.40;Initial Catalog=RPM;User
>> ID=rpmuser;Password=xxxxx"
>>
>>
>> MS - are you watching this post??? I'm posting with my MSDN alias -
>> and we're now at the deadline for resolution for my MSDN Managed
>> Newsgroup support. I had opened a support incident before posting
>> this, but had opened it with the Cluster group (since the website is
>> on 2 servers running NLBS), and they were unable to help me, so I
>> cancelled the ticket. Anyone have any ideas on which group should
>> handle this?
>>
>> Thanks,
>> Scott
>>
>>
>>
>>
>> "Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
>> news:uc**************@TK2MSFTNGP14.phx.gbl...
>>> Have you tried connecting with a different user name? And/or using
>>> the shorter server name (not sure what you're gaining from
>>> revsql01.revonet.local, unless you're trying to practice your typing
>>> skills)? And/or using the IP address in the connection string?
>>>
>>> --
>>> http://www.aspfaq.com/
>>> (Reverse address to reply.)
>>>
>>>
>>>
>>>
>>> "Scott Ivey" <si***@online.nospam> wrote in message
>>> news:et**************@TK2MSFTNGP12.phx.gbl...
>>>> I haven't changed anything from the default, so yes.
>>>>
>>>> Scott
>>>>
>>>> "Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
>>>> news:u1**************@TK2MSFTNGP12.phx.gbl...
>>>>>> revsql01 - TCP/IP - pointed to the SQL IP address, dynamic port
>>>>>> number revsql01.revonet.local - TCP/IP - pointed to the SQL IP
>>>>>> address, dynamic port number
>>>>>>
>>>>>> My connect string is "Provider=SQLOLEDB;Data
>>>>>> Source=revsql01.revonet.local;Initial Catalog=RPM;User
>>>>>> ID=rpmuser;Password=xxxxx"
>>>>>
>>>>> Is it running on port 1433, or another port?
>
> --
> Microsoft MVP - ASP/ASP.NET
> Please reply to the newsgroup. This email account is my spam trap so I
> don't check it very often. If you must reply off-line, then remove the
> "NO SPAM"
>



Jul 21 '05 #22

P: n/a
Did I maybe do this wrong? I'm thinking it should be...

"Provider=SQLOLEDB;Data Source=revsql01;Address=192.168.200.40,1433;Initia l
Catalog=RPM;User ID=rpmuser;Password=xxxxx"

Does anyone think this will make any difference?

Scott
"Scott Ivey" <si***@online.nospam> wrote in message
news:uZ**************@TK2MSFTNGP14.phx.gbl...
I changed the connect string to use the IP address - and still get the
errors. I don't get it - this just should not be happening. New connect
string is...

"Provider=SQLOLEDB;Data Source=192.168.200.40;Initial Catalog=RPM;User
ID=rpmuser;Password=xxxxx"
MS - are you watching this post??? I'm posting with my MSDN alias - and
we're now at the deadline for resolution for my MSDN Managed Newsgroup
support. I had opened a support incident before posting this, but had
opened it with the Cluster group (since the website is on 2 servers
running NLBS), and they were unable to help me, so I cancelled the ticket.
Anyone have any ideas on which group should handle this?
Thanks,
Scott


"Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
news:uc**************@TK2MSFTNGP14.phx.gbl...
Have you tried connecting with a different user name? And/or using the
shorter server name (not sure what you're gaining from
revsql01.revonet.local, unless you're trying to practice your typing
skills)? And/or using the IP address in the connection string?

--
http://www.aspfaq.com/
(Reverse address to reply.)


"Scott Ivey" <si***@online.nospam> wrote in message
news:et**************@TK2MSFTNGP12.phx.gbl...
I haven't changed anything from the default, so yes.

Scott

"Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
news:u1**************@TK2MSFTNGP12.phx.gbl...
>> revsql01 - TCP/IP - pointed to the SQL IP address, dynamic port
>> number
>> revsql01.revonet.local - TCP/IP - pointed to the SQL IP address,

dynamic
>> port number
>>
>> My connect string is "Provider=SQLOLEDB;Data
>> Source=revsql01.revonet.local;Initial Catalog=RPM;User
>> ID=rpmuser;Password=xxxxx"
>
> Is it running on port 1433, or another port?
>
>



Jul 21 '05 #23

P: n/a
anyone heard of this before? ADO will switch protocols on you...

http://support.microsoft.com/default...b;EN-US;328383

Scott

"Scott Ivey" <si***@online.nospam> wrote in message
news:eu**************@TK2MSFTNGP10.phx.gbl...
DBNETLIB is correct - that is the OLEDB compenent for SQL server, and is
used for TCP/IP connections - isn't it???

Scott

"Bob Barrows [MVP]" <re******@NOyahoo.SPAMcom> wrote in message
news:O3**************@TK2MSFTNGP09.phx.gbl...
Then I don't understand why you are seeing DBNETLIB in your error
statement...

Bob Barrows
Scott Ivey wrote:
I've tried that, but it didn't help. I've also used the Client
Network Utility to force TCP/IP, but that didn't help either.
Scott

"Bob Barrows [MVP]" <re******@NOyahoo.SPAMcom> wrote in message
news:OQ**************@TK2MSFTNGP09.phx.gbl...
You should try forcing TCP/IP to be used with the Network Library
attribute in your connection string.:

Network Library=DBMSSOCN;"

Bob Barrows

Scott Ivey wrote:
> I changed the connect string to use the IP address - and still get
> the errors. I don't get it - this just should not be happening. New
> connect string is...
>
> "Provider=SQLOLEDB;Data Source=192.168.200.40;Initial
> Catalog=RPM;User ID=rpmuser;Password=xxxxx"
>
>
> MS - are you watching this post??? I'm posting with my MSDN alias -
> and we're now at the deadline for resolution for my MSDN Managed
> Newsgroup support. I had opened a support incident before posting
> this, but had opened it with the Cluster group (since the website is
> on 2 servers running NLBS), and they were unable to help me, so I
> cancelled the ticket. Anyone have any ideas on which group should
> handle this?
>
> Thanks,
> Scott
>
>
>
>
> "Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
> news:uc**************@TK2MSFTNGP14.phx.gbl...
>> Have you tried connecting with a different user name? And/or using
>> the shorter server name (not sure what you're gaining from
>> revsql01.revonet.local, unless you're trying to practice your
>> typing skills)? And/or using the IP address in the connection
>> string? --
>> http://www.aspfaq.com/
>> (Reverse address to reply.)
>>
>>
>>
>>
>> "Scott Ivey" <si***@online.nospam> wrote in message
>> news:et**************@TK2MSFTNGP12.phx.gbl...
>>> I haven't changed anything from the default, so yes.
>>>
>>> Scott
>>>
>>> "Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
>>> news:u1**************@TK2MSFTNGP12.phx.gbl...
>>>>> revsql01 - TCP/IP - pointed to the SQL IP address, dynamic port
>>>>> number revsql01.revonet.local - TCP/IP - pointed to the SQL IP
>>>>> address, dynamic port number
>>>>>
>>>>> My connect string is "Provider=SQLOLEDB;Data
>>>>> Source=revsql01.revonet.local;Initial Catalog=RPM;User
>>>>> ID=rpmuser;Password=xxxxx"
>>>>
>>>> Is it running on port 1433, or another port?

--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap so
I don't check it very often. If you must reply off-line, then remove
the "NO SPAM"


--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap so I
don't check it very often. If you must reply off-line, then remove the
"NO SPAM"


Jul 21 '05 #24

P: n/a
If you were to pick a specific page would you be confident that it would
have errors within a reasonable time period (say 24 hours)?

If so, I would put an error trap around the open statement in a page, log
the error to a text file when it happens and retry opening the connection
after a short delay. If it is successful then log that re-try succeeded.

You can do a crude delay (this is a cpu-killer so only use it for
debugging).
t = timer() + 100
do while timer()<t
loop

--
Mark Schupp
Head of Development
Integrity eLearning
www.ielearning.com
"Scott Ivey" <si***@online.nospam> wrote in message
news:uY**************@TK2MSFTNGP12.phx.gbl...
I've done that. Also made an ASP page that used the same connect string in a loop to open & close the connection 250k times, and can't reproduce the
error. All I know is that every connection uses the same connect string
(application variable in asp), and that the errors are sporadic, but
continue to happen on a daily basis, no matter what I change.

Scott

"Mark Schupp" <no****@nospam.com> wrote in message
news:%2****************@tk2msftngp13.phx.gbl...
What happens if you put the code that opens the connection into a .vbs
file
and run it from a command prompt when logged on as administrator on the
server?

Have you worked through all of the variations at
http://www.able-consulting.com/MDAC/...erForSQLServer
--
Mark Schupp
Head of Development
Integrity eLearning
www.ielearning.com
"Scott Ivey" <si***@online.nospam> wrote in message
news:eH**************@TK2MSFTNGP10.phx.gbl...
I've tried that, but it didn't help. I've also used the Client Network
Utility to force TCP/IP, but that didn't help either.
Scott

"Bob Barrows [MVP]" <re******@NOyahoo.SPAMcom> wrote in message
news:OQ**************@TK2MSFTNGP09.phx.gbl...
> You should try forcing TCP/IP to be used with the Network Library
> attribute in your connection string.:
>
> Network Library=DBMSSOCN;"
>
> Bob Barrows
>
> Scott Ivey wrote:
>> I changed the connect string to use the IP address - and still get the >> errors. I don't get it - this just should not be happening. New
>> connect string is...
>>
>> "Provider=SQLOLEDB;Data Source=192.168.200.40;Initial Catalog=RPM;User >> ID=rpmuser;Password=xxxxx"
>>
>>
>> MS - are you watching this post??? I'm posting with my MSDN alias -
>> and we're now at the deadline for resolution for my MSDN Managed
>> Newsgroup support. I had opened a support incident before posting
>> this, but had opened it with the Cluster group (since the website is
>> on 2 servers running NLBS), and they were unable to help me, so I
>> cancelled the ticket. Anyone have any ideas on which group should
>> handle this?
>>
>> Thanks,
>> Scott
>>
>>
>>
>>
>> "Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
>> news:uc**************@TK2MSFTNGP14.phx.gbl...
>>> Have you tried connecting with a different user name? And/or using
>>> the shorter server name (not sure what you're gaining from
>>> revsql01.revonet.local, unless you're trying to practice your typing >>> skills)? And/or using the IP address in the connection string?
>>>
>>> --
>>> http://www.aspfaq.com/
>>> (Reverse address to reply.)
>>>
>>>
>>>
>>>
>>> "Scott Ivey" <si***@online.nospam> wrote in message
>>> news:et**************@TK2MSFTNGP12.phx.gbl...
>>>> I haven't changed anything from the default, so yes.
>>>>
>>>> Scott
>>>>
>>>> "Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
>>>> news:u1**************@TK2MSFTNGP12.phx.gbl...
>>>>>> revsql01 - TCP/IP - pointed to the SQL IP address, dynamic port
>>>>>> number revsql01.revonet.local - TCP/IP - pointed to the SQL IP
>>>>>> address, dynamic port number
>>>>>>
>>>>>> My connect string is "Provider=SQLOLEDB;Data
>>>>>> Source=revsql01.revonet.local;Initial Catalog=RPM;User
>>>>>> ID=rpmuser;Password=xxxxx"
>>>>>
>>>>> Is it running on port 1433, or another port?
>
> --
> Microsoft MVP - ASP/ASP.NET
> Please reply to the newsgroup. This email account is my spam trap so I > don't check it very often. If you must reply off-line, then remove the > "NO SPAM"
>



Jul 21 '05 #25

P: n/a
> Did I maybe do this wrong? I'm thinking it should be...

"Provider=SQLOLEDB;Data Source=revsql01;Address=192.168.200.40,1433;Initia l Catalog=RPM;User ID=rpmuser;Password=xxxxx"


Why do you have Data Source and Address different? Where did you get the
Address parameter (I've never used that with an OLEDB string)?

How about:

"Provider=SQLOLEDB;Data Source=192.168.200.40,1433;Initial Catalog=RPM;User
ID=rpmuser;Password=xxxxx"

A
Jul 21 '05 #26

P: n/a
I ran across the Address parameter on MS's support site in some articles. I
had never heard of that parameter either until researching this problem.
I've tried using the IP address as the data source, but that didn't cure my
problems.

Scott

"Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
news:u7*************@TK2MSFTNGP11.phx.gbl...
Did I maybe do this wrong? I'm thinking it should be...

"Provider=SQLOLEDB;Data

Source=revsql01;Address=192.168.200.40,1433;Initia l
Catalog=RPM;User ID=rpmuser;Password=xxxxx"


Why do you have Data Source and Address different? Where did you get the
Address parameter (I've never used that with an OLEDB string)?

How about:

"Provider=SQLOLEDB;Data Source=192.168.200.40,1433;Initial
Catalog=RPM;User
ID=rpmuser;Password=xxxxx"

A

Jul 21 '05 #27

P: n/a
I suspect this means that your server is not set up with the TCP/IP library.
You need to run SQL Server setup to verify this.

Bob Barrows
Scott Ivey wrote:
anyone heard of this before? ADO will switch protocols on you...

http://support.microsoft.com/default...b;EN-US;328383

Scott

"Scott Ivey" <si***@online.nospam> wrote in message
news:eu**************@TK2MSFTNGP10.phx.gbl...
DBNETLIB is correct - that is the OLEDB compenent for SQL server,
and is used for TCP/IP connections - isn't it???

Scott

"Bob Barrows [MVP]" <re******@NOyahoo.SPAMcom> wrote in message
news:O3**************@TK2MSFTNGP09.phx.gbl...
Then I don't understand why you are seeing DBNETLIB in your error
statement...

Bob Barrows
Scott Ivey wrote:
I've tried that, but it didn't help. I've also used the Client
Network Utility to force TCP/IP, but that didn't help either.
Scott

"Bob Barrows [MVP]" <re******@NOyahoo.SPAMcom> wrote in message
news:OQ**************@TK2MSFTNGP09.phx.gbl...
> You should try forcing TCP/IP to be used with the Network Library
> attribute in your connection string.:
>
> Network Library=DBMSSOCN;"
>
> Bob Barrows
>
> Scott Ivey wrote:
>> I changed the connect string to use the IP address - and still
>> get the errors. I don't get it - this just should not be
>> happening. New connect string is...
>>
>> "Provider=SQLOLEDB;Data Source=192.168.200.40;Initial
>> Catalog=RPM;User ID=rpmuser;Password=xxxxx"
>>
>>
>> MS - are you watching this post??? I'm posting with my MSDN
>> alias - and we're now at the deadline for resolution for my MSDN
>> Managed Newsgroup support. I had opened a support incident
>> before posting this, but had opened it with the Cluster group
>> (since the website is on 2 servers running NLBS), and they were
>> unable to help me, so I cancelled the ticket. Anyone have any
>> ideas on which group should handle this?
>>
>> Thanks,
>> Scott
>>
>>
>>
>>
>> "Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in
>> message news:uc**************@TK2MSFTNGP14.phx.gbl...
>>> Have you tried connecting with a different user name? And/or
>>> using the shorter server name (not sure what you're gaining from
>>> revsql01.revonet.local, unless you're trying to practice your
>>> typing skills)? And/or using the IP address in the connection
>>> string? --
>>> http://www.aspfaq.com/
>>> (Reverse address to reply.)
>>>
>>>
>>>
>>>
>>> "Scott Ivey" <si***@online.nospam> wrote in message
>>> news:et**************@TK2MSFTNGP12.phx.gbl...
>>>> I haven't changed anything from the default, so yes.
>>>>
>>>> Scott
>>>>
>>>> "Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in
>>>> message news:u1**************@TK2MSFTNGP12.phx.gbl...
>>>>>> revsql01 - TCP/IP - pointed to the SQL IP address, dynamic
>>>>>> port number revsql01.revonet.local - TCP/IP - pointed to the
>>>>>> SQL IP address, dynamic port number
>>>>>>
>>>>>> My connect string is "Provider=SQLOLEDB;Data
>>>>>> Source=revsql01.revonet.local;Initial Catalog=RPM;User
>>>>>> ID=rpmuser;Password=xxxxx"
>>>>>
>>>>> Is it running on port 1433, or another port?
>
> --
> Microsoft MVP - ASP/ASP.NET
> Please reply to the newsgroup. This email account is my spam trap
> so I don't check it very often. If you must reply off-line, then
> remove the "NO SPAM"

--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap
so I don't check it very often. If you must reply off-line, then
remove the "NO SPAM"


--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap so I
don't check it very often. If you must reply off-line, then remove the
"NO SPAM"
Jul 21 '05 #28

P: n/a
> t = timer() + 100
do while timer()<t
loop


Or if you can connect to a local SQL Server, you can connect and then call
WAITFOR DELAY '00:00:02' ... which can simulate a sleep() call in ASP.

A
Jul 21 '05 #29

P: n/a
We're using TCP/IP - and all of the connections are showing as TCP/IP thru
the enterprise manager. I just thought it was interesting that the newer
versions of ADO will actually try using Named Pipes if your initial TCP/IP
connection attempt returns any sort of error. I tried setting it up to do
this, but that didn't work either :(

Scott
"Bob Barrows [MVP]" <re******@NOyahoo.SPAMcom> wrote in message
news:%2****************@TK2MSFTNGP10.phx.gbl...
I suspect this means that your server is not set up with the TCP/IP
library. You need to run SQL Server setup to verify this.

Bob Barrows
Scott Ivey wrote:
anyone heard of this before? ADO will switch protocols on you...

http://support.microsoft.com/default...b;EN-US;328383

Scott

"Scott Ivey" <si***@online.nospam> wrote in message
news:eu**************@TK2MSFTNGP10.phx.gbl...
DBNETLIB is correct - that is the OLEDB compenent for SQL server,
and is used for TCP/IP connections - isn't it???

Scott

"Bob Barrows [MVP]" <re******@NOyahoo.SPAMcom> wrote in message
news:O3**************@TK2MSFTNGP09.phx.gbl...
Then I don't understand why you are seeing DBNETLIB in your error
statement...

Bob Barrows
Scott Ivey wrote:
> I've tried that, but it didn't help. I've also used the Client
> Network Utility to force TCP/IP, but that didn't help either.
>
>
> Scott
>
> "Bob Barrows [MVP]" <re******@NOyahoo.SPAMcom> wrote in message
> news:OQ**************@TK2MSFTNGP09.phx.gbl...
>> You should try forcing TCP/IP to be used with the Network Library
>> attribute in your connection string.:
>>
>> Network Library=DBMSSOCN;"
>>
>> Bob Barrows
>>
>> Scott Ivey wrote:
>>> I changed the connect string to use the IP address - and still
>>> get the errors. I don't get it - this just should not be
>>> happening. New connect string is...
>>>
>>> "Provider=SQLOLEDB;Data Source=192.168.200.40;Initial
>>> Catalog=RPM;User ID=rpmuser;Password=xxxxx"
>>>
>>>
>>> MS - are you watching this post??? I'm posting with my MSDN
>>> alias - and we're now at the deadline for resolution for my MSDN
>>> Managed Newsgroup support. I had opened a support incident
>>> before posting this, but had opened it with the Cluster group
>>> (since the website is on 2 servers running NLBS), and they were
>>> unable to help me, so I cancelled the ticket. Anyone have any
>>> ideas on which group should handle this?
>>>
>>> Thanks,
>>> Scott
>>>
>>>
>>>
>>>
>>> "Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in
>>> message news:uc**************@TK2MSFTNGP14.phx.gbl...
>>>> Have you tried connecting with a different user name? And/or
>>>> using the shorter server name (not sure what you're gaining from
>>>> revsql01.revonet.local, unless you're trying to practice your
>>>> typing skills)? And/or using the IP address in the connection
>>>> string? --
>>>> http://www.aspfaq.com/
>>>> (Reverse address to reply.)
>>>>
>>>>
>>>>
>>>>
>>>> "Scott Ivey" <si***@online.nospam> wrote in message
>>>> news:et**************@TK2MSFTNGP12.phx.gbl...
>>>>> I haven't changed anything from the default, so yes.
>>>>>
>>>>> Scott
>>>>>
>>>>> "Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in
>>>>> message news:u1**************@TK2MSFTNGP12.phx.gbl...
>>>>>>> revsql01 - TCP/IP - pointed to the SQL IP address, dynamic
>>>>>>> port number revsql01.revonet.local - TCP/IP - pointed to the
>>>>>>> SQL IP address, dynamic port number
>>>>>>>
>>>>>>> My connect string is "Provider=SQLOLEDB;Data
>>>>>>> Source=revsql01.revonet.local;Initial Catalog=RPM;User
>>>>>>> ID=rpmuser;Password=xxxxx"
>>>>>>
>>>>>> Is it running on port 1433, or another port?
>>
>> --
>> Microsoft MVP - ASP/ASP.NET
>> Please reply to the newsgroup. This email account is my spam trap
>> so I don't check it very often. If you must reply off-line, then
>> remove the "NO SPAM"

--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap
so I don't check it very often. If you must reply off-line, then
remove the "NO SPAM"


--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap so I
don't check it very often. If you must reply off-line, then remove the
"NO SPAM"

Jul 21 '05 #30

P: n/a
We're using TCP/IP - and all of the connections are showing as TCP/IP thru
the enterprise manager. I just thought it was interesting that the newer
versions of ADO will actually try using Named Pipes if your initial TCP/IP
connection attempt returns any sort of error. I tried setting it up to do
this, but that didn't work either :(

Scott
"Bob Barrows [MVP]" <re******@NOyahoo.SPAMcom> wrote in message
news:%2****************@TK2MSFTNGP10.phx.gbl...
I suspect this means that your server is not set up with the TCP/IP
library. You need to run SQL Server setup to verify this.

Bob Barrows
Scott Ivey wrote:
anyone heard of this before? ADO will switch protocols on you...

http://support.microsoft.com/default...b;EN-US;328383

Scott

"Scott Ivey" <si***@online.nospam> wrote in message
news:eu**************@TK2MSFTNGP10.phx.gbl...
DBNETLIB is correct - that is the OLEDB compenent for SQL server,
and is used for TCP/IP connections - isn't it???

Scott

"Bob Barrows [MVP]" <re******@NOyahoo.SPAMcom> wrote in message
news:O3**************@TK2MSFTNGP09.phx.gbl...
Then I don't understand why you are seeing DBNETLIB in your error
statement...

Bob Barrows
Scott Ivey wrote:
> I've tried that, but it didn't help. I've also used the Client
> Network Utility to force TCP/IP, but that didn't help either.
>
>
> Scott
>
> "Bob Barrows [MVP]" <re******@NOyahoo.SPAMcom> wrote in message
> news:OQ**************@TK2MSFTNGP09.phx.gbl...
>> You should try forcing TCP/IP to be used with the Network Library
>> attribute in your connection string.:
>>
>> Network Library=DBMSSOCN;"
>>
>> Bob Barrows
>>
>> Scott Ivey wrote:
>>> I changed the connect string to use the IP address - and still
>>> get the errors. I don't get it - this just should not be
>>> happening. New connect string is...
>>>
>>> "Provider=SQLOLEDB;Data Source=192.168.200.40;Initial
>>> Catalog=RPM;User ID=rpmuser;Password=xxxxx"
>>>
>>>
>>> MS - are you watching this post??? I'm posting with my MSDN
>>> alias - and we're now at the deadline for resolution for my MSDN
>>> Managed Newsgroup support. I had opened a support incident
>>> before posting this, but had opened it with the Cluster group
>>> (since the website is on 2 servers running NLBS), and they were
>>> unable to help me, so I cancelled the ticket. Anyone have any
>>> ideas on which group should handle this?
>>>
>>> Thanks,
>>> Scott
>>>
>>>
>>>
>>>
>>> "Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in
>>> message news:uc**************@TK2MSFTNGP14.phx.gbl...
>>>> Have you tried connecting with a different user name? And/or
>>>> using the shorter server name (not sure what you're gaining from
>>>> revsql01.revonet.local, unless you're trying to practice your
>>>> typing skills)? And/or using the IP address in the connection
>>>> string? --
>>>> http://www.aspfaq.com/
>>>> (Reverse address to reply.)
>>>>
>>>>
>>>>
>>>>
>>>> "Scott Ivey" <si***@online.nospam> wrote in message
>>>> news:et**************@TK2MSFTNGP12.phx.gbl...
>>>>> I haven't changed anything from the default, so yes.
>>>>>
>>>>> Scott
>>>>>
>>>>> "Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in
>>>>> message news:u1**************@TK2MSFTNGP12.phx.gbl...
>>>>>>> revsql01 - TCP/IP - pointed to the SQL IP address, dynamic
>>>>>>> port number revsql01.revonet.local - TCP/IP - pointed to the
>>>>>>> SQL IP address, dynamic port number
>>>>>>>
>>>>>>> My connect string is "Provider=SQLOLEDB;Data
>>>>>>> Source=revsql01.revonet.local;Initial Catalog=RPM;User
>>>>>>> ID=rpmuser;Password=xxxxx"
>>>>>>
>>>>>> Is it running on port 1433, or another port?
>>
>> --
>> Microsoft MVP - ASP/ASP.NET
>> Please reply to the newsgroup. This email account is my spam trap
>> so I don't check it very often. If you must reply off-line, then
>> remove the "NO SPAM"

--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap
so I don't check it very often. If you must reply off-line, then
remove the "NO SPAM"


--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap so I
don't check it very often. If you must reply off-line, then remove the
"NO SPAM"

Jul 22 '05 #31

P: n/a
HI Scott,

We have been battling the EXACT same problem for over 1 year now - our huge
app works perfectly on Windows 2000 server, but after moving same app to
Windows 2003, we every few hours or maybe more, suddenly gets hundreds of
script errors (we log all errors to central database), with the same error
as you :

[DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access
denied.

I am running my app on HP DL380 server, on a HP ProCurve switched network,
and all other applications, running on the same networks, has NO errors, so
I think we can leave network connectivity out of the question.

I have had Microsoft Consulting Services on this case, and they helped
setting up the correct connectionstring, when moving to Windows 2003, but
that did not remove the errors.

It really seems like a generel error, which has nothing to do with our code
???

Please let me know, if you ever solve the problem - we have had this very
frustrating error for over 1 year now!!!
Regards,
Tony Fonager, Denmark

"Scott Ivey" <si***@online.nospam> wrote in message
news:u2**************@TK2MSFTNGP09.phx.gbl...
The strange thing about it all is that when I copy the entire web
directory, including any connection strings, back to my win2000 server,
everything works fine - no errors ever.
Scott

Jul 22 '05 #32

P: n/a
Scott,

Yes, that is exactly the same way we have this error.

It is SO frustrating ... and at the same time, my other ASP apps (on Windows
2000) continues without any single connection error, using the same SQL
database on the same network!
Regards,
Tony Fonager, Denmark

"Scott Ivey" <si***@online.nospam> wrote in message
news:uY**************@TK2MSFTNGP12.phx.gbl...
I've done that. Also made an ASP page that used the same connect string
in a loop to open & close the connection 250k times, and can't reproduce
the error. All I know is that every connection uses the same connect
string (application variable in asp), and that the errors are sporadic,
but continue to happen on a daily basis, no matter what I change.

Scott

Jul 22 '05 #33

P: n/a
oj
Have you looked at this kb:
http://support.microsoft.com/default...b;en-us;328306

"Tony Fonager" <to**@dontspammeonthisemailadress-fonager.dk> wrote in
message news:eT**************@TK2MSFTNGP09.phx.gbl...
Scott,

Yes, that is exactly the same way we have this error.

It is SO frustrating ... and at the same time, my other ASP apps (on
Windows 2000) continues without any single connection error, using the
same SQL database on the same network!
Regards,
Tony Fonager, Denmark

"Scott Ivey" <si***@online.nospam> wrote in message
news:uY**************@TK2MSFTNGP12.phx.gbl...
I've done that. Also made an ASP page that used the same connect string
in a loop to open & close the connection 250k times, and can't reproduce
the error. All I know is that every connection uses the same connect
string (application variable in asp), and that the errors are sporadic,
but continue to happen on a daily basis, no matter what I change.

Scott


Jul 22 '05 #34

This discussion thread is closed

Replies have been disabled for this discussion.