By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,200 Members | 1,629 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,200 IT Pros & Developers. It's quick & easy.

Sending email problem with Windows 2000 professional

P: n/a
I wrote an asp program to send email. I set SMTP as 127.0.0.1 and it worked
well in Windows 2000 server but not in Windows 2000 Professional. What is
different between server and professional. My code is below:

Set iMsg = Server.CreateObject("CDO.Message")
Set iConf = Server.CreateObject("CDO.Configuration")
Set Flds = iConf.Fields
Flds("cdoSendUsingMethod") = cdoSendUsingPort
Flds("cdoSMTPServer") = "127.0.0.1"
Flds("cdoSMTPServerPort") = 25
Flds("cdoSMTPAuthenticate") = cdoAnonymous ' 0
Flds.Update
With iMsg
Set .Configuration = iConf
.To = "wz****@hotmail.com"
.CC = "wz****@yahoo.com"
.From = "wz****@sympatico.ca"
.Subject = "Testing"
.TextBody = "Testing"
.Send
End With
Set iMsg=Nothing
Set iConf=Nothing
Set Flds=Nothing

Jul 19 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
127.0.0.1 is the loopback address of the local machine, meaning you're
saying Flds("cdoSMTPServer") = [This computer that is running this script.]

Do you have SMTP installed on this machine?
In what way does this "not work" for you? Do you get an error of some sort?
Is this machine authorized to relay mail in your network?

Ray at work

"Alex" <Al**@discussions.microsoft.com> wrote in message
news:0C**********************************@microsof t.com...
I wrote an asp program to send email. I set SMTP as 127.0.0.1 and it worked
well in Windows 2000 server but not in Windows 2000 Professional. What is
different between server and professional. My code is below:

Set iMsg = Server.CreateObject("CDO.Message")
Set iConf = Server.CreateObject("CDO.Configuration")
Set Flds = iConf.Fields
Flds("cdoSendUsingMethod") = cdoSendUsingPort
Flds("cdoSMTPServer") = "127.0.0.1"
Flds("cdoSMTPServerPort") = 25
Flds("cdoSMTPAuthenticate") = cdoAnonymous ' 0
Flds.Update
With iMsg
Set .Configuration = iConf
.To = "wz****@hotmail.com"
.CC = "wz****@yahoo.com"
.From = "wz****@sympatico.ca"
.Subject = "Testing"
.TextBody = "Testing"
.Send
End With
Set iMsg=Nothing
Set iConf=Nothing
Set Flds=Nothing

Jul 19 '05 #2

P: n/a
I installed IIS 5.0 and SMTP service. I could get the email when I ran this
asp in server and but I couldn't get it when I ran it in professional.
Actually I didn't get any errors and I don't know if it is authorized to
relay emails. But I could get emails if I ran asp.net program to send email
out.

Alex
"Ray Costanzo [MVP]" wrote:
127.0.0.1 is the loopback address of the local machine, meaning you're
saying Flds("cdoSMTPServer") = [This computer that is running this script.]

Do you have SMTP installed on this machine?
In what way does this "not work" for you? Do you get an error of some sort?
Is this machine authorized to relay mail in your network?

Ray at work

"Alex" <Al**@discussions.microsoft.com> wrote in message
news:0C**********************************@microsof t.com...
I wrote an asp program to send email. I set SMTP as 127.0.0.1 and it worked
well in Windows 2000 server but not in Windows 2000 Professional. What is
different between server and professional. My code is below:

Set iMsg = Server.CreateObject("CDO.Message")
Set iConf = Server.CreateObject("CDO.Configuration")
Set Flds = iConf.Fields
Flds("cdoSendUsingMethod") = cdoSendUsingPort
Flds("cdoSMTPServer") = "127.0.0.1"
Flds("cdoSMTPServerPort") = 25
Flds("cdoSMTPAuthenticate") = cdoAnonymous ' 0
Flds.Update
With iMsg
Set .Configuration = iConf
.To = "wz****@hotmail.com"
.CC = "wz****@yahoo.com"
.From = "wz****@sympatico.ca"
.Subject = "Testing"
.TextBody = "Testing"
.Send
End With
Set iMsg=Nothing
Set iConf=Nothing
Set Flds=Nothing


Jul 19 '05 #3

P: n/a
Is the e-mail still sitting in \inetpub\mailroot\queue? Take a look in the
application event log to see if relaying was denied. Did you setup a
smarthost or anything in your SMTP settings? If so, make sure the target
server allows relaying from your machine's IP.

Ray at work

"Alex" <Al**@discussions.microsoft.com> wrote in message
news:C7**********************************@microsof t.com...
I installed IIS 5.0 and SMTP service. I could get the email when I ran
this
asp in server and but I couldn't get it when I ran it in professional.
Actually I didn't get any errors and I don't know if it is authorized to
relay emails. But I could get emails if I ran asp.net program to send
email
out.

Alex
"Ray Costanzo [MVP]" wrote:
127.0.0.1 is the loopback address of the local machine, meaning you're
saying Flds("cdoSMTPServer") = [This computer that is running this
script.]

Do you have SMTP installed on this machine?
In what way does this "not work" for you? Do you get an error of some
sort?
Is this machine authorized to relay mail in your network?

Ray at work

"Alex" <Al**@discussions.microsoft.com> wrote in message
news:0C**********************************@microsof t.com...
>I wrote an asp program to send email. I set SMTP as 127.0.0.1 and it
>worked
> well in Windows 2000 server but not in Windows 2000 Professional. What
> is
> different between server and professional. My code is below:
>
> Set iMsg = Server.CreateObject("CDO.Message")
> Set iConf = Server.CreateObject("CDO.Configuration")
> Set Flds = iConf.Fields
> Flds("cdoSendUsingMethod") = cdoSendUsingPort
> Flds("cdoSMTPServer") = "127.0.0.1"
> Flds("cdoSMTPServerPort") = 25
> Flds("cdoSMTPAuthenticate") = cdoAnonymous ' 0
> Flds.Update
> With iMsg
> Set .Configuration = iConf
> .To = "wz****@hotmail.com"
> .CC = "wz****@yahoo.com"
> .From = "wz****@sympatico.ca"
> .Subject = "Testing"
> .TextBody = "Testing"
> .Send
> End With
> Set iMsg=Nothing
> Set iConf=Nothing
> Set Flds=Nothing
>


Jul 19 '05 #4

P: n/a
I didn't see any deny message in the appliaction log and i didn't setup
smarhost or other in my SMTP. I don't know why the target email server
disallow relaying from my computer. But it is different that my windows 2000
server has public IP but professional doesnt have.

Alex

"Ray Costanzo [MVP]" wrote:
Is the e-mail still sitting in \inetpub\mailroot\queue? Take a look in the
application event log to see if relaying was denied. Did you setup a
smarthost or anything in your SMTP settings? If so, make sure the target
server allows relaying from your machine's IP.

Ray at work

"Alex" <Al**@discussions.microsoft.com> wrote in message
news:C7**********************************@microsof t.com...
I installed IIS 5.0 and SMTP service. I could get the email when I ran
this
asp in server and but I couldn't get it when I ran it in professional.
Actually I didn't get any errors and I don't know if it is authorized to
relay emails. But I could get emails if I ran asp.net program to send
email
out.

Alex
"Ray Costanzo [MVP]" wrote:
127.0.0.1 is the loopback address of the local machine, meaning you're
saying Flds("cdoSMTPServer") = [This computer that is running this
script.]

Do you have SMTP installed on this machine?
In what way does this "not work" for you? Do you get an error of some
sort?
Is this machine authorized to relay mail in your network?

Ray at work

"Alex" <Al**@discussions.microsoft.com> wrote in message
news:0C**********************************@microsof t.com...
>I wrote an asp program to send email. I set SMTP as 127.0.0.1 and it
>worked
> well in Windows 2000 server but not in Windows 2000 Professional. What
> is
> different between server and professional. My code is below:
>
> Set iMsg = Server.CreateObject("CDO.Message")
> Set iConf = Server.CreateObject("CDO.Configuration")
> Set Flds = iConf.Fields
> Flds("cdoSendUsingMethod") = cdoSendUsingPort
> Flds("cdoSMTPServer") = "127.0.0.1"
> Flds("cdoSMTPServerPort") = 25
> Flds("cdoSMTPAuthenticate") = cdoAnonymous ' 0
> Flds.Update
> With iMsg
> Set .Configuration = iConf
> .To = "wz****@hotmail.com"
> .CC = "wz****@yahoo.com"
> .From = "wz****@sympatico.ca"
> .Subject = "Testing"
> .TextBody = "Testing"
> .Send
> End With
> Set iMsg=Nothing
> Set iConf=Nothing
> Set Flds=Nothing
>


Jul 19 '05 #5

P: n/a
Well, when you an admin who is at least not totally incompetent, he will not
allow relaying from any IP but those he explicitly specifies. So, chances
are the e-mail is being denied by your Internet-outbound SMTP server. Ask
your admin if SMTP relaying is permitted by your inhouse SMTP server -
perhaps your Exchange server.

Ray at home

"Alex" <Al**@discussions.microsoft.com> wrote in message
news:6D**********************************@microsof t.com...
I didn't see any deny message in the appliaction log and i didn't setup
smarhost or other in my SMTP. I don't know why the target email server
disallow relaying from my computer. But it is different that my windows
2000
server has public IP but professional doesnt have.

Alex

"Ray Costanzo [MVP]" wrote:
Is the e-mail still sitting in \inetpub\mailroot\queue? Take a look in
the
application event log to see if relaying was denied. Did you setup a
smarthost or anything in your SMTP settings? If so, make sure the target
server allows relaying from your machine's IP.

Ray at work

"Alex" <Al**@discussions.microsoft.com> wrote in message
news:C7**********************************@microsof t.com...
>I installed IIS 5.0 and SMTP service. I could get the email when I ran
>this
> asp in server and but I couldn't get it when I ran it in professional.
> Actually I didn't get any errors and I don't know if it is authorized
> to
> relay emails. But I could get emails if I ran asp.net program to send
> email
> out.
>
> Alex
>
>
> "Ray Costanzo [MVP]" wrote:
>
>> 127.0.0.1 is the loopback address of the local machine, meaning you're
>> saying Flds("cdoSMTPServer") = [This computer that is running this
>> script.]
>>
>> Do you have SMTP installed on this machine?
>> In what way does this "not work" for you? Do you get an error of some
>> sort?
>> Is this machine authorized to relay mail in your network?
>>
>> Ray at work
>>
>> "Alex" <Al**@discussions.microsoft.com> wrote in message
>> news:0C**********************************@microsof t.com...
>> >I wrote an asp program to send email. I set SMTP as 127.0.0.1 and it
>> >worked
>> > well in Windows 2000 server but not in Windows 2000 Professional.
>> > What
>> > is
>> > different between server and professional. My code is below:
>> >
>> > Set iMsg = Server.CreateObject("CDO.Message")
>> > Set iConf = Server.CreateObject("CDO.Configuration")
>> > Set Flds = iConf.Fields
>> > Flds("cdoSendUsingMethod") = cdoSendUsingPort
>> > Flds("cdoSMTPServer") = "127.0.0.1"
>> > Flds("cdoSMTPServerPort") = 25
>> > Flds("cdoSMTPAuthenticate") = cdoAnonymous ' 0
>> > Flds.Update
>> > With iMsg
>> > Set .Configuration = iConf
>> > .To = "wz****@hotmail.com"
>> > .CC = "wz****@yahoo.com"
>> > .From = "wz****@sympatico.ca"
>> > .Subject = "Testing"
>> > .TextBody = "Testing"
>> > .Send
>> > End With
>> > Set iMsg=Nothing
>> > Set iConf=Nothing
>> > Set Flds=Nothing
>> >
>>
>>
>>


Jul 19 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.