468,510 Members | 1,712 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,510 developers. It's quick & easy.

Enter username and password for "" at http://localhost

Fuhrer
30
Hi ,i have installed the IIS server on my computer to work on a project(Asp).
I have used the I.E browser, then i decided to try my project on Firefox browser
but when i tried to open the project i got this prompt message:

Enter username and password for "" at http://localhost
User name:
Password:


what should i do to be able to open my project on firefox(same thing with Netscape and Opera browsers)

Thank u alll
Jan 20 '07 #1
14 90109
iam_clint
1,208 Expert 1GB
try http://127.0.0.1
Jan 22 '07 #2
Fuhrer
30
try http://127.0.0.1


I try it my friend and a popup window is opened asking me for my username and password.
What should i do?
Jan 22 '07 #3
ljnel
1
Hi ,i have installed the IIS server on my computer to work on a project(Asp).
I have used the I.E browser, then i decided to try my project on Firefox browser
but when i tried to open the project i got this prompt message:

Enter username and password for "" at http://localhost
User name:
Password:


what should i do to be able to open my project on firefox(same thing with Netscape and Opera browsers)

Thank u alll
Please tell me if you have been able to solve this problem - I'm battling with prompts for username and password when I try to publish to IIS.
Feb 7 '07 #4
Hello,
I was experiencing the same issue and found the following solution:
The Login Popup is due to a setting in your IE Browser.
In your IE Browser:
1. Go to the Top menu "Tools" -> "Internet Options".
2. Then choose the "Advanced" Tab.
3. Then Scroll all the way down and "Uncheck" the Checkbox corresponding to "Enable Integrated Windows Authentication".
4. Then Click the button that says "Apply" and then "OK".
5. Close the browser and in a new browser try http://localhost.
Feb 17 '07 #5
smonty
1
For the FIX, go to:
http://blogs.neudesic.com/blogs/pete_orologas/archive/2006/08/14/224.aspx?CommentPosted=true#commentmessage
Mar 16 '07 #6
I got the same thing happening.

But I don't use IE.

I use Firefox.

AND - there's this difference: I've got six different directories in my IIS inetpub directory for 6 diffferent web sites.

5 of them work fine.

Just one doesn't. Just one of them throws up the "Enter Username and password..." message.

So naturally I think it must have something to do with the index.html on that site, which I just this day downloaded from the site because my Inetpub dir was out of date because I'd been doing editing using my host's editing facilities. So the online page was more advanced than the Inetpub page. So I downloaded.

That is the only index.html that has been downloaded like that.

If I take one of the old index.html's in that dir, that have been renamed in the past indexmarch07.html, indexfeb08.html and so on - old versions that I just keep around I don't quite know why - then they work alright. They don't cause the error message to pop up.

So what's the problem?

Can anyone help?

regards,

ab :)
Apr 12 '08 #7
DrBunchman
979 Expert 512MB
You will be prompted for a username and password when you try to browse a website which hasn't been configured for anonymous access.To check the security settings do the following:

Open the IIS console (you can run inetmgr from the command line) , right click on the appropriate website/virtual directory, select <properties> and click on the directory security tab. If you click on <edit> you can see what sort of security the website is using. Select Anonymous Access and try to browse your site again. You may need to restart the IIS before any changes come into effect.

Does this help at all? Let me know.

Dr B
Apr 12 '08 #8
I was experiencing the same problem of asking to type username and passoword for http://localhost. try this solution as mentioned below :

1. Open firefox and type in the address bar about:config
2. type ntlm in the textbox.
3. Double click on network.automatic-ntlm-auth.trusted-uris and type localhost there.
4. Click on OK.

You are done.

Feedbacks appraised.
Dec 22 '09 #9
Hi. Thank you for the solution. I went to about:config and changed it localhost. Now it is working.
Feb 15 '10 #10
Hey...thanx for the solution...i went to about:config and immediately changed it...its working now... could you please tell me that how did u know this..i mean where can i read it from... thanx again....
Mar 25 '10 #11
I got the same problem.
And I had done by

Go to "Authentication Method" in Default Web Site in IIS
Check on "Integrated Windows Authenticaton"
Apply
and Refresh

It will not require username-password.
Let try!
May 21 '10 #12
I had similar problem: downloaded zip of phpMyAdmin, unzipped in the .htdocs root, created a basic config.inc.php file, and had one successful session. After that, I could not run phpMyAdmin because of the Windows password popup mentioned above. I did the IIS, Internet Options|Advanced| suggestion, and even went through Firefox. I deleted and re-unzipped the files twice.

Note that when I unzipped, I would get:<root>/phpMyAdmin-3.3.3-english/phpMyAdmin-3.3.3-english/

I would rename for simplicity:<root>/phpMyAdmin/phpMyAdmin/

I would be prompted for a password.

I finally renamed the folders to make it easier to track: <root>/phpMyAdmin1/phpMyAdmin2/

By renaming these folders with different names, it now works without a password prompt.

This reminds of lighting a candle to solve a problem. Any ideas of why this works?
Jun 9 '10 #13
I had the same problem and after reading this post and the subsequent replies..I got the solution..

But, what I didnt understand is, the IIS site which started asking for the username and password has been in place for the last 15-20 days on my computer (i have almost finished writing the webAPP i was working)..and it never asked for a username/password till today...why would it ask for a username and password after 15-20 days of being created?
Another weird thing i noticed was that a certain peice of HTML code which was working till today suddenly stopped working...i was using a <frameset> tag inside a <body> tag..which is technically incorrect..but the page was displaying properly all this time..today it suddenly went blank..and when i rectified that...boom!...it asked for username and password for localhost..is it possible that some upadte has been done to IIS or the chrome browser which suddenly made these changes? (i have not done any update myself)..can someone shed some light on this?
Oct 1 '10 #14
ya Its working i think this problem occur with firebox not with internet explorer so thanks a lot giving good solution
Oct 20 '10 #15

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

reply views Thread by yurps | last post: by
reply views Thread by Morgan Cheng | last post: by
18 posts views Thread by =?Utf-8?B?VG9t?= | last post: by
12 posts views Thread by Jonathan Wood | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.