469,323 Members | 1,560 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,323 developers. It's quick & easy.

ASP page can't post to IIS 5.0 Server

Hello,

We are trying to get an .asp page to post to an access
database. the page is viewable, and the form boxes can be
filled in. Upon submission of the data a confirmation
page is then to show.

What happens is the data is inserted into the page, but
upon submission an HTTP 500 Internal server error appears.

if we uncheck show friendly http errors in IE there is
still no more info to go on.

My question is then, where to begin?

I suspect perhaps a security setting, but which?

How to get more error info?

Any ideas are appreciated.

Regards

Hunter
Jul 19 '05 #1
5 1427
After unchecking friendly errors, what exactly do you see in your browser?
If you're truly seeing nothing of use, go into the IIS management console,
pull up the properties of your site or application, go to the Home Directory
tab, click the Configuration button under "Application Settings," go to the
App Debugging tab, and verify that "Send detailed ASP error messages to
client" radio button is selected.

Ray at work

"Hunter Pieper" <hu***********@yahoo.com> wrote in message
news:30****************************@phx.gbl...
Hello,

We are trying to get an .asp page to post to an access
database. the page is viewable, and the form boxes can be
filled in. Upon submission of the data a confirmation
page is then to show.

What happens is the data is inserted into the page, but
upon submission an HTTP 500 Internal server error appears.

if we uncheck show friendly http errors in IE there is
still no more info to go on.

My question is then, where to begin?

I suspect perhaps a security setting, but which?

How to get more error info?

Any ideas are appreciated.

Regards

Hunter

Jul 19 '05 #2
It only says:

HTTP 404 - File not found
Internet Information Services

Which really narrows it down.

Regards

Hunter

-----Original Message-----
After unchecking friendly errors, what exactly do you see in your browser?If you're truly seeing nothing of use, go into the IIS management console,pull up the properties of your site or application, go to the Home Directorytab, click the Configuration button under "Application Settings," go to theApp Debugging tab, and verify that "Send detailed ASP error messages toclient" radio button is selected.

Ray at work

"Hunter Pieper" <hu***********@yahoo.com> wrote in messagenews:30****************************@phx.gbl...
Hello,

We are trying to get an .asp page to post to an access
database. the page is viewable, and the form boxes can be filled in. Upon submission of the data a confirmation
page is then to show.

What happens is the data is inserted into the page, but
upon submission an HTTP 500 Internal server error appears.
if we uncheck show friendly http errors in IE there is
still no more info to go on.

My question is then, where to begin?

I suspect perhaps a security setting, but which?

How to get more error info?

Any ideas are appreciated.

Regards

Hunter

.

Jul 19 '05 #3
Your 500 error turns into a 404 after unchecking friendly errors? :| Are
you sure you have the URL right? What about a static .htm page in the same
directory? Create test.htm and test.asp in the same directory, with these
contents:

test.htm:
<html><body>I'm in test.htm</body></html>

test.asp:
Response.Write "<html><body>I'm in test.asp</body></html>"
Can you load either page?

Ray at work

"Hunter Pieper" <hu***********@yahoo.com> wrote in message
news:2f****************************@phx.gbl...
It only says:

HTTP 404 - File not found
Internet Information Services

Which really narrows it down.

Regards

Hunter

-----Original Message-----
After unchecking friendly errors, what exactly do you see

in your browser?
If you're truly seeing nothing of use, go into the IIS

management console,
pull up the properties of your site or application, go to

the Home Directory
tab, click the Configuration button under "Application

Settings," go to the
App Debugging tab, and verify that "Send detailed ASP

error messages to
client" radio button is selected.

Ray at work

"Hunter Pieper" <hu***********@yahoo.com> wrote in

message
news:30****************************@phx.gbl...
Hello,

We are trying to get an .asp page to post to an access
database. the page is viewable, and the form boxes can be filled in. Upon submission of the data a confirmation
page is then to show.

What happens is the data is inserted into the page, but
upon submission an HTTP 500 Internal server error appears.
if we uncheck show friendly http errors in IE there is
still no more info to go on.

My question is then, where to begin?

I suspect perhaps a security setting, but which?

How to get more error info?

Any ideas are appreciated.

Regards

Hunter

.

Jul 19 '05 #4
On Mon, 30 Aug 2004 15:06:44 -0700, "Hunter Pieper"
<hu***********@yahoo.com> wrote:
It only says:

HTTP 404 - File not found
Internet Information Services

Which really narrows it down.


It actually does. Since you had a 500 error and now it's a 404, then
the probl;em is now different. Check and see if the file is actually
there to be found by the account accessing it.

Then, when you get that fixed, repost the full error for the 500
error.

Jeff
-----Original Message-----
After unchecking friendly errors, what exactly do you see

in your browser?
If you're truly seeing nothing of use, go into the IIS

management console,
pull up the properties of your site or application, go to

the Home Directory
tab, click the Configuration button under "Application

Settings," go to the
App Debugging tab, and verify that "Send detailed ASP

error messages to
client" radio button is selected.

Ray at work

"Hunter Pieper" <hu***********@yahoo.com> wrote in

message
news:30****************************@phx.gbl...
Hello,

We are trying to get an .asp page to post to an access
database. the page is viewable, and the form boxes canbe filled in. Upon submission of the data a confirmation
page is then to show.

What happens is the data is inserted into the page, but
upon submission an HTTP 500 Internal server errorappears.
if we uncheck show friendly http errors in IE there is
still no more info to go on.

My question is then, where to begin?

I suspect perhaps a security setting, but which?

How to get more error info?

Any ideas are appreciated.

Regards

Hunter

.


Jul 19 '05 #5
I figured it out.

I had the URLScan asapi filter running. I had removed it
earlier in the day, but I had forgotten to restart the IIS
server.

It took a while for my brains to start working; so it was
later in the day when I finally remembered, to recheck the
URLScan log. At which time I noticed it was denying
access, and that a restart was necessary to get the
desired effect.

Damn.

Thanks for the help though, and sorry for the trouble.

Hunter


-----Original Message-----
Your 500 error turns into a 404 after unchecking friendly errors? :| Areyou sure you have the URL right? What about a static .htm page in the samedirectory? Create test.htm and test.asp in the same directory, with thesecontents:

test.htm:
<html><body>I'm in test.htm</body></html>

test.asp:
Response.Write "<html><body>I'm in test.asp</body></html>"
Can you load either page?

Ray at work

"Hunter Pieper" <hu***********@yahoo.com> wrote in messagenews:2f****************************@phx.gbl...
It only says:

HTTP 404 - File not found
Internet Information Services

Which really narrows it down.

Regards

Hunter

-----Original Message-----
After unchecking friendly errors, what exactly do you see
in your browser?
If you're truly seeing nothing of use, go into the IIS

management console,
pull up the properties of your site or application, go
to the Home Directory
tab, click the Configuration button under "Application

Settings," go to the
App Debugging tab, and verify that "Send detailed ASP

error messages to
client" radio button is selected.

Ray at work

"Hunter Pieper" <hu***********@yahoo.com> wrote in

message
news:30****************************@phx.gbl.. .
Hello,

We are trying to get an .asp page to post to an access
database. the page is viewable, and the form boxes
can be
filled in. Upon submission of the data a confirmation
page is then to show.

What happens is the data is inserted into the page,

but upon submission an HTTP 500 Internal server error

appears.

if we uncheck show friendly http errors in IE there is
still no more info to go on.

My question is then, where to begin?

I suspect perhaps a security setting, but which?

How to get more error info?

Any ideas are appreciated.

Regards

Hunter
.

.

Jul 19 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

6 posts views Thread by scottyman | last post: by
7 posts views Thread by GaryDean | last post: by
7 posts views Thread by Schmidty | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by suresh191 | last post: by
reply views Thread by Gurmeet2796 | last post: by
reply views Thread by harlem98 | last post: by
reply views Thread by listenups61195 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.