By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
446,267 Members | 1,808 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 446,267 IT Pros & Developers. It's quick & easy.

why is "Home Directory" grayed out in IIS Manager?

P: n/a
Ed
Hello All,

I posted earlier about a problem I was having with editing
or pasting/deleting files in the "Home Directory" of my
web server. I just noticed that the "Home Directory"
option in the "Home Directory" tab is grayed out. Why
would this be grayed out?

Would this be a configuration thing or a permissions
thing? I have an administrator account on this server
computer which I do development work on and is not
accessible outside the firewall of my company. However,
the I.T. dept maintains it (but I am the only user of this
machine). So is there some setting I need to set in IIS
manager to endable the "Home Directory" or do I need to
contact I.T.? Note: I can create virtual directories to
my heart's content. I just can't set the "Home
Directory". Any advice appreciated what I need to do to
enable the "Home Directory" option.

Thanks,
Ed
Jul 19 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
Ed
Sorry in advance if I sound like I was freaking out. So
on the website Identification window, I was infact able to
change the home directory of the identifier to a new "Home
directory". Now I don't have the problems I was having.
However, the old directory is still locked. Maybe it is
an NTFS thing. I can't delete anything from this old
directory. Is it a windows thing? or is the old "Home
Directory" still connected to IIS?

Thanks,
Ed

-----Original Message-----
Hello All,

I posted earlier about a problem I was having with editingor pasting/deleting files in the "Home Directory" of my
web server. I just noticed that the "Home Directory"
option in the "Home Directory" tab is grayed out. Why
would this be grayed out?

Would this be a configuration thing or a permissions
thing? I have an administrator account on this server
computer which I do development work on and is not
accessible outside the firewall of my company. However,
the I.T. dept maintains it (but I am the only user of thismachine). So is there some setting I need to set in IIS
manager to endable the "Home Directory" or do I need to
contact I.T.? Note: I can create virtual directories to
my heart's content. I just can't set the "Home
Directory". Any advice appreciated what I need to do to
enable the "Home Directory" option.

Thanks,
Ed
.

Jul 19 '05 #2

P: n/a
Did you stop & restart the IIS server after changing the home directory?

Ed wrote:
Sorry in advance if I sound like I was freaking out. So
on the website Identification window, I was infact able to
change the home directory of the identifier to a new "Home
directory". Now I don't have the problems I was having.
However, the old directory is still locked. Maybe it is
an NTFS thing. I can't delete anything from this old
directory. Is it a windows thing? or is the old "Home
Directory" still connected to IIS?

Thanks,
Ed
-----Original Message-----
Hello All,

I posted earlier about a problem I was having with


editing
or pasting/deleting files in the "Home Directory" of my
web server. I just noticed that the "Home Directory"
option in the "Home Directory" tab is grayed out. Why
would this be grayed out?

Would this be a configuration thing or a permissions
thing? I have an administrator account on this server
computer which I do development work on and is not
accessible outside the firewall of my company. However,
the I.T. dept maintains it (but I am the only user of


this
machine). So is there some setting I need to set in IIS
manager to endable the "Home Directory" or do I need to
contact I.T.? Note: I can create virtual directories to
my heart's content. I just can't set the "Home
Directory". Any advice appreciated what I need to do to
enable the "Home Directory" option.

Thanks,
Ed
.


Jul 19 '05 #3

P: n/a
Ed
No. I rebooted the whole machine (mouse wasn't
clicking). Then I reset security on the old directory. I
was now able to delete everything.

When you reboot the computer does that also stop and
restart IIS? I did stop and restart IIS before I created
the new Home Directory. I was still having the same
problems. I really have to face the fact that I am still
a beginner with IIS. I had a class in IIS several years
ago (IIS4). But I learn the most by fooling around with
it.

Thanks for the reply,
Ed

-----Original Message-----
Did you stop & restart the IIS server after changing the home directory?
Ed wrote:
Sorry in advance if I sound like I was freaking out. So on the website Identification window, I was infact able to change the home directory of the identifier to a new "Home directory". Now I don't have the problems I was having. However, the old directory is still locked. Maybe it is an NTFS thing. I can't delete anything from this old
directory. Is it a windows thing? or is the old "Home
Directory" still connected to IIS?

Thanks,
Ed
-----Original Message-----
Hello All,

I posted earlier about a problem I was having with


editing
or pasting/deleting files in the "Home Directory" of my
web server. I just noticed that the "Home Directory"
option in the "Home Directory" tab is grayed out. Why
would this be grayed out?

Would this be a configuration thing or a permissions
thing? I have an administrator account on this server
computer which I do development work on and is not
accessible outside the firewall of my company. However,the I.T. dept maintains it (but I am the only user of


this
machine). So is there some setting I need to set in IISmanager to endable the "Home Directory" or do I need to
contact I.T.? Note: I can create virtual directories tomy heart's content. I just can't set the "Home
Directory". Any advice appreciated what I need to do toenable the "Home Directory" option.

Thanks,
Ed
.


.

Jul 19 '05 #4

P: n/a
Well a system reboot would stop the service at shutdown & restart it
after the system starts coming up. I'm not sure at his point.

Ed wrote:
No. I rebooted the whole machine (mouse wasn't
clicking). Then I reset security on the old directory. I
was now able to delete everything.

When you reboot the computer does that also stop and
restart IIS? I did stop and restart IIS before I created
the new Home Directory. I was still having the same
problems. I really have to face the fact that I am still
a beginner with IIS. I had a class in IIS several years
ago (IIS4). But I learn the most by fooling around with
it.

Thanks for the reply,
Ed
-----Original Message-----
Did you stop & restart the IIS server after changing the


home directory?
Ed wrote:

Sorry in advance if I sound like I was freaking out.
So
on the website Identification window, I was infact able
to
change the home directory of the identifier to a
new "Home
directory". Now I don't have the problems I was
having.
However, the old directory is still locked. Maybe it
is
an NTFS thing. I can't delete anything from this old
directory. Is it a windows thing? or is the old "Home
Directory" still connected to IIS?

Thanks,
Ed


-----Original Message-----
Hello All,

I posted earlier about a problem I was having with

editing
or pasting/deleting files in the "Home Directory" of my
web server. I just noticed that the "Home Directory"
option in the "Home Directory" tab is grayed out. Why
would this be grayed out?

Would this be a configuration thing or a permissions
thing? I have an administrator account on this server
computer which I do development work on and is not
accessible outside the firewall of my company.
However,
the I.T. dept maintains it (but I am the only user of

this
machine). So is there some setting I need to set in
IIS
manager to endable the "Home Directory" or do I need to
contact I.T.? Note: I can create virtual directories
to
my heart's content. I just can't set the "Home
Directory". Any advice appreciated what I need to do
to
enable the "Home Directory" option.

Thanks,
Ed
.


.


Jul 19 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.