By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
426,083 Members | 1,608 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 426,083 IT Pros & Developers. It's quick & easy.

Cookies not working in japanese vitual folder.

P: n/a
I created an asp page that writes to cookies and copied it to a japanese virtual folder.

The cookie writing code is below.

first.asp
var sUserId = new String();
var sPassword = new String();
var cCookieExpiryDate = "December 31, 2010";

sUserId = "manjunatha";
sPassword = "password";

Response.Cookies("ERMSUserId") = sUserId;
Response.Cookies("ERMSPassword") = sPassword;
Response.Cookies("ERMSUserId").Expires = cCookieExpiryDate;
Response.Cookies("ERMSPassword").Expires = cCookieExpiryDate;

Created another page in the same virtual folder which displays the values of the cookies.
The cookie reading code is below

second.asp
Response.Write("User Id : " + Request.Cookies("ERMSUserId"));
Response.Write("Password : " + Request.Cookies("ERMSPassword"));

I executed the first.asp and later executed second.asp. The second.asp didn't display the cookie values i have written in first.asp.
I gave an English name to the virtual folder and repeated the same process again. This time it displayed cookie values.

Can anybody tell me what is the problem and suggest a solution.

Regards,
Manjunatha
Jul 19 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.