469,271 Members | 1,466 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,271 developers. It's quick & easy.

ASP mail IIS server

Hi all...
Could anyone please tell me how to use ASP to send mail from my local web
server (using IIS on wWindowsXP-pro)? what are the necessary setting needed
in IIS to enable mail sending? and how can i send mail?? I tried many web
sited but the codes I get simply dont work at all!!! I am really going nuts
here!
thanks
Jul 19 '05 #1
8 3138
On Thu, 17 Jun 2004 19:23:25 GMT, "Ammar" <am**********@comhem.se>
wrote:
Hi all...
Could anyone please tell me how to use ASP to send mail from my local web
server (using IIS on wWindowsXP-pro)?
That would be a FAQ:

http://www.aspfaq.com/show.asp?id=2119
what are the necessary setting needed
in IIS to enable mail sending?
That depends on the method. See the FAQ above.
and how can i send mail??
See the FAQ.
I tried many web
sited but the codes I get simply dont work at all!!!
Could be you're low on SMTP fluid in your IIS server. Make sure you
don't add "STP" it's a lower grade and only works with three letter
acronyms.

Or maybe that's not it at all. Hard to tell from the extensive
symptoms and error messages you've posted.
I am really going nuts
here!


Most of us have been nuts for years.

Jeff
Jul 19 '05 #2

"Jeff Cochran" <je*********@zina.com> wrote in message
news:40****************@msnews.microsoft.com...
On Thu, 17 Jun 2004 19:23:25 GMT, "Ammar" <am**********@comhem.se>
wrote:
Hi all...
Could anyone please tell me how to use ASP to send mail from my local web
server (using IIS on wWindowsXP-pro)?


That would be a FAQ:

http://www.aspfaq.com/show.asp?id=2119
what are the necessary setting needed
in IIS to enable mail sending?


That depends on the method. See the FAQ above.
and how can i send mail??


See the FAQ.
I tried many web
sited but the codes I get simply dont work at all!!!


Could be you're low on SMTP fluid in your IIS server. Make sure you
don't add "STP" it's a lower grade and only works with three letter
acronyms.

Or maybe that's not it at all. Hard to tell from the extensive
symptoms and error messages you've posted.
I am really going nuts
here!


Most of us have been nuts for years.

Jeff


Thanks,
the way i understand it, is that i have to install a third party e-mail
software like JMail, but i was wondering, cant i send e mail from my local
IIS without a third party mail? i mean if i uppload my web page to an ASP
host that runs only IIS and no other softwares, how can i send e mails form
that server then??
Am i missing something here? maybe i am asking something very stupid or
basic but i am new to ASP
Ammar
Jul 19 '05 #3
"Ammar" <am**********@comhem.se> wrote in message
news:E7******************@newsb.telia.net...

"Jeff Cochran" <je*********@zina.com> wrote in message
news:40****************@msnews.microsoft.com...
On Thu, 17 Jun 2004 19:23:25 GMT, "Ammar" <am**********@comhem.se>
wrote:
Hi all...
Could anyone please tell me how to use ASP to send mail from my local webserver (using IIS on wWindowsXP-pro)?


That would be a FAQ:

http://www.aspfaq.com/show.asp?id=2119
what are the necessary setting needed
in IIS to enable mail sending?


That depends on the method. See the FAQ above.
and how can i send mail??


See the FAQ.
I tried many web
sited but the codes I get simply dont work at all!!!


Could be you're low on SMTP fluid in your IIS server. Make sure you
don't add "STP" it's a lower grade and only works with three letter
acronyms.

Or maybe that's not it at all. Hard to tell from the extensive
symptoms and error messages you've posted.
I am really going nuts
here!


Most of us have been nuts for years.

Jeff


Thanks,
the way i understand it, is that i have to install a third party e-mail
software like JMail,


No - you don't. Did you read the FAQ? Make sure you install the SMTP
service with IIS.

--
Tom Kaminski IIS MVP
http://www.microsoft.com/windowsserv...y/centers/iis/
http://mvp.support.microsoft.com/
http://www.iisfaq.com/
http://www.iistoolshed.com/ - tools, scripts, and utilities for running IIS
http://www.tryiis.com
Jul 19 '05 #4

"Tom Kaminski [MVP]" <tomk (A@T) mvps (D.O.T) org> wrote in message
news:ca*********@kcweb01.netnews.att.com...
"Ammar" <am**********@comhem.se> wrote in message
news:E7******************@newsb.telia.net...

"Jeff Cochran" <je*********@zina.com> wrote in message
news:40****************@msnews.microsoft.com...
On Thu, 17 Jun 2004 19:23:25 GMT, "Ammar" <am**********@comhem.se>
wrote:

>Hi all...
>Could anyone please tell me how to use ASP to send mail from my local web >server (using IIS on wWindowsXP-pro)?

That would be a FAQ:

http://www.aspfaq.com/show.asp?id=2119

>what are the necessary setting needed
>in IIS to enable mail sending?

That depends on the method. See the FAQ above.

>and how can i send mail??

See the FAQ.

>I tried many web
>sited but the codes I get simply dont work at all!!!

Could be you're low on SMTP fluid in your IIS server. Make sure you
don't add "STP" it's a lower grade and only works with three letter
acronyms.

Or maybe that's not it at all. Hard to tell from the extensive
symptoms and error messages you've posted.

>I am really going nuts
>here!

Most of us have been nuts for years.

Jeff
Thanks,
the way i understand it, is that i have to install a third party e-mail
software like JMail,


No - you don't. Did you read the FAQ? Make sure you install the SMTP
service with IIS.

--
Tom Kaminski IIS MVP
http://www.microsoft.com/windowsserv...y/centers/iis/
http://mvp.support.microsoft.com/
http://www.iisfaq.com/
http://www.iistoolshed.com/ - tools, scripts, and utilities for running

IIS http://www.tryiis.com

OK huys
finally i made it!! it is wonderful! i managed to send my first ASP mail!!
one thing left, i souldnt find how to send attachements through CDO (and NOT
CDONTS) obj. can anyone help
Thanks
Ammar

Jul 19 '05 #5

OK huys
finally i made it!! it is wonderful! i managed to send my first ASP mail!!
one thing left, i souldnt find how to send attachements through CDO (and

NOT CDONTS) obj. can anyone help
Thanks
Ammar

to explain more....
i used the .AddAttachment method, but i get an error all the time:

a.. Error Type:
CDO.Message.1 (0x800C000D)
The specified protocol is unknown.
/mail.asp, line 20

line 20 is:

.AddAttachment "c:\boot.ini"

i tried several file pathes with the same result...

what to do?

Ammar
Jul 19 '05 #6
"Ammar" wrote in message news:3u********************@newsc.telia.net...
:
: > >
: > >
: > OK huys
: > finally i made it!! it is wonderful! i managed to send my first ASP
mail!!
: > one thing left, i souldnt find how to send attachements through CDO (and
: NOT
: > CDONTS) obj. can anyone help
: > Thanks
: > Ammar
: >
: to explain more....
: i used the .AddAttachment method, but i get an error all the time:
:
: a.. Error Type:
: CDO.Message.1 (0x800C000D)
: The specified protocol is unknown.
: /mail.asp, line 20
:
: line 20 is:
:
: .AddAttachment "c:\boot.ini"
:
: i tried several file pathes with the same result...
:
: what to do?

Why are you trying to attach your boot.ini file which is read-only, hidden
and system attributed?

--
Roland Hall
/* This information is distributed in the hope that it will be useful, but
without any warranty; without even the implied warranty of merchantability
or fitness for a particular purpose. */
Technet Script Center - http://www.microsoft.com/technet/scriptcenter/
WSH 5.6 Documentation - http://msdn.microsoft.com/downloads/list/webdev.asp
MSDN Library - http://msdn.microsoft.com/library/default.asp
Jul 19 '05 #7
On Thu, 17 Jun 2004 20:26:12 GMT, "Ammar" <am**********@comhem.se>
wrote:

"Jeff Cochran" <je*********@zina.com> wrote in message
news:40****************@msnews.microsoft.com...
On Thu, 17 Jun 2004 19:23:25 GMT, "Ammar" <am**********@comhem.se>
wrote:
>Hi all...
>Could anyone please tell me how to use ASP to send mail from my local web
>server (using IIS on wWindowsXP-pro)?
That would be a FAQ:

http://www.aspfaq.com/show.asp?id=2119
>what are the necessary setting needed
>in IIS to enable mail sending?


That depends on the method. See the FAQ above.
>and how can i send mail??


See the FAQ.
>I tried many web
>sited but the codes I get simply dont work at all!!!


Could be you're low on SMTP fluid in your IIS server. Make sure you
don't add "STP" it's a lower grade and only works with three letter
acronyms.

Or maybe that's not it at all. Hard to tell from the extensive
symptoms and error messages you've posted.
>I am really going nuts
>here!


Most of us have been nuts for years.

Jeff


Thanks,
the way i understand it, is that i have to install a third party e-mail
software like JMail, but i was wondering, cant i send e mail from my local
IIS without a third party mail?


Did you actually read the FAQ?

The first two sentences:

"There are several components that enable you to do this. You may
already have one, if you have an SMTP server installed alongside IIS -
it's called CDO.Message."

So, you don't need a third party email component like JMail.
i mean if i uppload my web page to an ASP
host that runs only IIS and no other softwares, how can i send e mails form
that server then??
Via whatever method that host supports.
Am i missing something here? maybe i am asking something very stupid or
basic but i am new to ASP


It's not stupid, but if you're uploading to a host you can't control,
you need to use whatever method that host has available for sending
email. If you can install components, then you can use a third party
component if you wish. Read the FAQ and look at the options listed.

Jeff
Jul 19 '05 #8
On Thu, 17 Jun 2004 21:58:23 GMT, "Ammar" <am**********@comhem.se>
wrote:
>
>

OK huys
finally i made it!! it is wonderful! i managed to send my first ASP mail!!
one thing left, i souldnt find how to send attachements through CDO (and

NOT
CDONTS) obj. can anyone help
Thanks
Ammar

to explain more....
i used the .AddAttachment method, but i get an error all the time:

a.. Error Type:
CDO.Message.1 (0x800C000D)
The specified protocol is unknown.
/mail.asp, line 20

line 20 is:

.AddAttachment "c:\boot.ini"

i tried several file pathes with the same result...

what to do?


Try a sample text file, in the web folder itself. Not a hidden,
read-only file on a drive the IUSR account may not have access to
(shouldn't have at least).

Also, Google for "ASP CDO Attachment" and you'll find examples of
specific code.

Jeff
Jul 19 '05 #9

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

5 posts views Thread by Charlie | last post: by
34 posts views Thread by antonyliu2002 | last post: by
8 posts views Thread by Robert Dufour | last post: by
4 posts views Thread by =?Utf-8?B?UmljaA==?= | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by zhoujie | last post: by
reply views Thread by suresh191 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.