By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,537 Members | 1,471 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,537 IT Pros & Developers. It's quick & easy.

basic questions, can't browse Inetpub\wwwroot, can't dbl-click aspfile to open it

P: n/a
I just installed ASP after a couple of years of not using it, PWS Win 98 SE.

A couple of things are throwing me, and I can't remember whether these
worked in the past.

One is I can't double-click on an .asp file in my file explorer and have
it load in IE6. IE shows the page in the address bar, e.g.

C:\Inetpub\wwwroot\myweb\math.asp

but doesn't execute it. If I type it into the addressbar manually like
this, it executes fine:

http://localhost/myweb/math.asp

Also if I try to open a file from IE, selecting an .asp file ends up
displaying it in the address bar like this, and it doesn't execute:

C:\Inetpub\wwwroot\myweb\collectinfo.asp

And if I type this into the address bar of the browser, I don't see any
files or folders, just a blank page, even though I have checked the
checkboxes for Read, Access, Scripts in the Advanced section of my PWS
manager.

Any suggestions would be appreciated,
Mike

Jul 19 '05 #1
Share this Question
Share on Google+
6 Replies


P: n/a
> C:\Inetpub\wwwroot\myweb\math.asp

but doesn't execute it. If I type it into the addressbar manually like
this, it executes fine:

http://localhost/myweb/math.asp


Yes, note the difference. C:\ only opens the file; calling it via http://
is the only way to have the web server parse and execute the ASP code (C:\
doesn't involve a web server).

If you want ASP code to execute, you *MUST* call it via http://

--
http://www.aspfaq.com/
(Reverse address to reply.)
Jul 19 '05 #2

P: n/a
Aaron [SQL Server MVP] wrote:
C:\Inetpub\wwwroot\myweb\math.asp

but doesn't execute it. If I type it into the addressbar manually like
this, it executes fine:

http://localhost/myweb/math.asp


Yes, note the difference. C:\ only opens the file; calling it via http://
is the only way to have the web server parse and execute the ASP code (C:\
doesn't involve a web server).

If you want ASP code to execute, you *MUST* call it via http://


Yes, I was hoping I could just double-click on the file and IE would run
the script in it, but no go. I'm surprised there's not a registry
setting I can use to make this happen. Are there any fixes/workarounds
that you know of?

Thanks,
Mike

Jul 19 '05 #3

P: n/a
> Yes, I was hoping I could just double-click on the file and IE would run
the script in it, but no go. I'm surprised there's not a registry setting
I can use to make this happen. Are there any fixes/workarounds that you
know of?


YES! Open the browser, and type http://yourserver/yourfile.asp

--
http://www.aspfaq.com/
(Reverse address to reply.)
Jul 19 '05 #4

P: n/a
There is nothing to workaround. The behaviour is correct and easily
understood.

You might like a feature in the configuration for IIS though. Open
Administrative Tools > Internet Information Services. Navigate to the ASP
file you want. Right-click and choose Browse. Of course you could have just
typed the URL.

Paul

"Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
news:ub**************@TK2MSFTNGP10.phx.gbl...
Yes, I was hoping I could just double-click on the file and IE would run
the script in it, but no go. I'm surprised there's not a registry setting I can use to make this happen. Are there any fixes/workarounds that you
know of?


YES! Open the browser, and type http://yourserver/yourfile.asp

--
http://www.aspfaq.com/
(Reverse address to reply.)

Jul 19 '05 #5

P: n/a
Paul Baker [MVP, Windows - SDK] wrote:
There is nothing to workaround. The behaviour is correct and easily
understood.

You might like a feature in the configuration for IIS though. Open
Administrative Tools > Internet Information Services. Navigate to the ASP
file you want. Right-click and choose Browse. Of course you could have just
typed the URL.

Paul

"Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
news:ub**************@TK2MSFTNGP10.phx.gbl...
Yes, I was hoping I could just double-click on the file and IE would run
the script in it, but no go. I'm surprised there's not a registry
setting
I can use to make this happen. Are there any fixes/workarounds that you
know of?


YES! Open the browser, and type http://yourserver/yourfile.asp


Hi Paul,

I'm wondering why I can browse some of my asp folders but not all, maybe
you can straighten this out for me. I made a virtual directory where I
keep asp files and project folders:

http://localhost/myweb/ (C:\Inetpub\wwwroot\myweb)

I made a link to http://localhost/myweb/ in my browser (it shows in the
address bar correctly), and when I go to the folder using the link I
don't see any of the 173 files that reside there. If I type in a
sub-folder name, e.g.

http://localhost/myweb/dir

I can see and double-click on the files in the folder dir, their script
is executed, and I can browse any subfolders of the folder I typed in.
So I'm wondering why I can browse all of my subfolders but not my top
level virtual folder.

Web Sharing includes the folder /myweb for sharing, and it has Read,
Execute, and Scripts permissions. And in PWS 'Allow Directory Browsing'
is checked.

Thanks,
Mike



Jul 19 '05 #6

P: n/a
There is a setting in IIS called "Allow directory browsing"...

--
http://www.aspfaq.com/
(Reverse address to reply.)


"mscir" <ms***@fake.zzz> wrote in message
news:10*************@corp.supernews.com...
Paul Baker [MVP, Windows - SDK] wrote:
There is nothing to workaround. The behaviour is correct and easily
understood.

You might like a feature in the configuration for IIS though. Open
Administrative Tools > Internet Information Services. Navigate to the ASP file you want. Right-click and choose Browse. Of course you could have just typed the URL.

Paul

"Aaron [SQL Server MVP]" <te*****@dnartreb.noraa> wrote in message
news:ub**************@TK2MSFTNGP10.phx.gbl...
Yes, I was hoping I could just double-click on the file and IE would runthe script in it, but no go. I'm surprised there's not a registry


setting
I can use to make this happen. Are there any fixes/workarounds that you
know of?

YES! Open the browser, and type http://yourserver/yourfile.asp


Hi Paul,

I'm wondering why I can browse some of my asp folders but not all, maybe
you can straighten this out for me. I made a virtual directory where I
keep asp files and project folders:

http://localhost/myweb/ (C:\Inetpub\wwwroot\myweb)

I made a link to http://localhost/myweb/ in my browser (it shows in the
address bar correctly), and when I go to the folder using the link I
don't see any of the 173 files that reside there. If I type in a
sub-folder name, e.g.

http://localhost/myweb/dir

I can see and double-click on the files in the folder dir, their script
is executed, and I can browse any subfolders of the folder I typed in.
So I'm wondering why I can browse all of my subfolders but not my top
level virtual folder.

Web Sharing includes the folder /myweb for sharing, and it has Read,
Execute, and Scripts permissions. And in PWS 'Allow Directory Browsing'
is checked.

Thanks,
Mike



Jul 19 '05 #7

This discussion thread is closed

Replies have been disabled for this discussion.