By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,364 Members | 1,254 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,364 IT Pros & Developers. It's quick & easy.

Session Variables...

P: n/a
I am using Session variables in my ASP application. I have tested the
application on a Win2k professional and it works fine. When the same web
app is installed on a win2k advanced server from the client browser when the
app is accessed the session variable returns null inspite of a value being
already set. I have checked the IIS enable session state settings. When i
use the server machine as client and access the app as localhost then the
session variable has correct value.

How can this be solved? What other settings if any, need to be changed to
get it work.

Thanks,
RamG
Jul 19 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
http://www.aspfaq.com/show.asp?id=2157

--
Mark Schupp
Head of Development
Integrity eLearning
www.ielearning.com
"Microsoft" <so*****@everyone.com> wrote in message
news:%2****************@TK2MSFTNGP09.phx.gbl...
I am using Session variables in my ASP application. I have tested the
application on a Win2k professional and it works fine. When the same web
app is installed on a win2k advanced server from the client browser when the app is accessed the session variable returns null inspite of a value being
already set. I have checked the IIS enable session state settings. When i use the server machine as client and access the app as localhost then the
session variable has correct value.

How can this be solved? What other settings if any, need to be changed to
get it work.

Thanks,
RamG

Jul 19 '05 #2

P: n/a
check in IIS , is your virtual directory is "application" or not....

!mran Khan

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Jul 19 '05 #3

P: n/a
rwg
The browser can affect session state information. In order to maintain session information in the 'internet' zone, either "First Party Cookies" and/or "Always
allow session cookies" must be allowed in the Internet Explorer.
< In IE: Menu: Tools -> Internet Options for the Internet Options panel. Tab: Privacy, button: Advanced for the "Advanced Privacy Options dialog. >

These settings do not apply to the 'local intranet zone' where session information is maintained despite the options chosen here. This leads to the
IWOMDS ('It Works On My Desk Syndrome')

Other reasons for the loss of session information are:

* Session timeout. In ASP, this is an IIS setting. In ASPX, this is set in the web.config file for the application.

* If the IIS worker process fails for some reason, such as an application crash, a change or anti-virus touch of the global.asp file, the session information is
reset.

PRB: Session Data Is Lost When You Use ASP.NET InProc Session State Mode
http://support.microsoft.com/?id=324772

* If using a Web Garden, session state is not maintained from one processor to another processor in the garden.

IIS 6.0 Session State May Be Lost If You Use Web Gardens with ASP
http://support.microsoft.com/?id=822171

* Use of a Frameset where frame s point to seperate Web Sites can lose Session information due to P3P standards (Platform for Privacy Preferences)

PRB: Session Variables Are Lost If You Use FRAMESET in Internet Explorer
http://support.microsoft.com/?id=323752

* ASP.NET session management information
INFO: ASP.NET State Management Overview
http://support.microsoft.com/?id=307598
- and -
http://msdn.microsoft.com/library/de...ssionstate.asp

---
Why won't my session variables stick?
http://www.aspfaq.com/show.asp?id=2157

-rwg
This is what I think, not necessarily what is accurate!

--------------------
| From: "Microsoft" <so*****@everyone.com>
| Subject: Session Variables...
| Date: Wed, 10 Mar 2004 20:48:28 +0530
| Lines: 15
| X-Priority: 3
| X-MSMail-Priority: Normal
| X-Newsreader: Microsoft Outlook Express 6.00.2600.0000
| X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2600.0000
| Message-ID: <#c**************@TK2MSFTNGP09.phx.gbl>
| Newsgroups: microsoft.public.inetserver.asp.general
| NNTP-Posting-Host: 203.112.158.70
| Path: cpmsftngxa06.phx.gbl!TK2MSFTNGP08.phx.gbl!TK2MSFTN GP09.phx.gbl
| Xref: cpmsftngxa06.phx.gbl microsoft.public.inetserver.asp.general:267967
| X-Tomcat-NG: microsoft.public.inetserver.asp.general
|
| I am using Session variables in my ASP application. I have tested the
| application on a Win2k professional and it works fine. When the same web
| app is installed on a win2k advanced server from the client browser when the
| app is accessed the session variable returns null inspite of a value being
| already set. I have checked the IIS enable session state settings. When i
| use the server machine as client and access the app as localhost then the
| session variable has correct value.
|
| How can this be solved? What other settings if any, need to be changed to
| get it work.
|
| Thanks,
| RamG
|
|
|
Jul 19 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.