By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
429,251 Members | 2,727 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 429,251 IT Pros & Developers. It's quick & easy.

ASP stops working after loading FrontPage material

P: n/a



I'm a newbie to FrontPage and IIS.

I have a simple issue that I believe may be a
configuration setting somewhere.
If there is a KB article, I just cannot find it.


I'm trying to load my simple FrontPage web material that
includes MS Access database access into my IIS 5.0 server
on my one Windows 2000 Professional machine.

When I first install IIS 5.0,
my "http://localhost/localstart.asp" file works as
described in Knowledge Base article Q162976.

"How to Verify That ASP Is Working on Your Web Server."

Then I publish my existing and very simple FrontPage web
directory into the IIS 5.0 "wwwroot" folder.

Once that FrontPage publishing finishes successfully, I
can no longer run the
default "http://localhost/localstart.asp" IIS file
anymore. That URL now hangs.

It appears that the installation of the FrontPage material
into the IIS 5.0 "wwwroot" folder corrupts something in
the originally clean and working IIS 5.0 installation.

I have been searching (... and searching) for a Knowledge
Base article with a resolution to this issue. I have not
been successful.

(An interesting side note is that after publishing, the
HTML files from my FrontPage material all work properly in
the new IIS 5.0 web folder. It is only the original IIS
ASP files and the FrontPage ASP files that do not work.)

Some Background

One machine

MS Windows 2000 SP4
IIS 5.0
MS Office 2000 SP3 (FrontPage)
Front Page Server Extensions.
IE 6.0

I am always the Administrator using full Administrative

Thanks In Advance,

I assume the following issue is very important to this
discussion as well.

When I publish the FrontPage web material to the IIS
server, I have two choices. I may publish
to "D:\Inetpub\wwwroot" or to "http://localhost"

When I try publishing with the "http://localhost" folder
selection, I receive the following message and the
publishing transaction fails from within FrontPage.

"The server you are publishing to does not have the
FrontPage Server Extensions installed, and therefore does
not support publishing via HTTP. To continue publishing,
specify a location that will work with FTP."

(The grammar mistakes in the previous paragraph are not

When I publish from FrontPage with
the "D:\inetpub\wwwroot" folder selection, everything
appears to publish properly.

I believe, (probably wrongly believe) that the FrontPage
Server Extensions are installed on my machine, because I
can open the "Server Extensions Administrator" from the
Administrative Tools" selection within the "Programs" menu.

Jul 19 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.