By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,144 Members | 1,056 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,144 IT Pros & Developers. It's quick & easy.

Problems Browsing Default Web Site and IISADMIN on IIS 5.0

P: n/a
HELP!

This problem is driving me crazy. All other web sites
that are being served out through this server are working,
including sites and virtual directories that are under the
Default Web Site, yet when I attempt to browse the Default
Web Site I get this error:

The page cannot be displayed

There is a problem with the page you are trying to reach
and it cannot be displayed.

-----------------------------------------------------------
---------------------

Please try the following:

Click the Refresh button, or try again later.

Open the www.domainname.com home page, and then look for
links to the information you want.
HTTP 500.100 - Internal Server Error - ASP error
Internet Information Services

-----------------------------------------------------------
---------------------

Technical Information (for support personnel)

Error Type:
(0x80090020)
An internal error occurred.
/localstart.asp, line 18
Browser Type:
Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET
CLR 1.0.3705; .NET CLR 1.1.4322)

Page:
GET /localstart.asp

Time:
Friday, February 06, 2004, 2:58:49 PM
More information:
Microsoft Support

Similarly, when I attempt to browse the Administration Web
Site I get this error:

Unable to connect to the Active Directory Service Object.
Please contact your system administrator.
Error:-2146893792

I have been looking around the newsgroups for fixes to
these problems, and have found that it possibly could be a
IIS Metabase issue, but I am still not sure.

These problems seem to have cropped up after a problem we
had with this servers clock running wild, a problem that
was reported fixed in Service Pack 4. This server is also
a Enterprise Certificate Authority and when the clock was
running wild it caused thousands of certificates to be
issued. Well, in the certificate clean up process, I read
in several newsgroups and web articles that along with
deleting the certificates from the Certificate Store and
deleting the Root Certificates from the Active Directory,
I should also backup and delete the contents of the
\Documents and Settings\All Users\Application
Data\Microsoft\Crypto\RSA\MachineKeys. After completing
these steps I rebooted the server. When the server came
back up I had a REAL problem on my hands. I would say 90%
of the server failed to start. Needless to say this was
bad. I figured it had something to do with the
MachineKeys Folder being empty. So I restored the folder
to its original state, and rebooted. The server came back
up without an error. So I figured that there must be some
files that are needed. I checked which files were in this
folder on another functioning machine, and found that
there only a few. I opened these files, and found that
each file was marked with by IIS, DCOM, etc. I then
returned to the machine with all of the bad certificates,
and did a "Find" on the MachineKeys Directory looking for
files with IIS, DCOM, etc contained within them. After
finding each of the files that were on the functioning
server, I did a backup of the MachineKeys folder and
deleted the the files that were not needed, then
rebooted. The server came back up without an error.

The problem was fixed, or so I thought, but ever since
this happened I have not been able to access the Default
Web Site or the IISADMIN Web Site. Reinstalling IIS is
not really a viable option, too many things I have loaded
depend on IIS. I am hoping to be able to restore IIS and
IISAdmin back to their default installed condition using
other means. I have tried restoring the MachineKeys
Folder, I thought that maybe I missed a file, but it
didn't help.

Any help on this problem would really be appreciated.

Thanks in advance.

-John
Jul 19 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.