469,271 Members | 1,466 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,271 developers. It's quick & easy.

Is there a way to have IIS stop sending ASP_DEBUG_INFO METADATA in debug mode?

Hi.

This is a feature that is really going on my nerves as I've been writing SOAP
Web services using ASP and SOAP toolkit 3.0. My web services ASP scripts send
XML data to the client application.

When I'm debugging under Visual Sudio, IIS prefixes *all* streams that go to the
client with <!-- METADATA TYPE="ASP_DEBUG_INFO">. I'm using XMLHTTP in some
cases to receive data. Neither XMLHTTP v3 nor v4 seem to accept this as valid
XML. I must instantiate an XML document and load stripped data instead.

So isn't there any way for IIS to stop sending this METADATA?

Thanks in advance,
Vince C.
Jul 19 '05 #1
9 4248
Disable the Server-side and client-side debugging options under the
configuration of the application from IIS manager.

I believe that's what I did when I had the problem.

HTH
Lance
"Vince C." <no**@hotmail.com> wrote in message
news:OQ****************@tk2msftngp13.phx.gbl...
Hi.

This is a feature that is really going on my nerves as I've been writing SOAP Web services using ASP and SOAP toolkit 3.0. My web services ASP scripts send XML data to the client application.

When I'm debugging under Visual Sudio, IIS prefixes *all* streams that go to the client with <!-- METADATA TYPE="ASP_DEBUG_INFO">. I'm using XMLHTTP in some cases to receive data. Neither XMLHTTP v3 nor v4 seem to accept this as valid XML. I must instantiate an XML document and load stripped data instead.

So isn't there any way for IIS to stop sending this METADATA?

Thanks in advance,
Vince C.

Jul 19 '05 #2
"Lance Wynn" <la********@N.O.S.P.A.M.hotmail.com> a écrit dans le message de
news:%2****************@tk2msftngp13.phx.gbl...
Disable the Server-side and client-side debugging options under the
configuration of the application from IIS manager.

I believe that's what I did when I had the problem.


Well, I can't because they're automatically set by VInterdev when I start a
debugging session. I've seen in MS KB I "had to" uncheck the "client-side
debugging option" in the property page you're referring to but it's the same
problem. Visual Interdev doesn't offer any choice whether to allow client side
debugging. And manual debugging is not an option, unfortunately for specific
reasons.

Vince C.
Jul 19 '05 #3
Hello Vince,

Thanks for posting in the group.

Based on my understanding, now the issue is: You developed web service in
IIS server side. When you debug it under VS 6.0, the response contains <!--
METADATA TYPE="ASP_DEBUG_INFO"> in the prefix of all responses, which makes
your client XMLHttp failed in parsing. Please feel free to post here if I
have misunderstood the problem.

Generally speaking, When we view or debug an Active Server Pages (ASP)
page, we may notice that the following tag is inserted into the resultant
HTML at the top of your page: <!-- METADATA TYPE="ASP_DEBUG_INFO" -->

When this tag is inserted into the resultant HTML, it may cause problems in
the following scenarios:
1) When you generate XML in your ASP page and send the XML to the client
rather than HTML. (that is your scenario)
2) When you use the Response.BinaryWrite method to stream binary data to
the client (for example, a Microsoft Excel document).

In fact, ASP sends down this tag when the following two conditions are met:
1) The Enable ASP client-side script debugging flag is enabled for the Web
application.
2) An ASPCLIENTDEBUG cookie is present on the client that makes the request.

Typically, when you use automatic debugging with Visual InterDev 6.0, both
of these conditions are met. The Visual InterDev debugger requires this tag
at run time to automatically map breakpoints in the client script.

To resolve this problem, we can use one of the following methods.

Method 1
Disable the Enable ASP client-side script debugging flag as follows:
In the Internet Services Manager, right-click the Web application with
which you are currently working, and then click Properties.
Click Configuration.
On the App Debugging tab, clear the Enable ASP client-side script debugging
check box.

Method 2
Delete the ASPCLIENTDEBUG cookie from your client computer as follows:
On your computer, search for a file named username@applicationname*. For
example, if the user name is "johndoe" and the application is named
"myapplication," search for the johndoe@myapplication* file.
After you locate the file, delete it.

For more details, please refer to http://support.microsoft.com/?id=297995.
"PRB: "ASP_DEBUG_INFO" Tag Is Inserted into HTML When You Debug with Visual
InterDev 6.0".

Does that answer your question?

Best regards,
Yanhong Huang
Microsoft Community Support

Get Secure! ¨C www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no rights.

Jul 19 '05 #4
Hello Vince,

Have you tried the suggestion yet? If the problem still can't be resolved,
please feel free to post here. I am glad to work with you on it.

Thanks again for participating the community.

Best regards,
Yanhong Huang
Microsoft Community Support

Get Secure! ¨C www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no rights.

Jul 19 '05 #5
"Yan-Hong Huang[MSFT]" <yh*****@online.microsoft.com> a écrit dans le message de
news:XR*************@cpmsftngxa07.phx.gbl...
Hello Vince,

Have you tried the suggestion yet? If the problem still can't be resolved,
please feel free to post here. I am glad to work with you on it.


The first suggestion is not applicable as both options are automatically set by
Visual Interdev when starting a debugging session. Manually configuring the
server for debugging is... boring. I must set the options whenever I need to
debug and clear them when I want to run the web application normally.

The second option is not applicable either as the cookie is sent whenever a
debugging session is started. At least this is what I've noticed. It is sent as
soon as the debugging options are set in IIS properties. And since they are set
automatically... you've understood.

It would have been best if one could setup VI to automatically check one or both
options.

Vince C.
Jul 19 '05 #6
Hi Vince,

Thanks for your response.

As KB article "PRB: "ASP_DEBUG_INFO" Tag Is Inserted into HTML When You
Debug with Visual InterDev 6.0" mentioned, this is a known issue and the
only way is to change setting by ourselves. For the second way in this
article, we need to delete cookies every time too. I understand that what
you need is to simply set it automatically. However, we could only setup it
each time in InterDev for now. We can't use the automatic debugging in
these scenarios.

http://support.microsoft.com/?id=297995 has a clear explanation on it.

Thanks.

Best regards,
Yanhong Huang
Microsoft Community Support

Get Secure! ¨C www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no rights.

Jul 19 '05 #7
"Yan-Hong Huang[MSFT]" <yh*****@online.microsoft.com> a écrit dans le message de
news:Qq*************@cpmsftngxa07.phx.gbl...
Hi Vince,

Thanks for your response.

As KB article "PRB: "ASP_DEBUG_INFO" Tag Is Inserted into HTML When You
Debug with Visual InterDev 6.0" mentioned, this is a known issue and the
only way is to change setting by ourselves. For the second way in this
article, we need to delete cookies every time too. I understand that what
you need is to simply set it automatically. However, we could only setup it
each time in InterDev for now. We can't use the automatic debugging in
these scenarios.

http://support.microsoft.com/?id=297995 has a clear explanation on it.


If I can make a suggestion why not putting a processing directive such as

<@ aspdebuginfo=false @>

on top of pages in which we don't want VI/IIS to send debug information?

Vince C.
Jul 19 '05 #8
Hi Vince,

Thanks very much for your feedback.

I will pass your suggestion to our product group. Also, you can submit it
at
http://register.microsoft.com/mswish...=EN-US&gssnb=1.

We appreciate your input there, and look forward to building better
products with helpful ideas such as yours.

Thanks again for participating the community.

Best regards,
Yanhong Huang
Microsoft Community Support

Get Secure! ¨C www.microsoft.com/security
This posting is provided "AS IS" with no warranties, and confers no rights.

Jul 19 '05 #9
I am having the same problem with VisualStudio.NET that debugs both ASP and ASP.NET pages coexisting in the same application. Is there a way you can mark an ASP page not to be debugged by Visual Studio .NET
Jul 19 '05 #10

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

7 posts views Thread by Srinivasa Rao | last post: by
2 posts views Thread by ringo | last post: by
5 posts views Thread by =?Utf-8?B?SmVycnkgSg==?= | last post: by
5 posts views Thread by =?Utf-8?B?cmF1bGF2aQ==?= | last post: by
reply views Thread by zhoujie | last post: by
reply views Thread by suresh191 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.