467,910 Members | 1,660 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 467,910 developers. It's quick & easy.

Configuring OWA 2003 FE server on IIS 6.0 for auto-redirect?

I now realize I probably should have tried posting this on the IIS board
first..

I am running OWA 2003 Server as Front End server to my Exchange 2000 native
domain. The FE server is secured by a 128 bit SSL cert. The OWA 2003
server is running on Windows 2003 server in a Windows 2003 native AD domain.

At present, the server is configured so that user's have to specifically go
to the URL httpS://myserver.company.com in order to access OWA securely.
The FE server then automatically redirects the user to the /Exchange
subdirectory allowing for access to their backend mailbox.

However, I would prefer to be able to have users be able to simply go to
httP://myserver.company.com and have the FE server automatically redirect
them to the httpS://myserver.company.com URL, instead of forcing them to
make sure they're using httpS from the get go.

However, attempting to make this change at the root level of the web server,
automatically propagates the redirect changes all the way down to the
/exchange subdirectory, creating an infinite loop.

What do I need to change on the FE server's IIS configuration to allow this
auto-redirect to happen?
Jul 19 '05 #1
  • viewed: 7216
Share:
2 Replies
If you want to redirect requests to httP://myserver.company.com *only* (ie
not other URLs like httP://myserver.company.com/someDocument.htm) then I
would:

a) create a default document (eg default.asp or default.aspx) and place it
into the root of your server.
b) please the following ASP code in the default.asp page:

<% @Language=VBScript EnableSessionState=False%>
<%
Response.Redirect("https://myserver.myCompany.com/exchange/")
%>
If you want to redirect *all* requests to any URL (except, obviously within
the /exchange folder itself) that are http://, then:
I would create a custom 403.4 error handler (for SSL required). This would
contain similar code to the one above that would redirect requests to the
/exchange/ folder. You would then "require" SSL for the server in question
(in the directory security tab of the IIS MMC Snapin), but remove SSL
requirement for the error handler page.
This article outlines the steps:
http://support.microsoft.com/?kbid=279681
However, it doesn't work for IIS6 unless you place the error handler page in
the same web app pool as the location the error is being generated in.

Cheers
Ken

"Robert Gordon" <Ro***********@nospam.perlegen.com> wrote in message
news:uw**************@TK2MSFTNGP10.phx.gbl...
: I now realize I probably should have tried posting this on the IIS board
: first..
:
: I am running OWA 2003 Server as Front End server to my Exchange 2000
native
: domain. The FE server is secured by a 128 bit SSL cert. The OWA 2003
: server is running on Windows 2003 server in a Windows 2003 native AD
domain.
:
: At present, the server is configured so that user's have to specifically
go
: to the URL httpS://myserver.company.com in order to access OWA securely.
: The FE server then automatically redirects the user to the /Exchange
: subdirectory allowing for access to their backend mailbox.
:
: However, I would prefer to be able to have users be able to simply go to
: httP://myserver.company.com and have the FE server automatically redirect
: them to the httpS://myserver.company.com URL, instead of forcing them to
: make sure they're using httpS from the get go.
:
: However, attempting to make this change at the root level of the web
server,
: automatically propagates the redirect changes all the way down to the
: /exchange subdirectory, creating an infinite loop.
:
: What do I need to change on the FE server's IIS configuration to allow
this
: auto-redirect to happen?
:
:
Jul 19 '05 #2
How do you place the error handler page in the same web app pool

Thanks
Lloy

----- Ken Schaefer wrote: ----

If you want to redirect requests to httP://myserver.company.com *only* (i
not other URLs like httP://myserver.company.com/someDocument.htm) then
would

a) create a default document (eg default.asp or default.aspx) and place i
into the root of your server
b) please the following ASP code in the default.asp page

<% @Language=VBScript EnableSessionState=False%><
Response.Redirect("https://myserver.myCompany.com/exchange/"
%
If you want to redirect *all* requests to any URL (except, obviously withi
the /exchange folder itself) that are http://, then
I would create a custom 403.4 error handler (for SSL required). This woul
contain similar code to the one above that would redirect requests to th
/exchange/ folder. You would then "require" SSL for the server in questio
(in the directory security tab of the IIS MMC Snapin), but remove SS
requirement for the error handler page
This article outlines the steps
http://support.microsoft.com/?kbid=27968
However, it doesn't work for IIS6 unless you place the error handler page i
the same web app pool as the location the error is being generated in

Cheer
Ke

"Robert Gordon" <Ro***********@nospam.perlegen.com> wrote in messag
news:uw**************@TK2MSFTNGP10.phx.gbl..
: I now realize I probably should have tried posting this on the IIS boar
: first.

: I am running OWA 2003 Server as Front End server to my Exchange 200
nativ
: domain. The FE server is secured by a 128 bit SSL cert. The OWA 200
: server is running on Windows 2003 server in a Windows 2003 native A
domain

: At present, the server is configured so that user's have to specificall
g
: to the URL httpS://myserver.company.com in order to access OWA securely
: The FE server then automatically redirects the user to the /Exchang
: subdirectory allowing for access to their backend mailbox

: However, I would prefer to be able to have users be able to simply go t
: httP://myserver.company.com and have the FE server automatically redirec
: them to the httpS://myserver.company.com URL, instead of forcing them t
: make sure they're using httpS from the get go

: However, attempting to make this change at the root level of the we
server
: automatically propagates the redirect changes all the way down to th
: /exchange subdirectory, creating an infinite loop

: What do I need to change on the FE server's IIS configuration to allo
thi
: auto-redirect to happen

Jul 19 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

26 posts views Thread by Dragon | last post: by
1 post views Thread by pmclinn | last post: by
17 posts views Thread by Mell via AccessMonster.com | last post: by
5 posts views Thread by NonNB | last post: by
1 post views Thread by rada.lambretha | last post: by
3 posts views Thread by =?Utf-8?B?TWFyYw==?= | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.