472,127 Members | 1,944 Online
Bytes | Software Development & Data Engineering Community
Post +

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 472,127 software developers and data experts.

IIS and WebDav problems

I am trying to setup IIS 6 to allow web developers to connect up to the
web root of a website via WebDav and work on site files including .asp
and .aspx files.

I have setup a website for this purpose in IIS. The home directory is
mapped to a local folder on the machine. Under the 'home directory' tab
all the permission boxes are checked ('script source access, read,
write, etc...). Execute permissions are set to 'scripts and
executables'. I've also removed .asp from the 'application extensions'
list accessed from the 'configuration' tab. Basic authentication is
turned on under 'directory security/authenticati on and access
control'. I do not have URLScan installed, so any filtering is by IIS

This is all working as expected; I can mount the WebDav connection in
Windows Explorer and navigate, view and open/save files. I can also
access the website via a browser and browse directories/view browser
appropriate files, etc. The problem is that I cannot access any .asp
files at all. If I look in the logs for the website I get a entry for
the WebDav request (PROPFIND) with a 404 error. The file *is there* I
just can't access it. Other files (.html, .css., .jpg, etc.) work fine.

What can I enable/disable in IIS to make this work?? I have spent hours
on this already and about to give up.

Oct 24 '06 #1
0 1474

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

4 posts views Thread by Jody Winston | last post: by
reply views Thread by Rade Josovic | last post: by
reply views Thread by Michael G. Schneider | last post: by
reply views Thread by SimpleSimple | last post: by
7 posts views Thread by Steve Drake | last post: by
reply views Thread by Gary Chamberlain via .NET 247 | last post: by
reply views Thread by arjen1984 | last post: by
reply views Thread by leo001 | last post: by

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.