By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
457,732 Members | 842 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 457,732 IT Pros & Developers. It's quick & easy.

Permissions/security problem

P: n/a
hello again oh knowledgable ones

Today I took the plunge (more like a hell-hole dive) and upgraded to windows
XP Pro..

and as I expected things are slightly different...

what I didn't expect was for things to be so damn complicated!!

I'm having trouble with my local DB sites. I keep getting "the file is read
only" error...

I've checked all the files and they're not!!!

Previously in win2000 I could just right click and select properties and
then security settings and select USR, Everyone etc etc etc....but I dont
have this option in XP...so I really don't know what to do. I don't like to
go messing about in IIS Admin tools for fear of cocking something up, but
I'm guessing I might have to.

anywhere I can get a straighforward guide, with the newbie in mind??

many thanks

Jul 19 '05 #1
Share this Question
Share on Google+
22 Replies


P: n/a
> I've checked all the files and they're not!!!

What about the folder that the files are in?
Previously in win2000 I could just right click and select properties and
then security settings and select USR, Everyone etc etc etc....but I dont
have this option in XP...


You need to go to your Folder Options (Start>Settings>Control Panel>Folder
Options) and click the View tab... scroll down to the bottom of the list and
uncheck the simple file sharing option. Then you should be able to see the
security tab from the properties of a file or folder.
Jul 19 '05 #2

P: n/a
Open a folder, go to Tools-->Folder Options. The very last one says
something about using simple sharing. Remove the checkbox.

I think that'll fix it.

"Alistair" <news@*remove*alistairb.co.uk> wrote in message
news:vt************@corp.supernews.com...
hello again oh knowledgable ones

Today I took the plunge (more like a hell-hole dive) and upgraded to windows XP Pro..

and as I expected things are slightly different...

what I didn't expect was for things to be so damn complicated!!

I'm having trouble with my local DB sites. I keep getting "the file is read only" error...

I've checked all the files and they're not!!!

Previously in win2000 I could just right click and select properties and
then security settings and select USR, Everyone etc etc etc....but I dont
have this option in XP...so I really don't know what to do. I don't like to go messing about in IIS Admin tools for fear of cocking something up, but
I'm guessing I might have to.

anywhere I can get a straighforward guide, with the newbie in mind??

many thanks

Jul 19 '05 #3

P: n/a
Alistair wrote:
hello again oh knowledgable ones

Today I took the plunge (more like a hell-hole dive) and upgraded to
windows XP Pro..

and as I expected things are slightly different...

what I didn't expect was for things to be so damn complicated!!

I'm having trouble with my local DB sites. I keep getting "the file
is read only" error...

I've checked all the files and they're not!!!

Previously in win2000 I could just right click and select properties
and then security settings and select USR, Everyone etc etc
etc....but I dont have this option in XP...so I really don't know
what to do. I don't like to go messing about in IIS Admin tools for
fear of cocking something up, but I'm guessing I might have to.

anywhere I can get a straighforward guide, with the newbie in mind??

many thanks


http://www.microsoft.com/windowsxp/p...esscontrol.asp

IIRC, in XP, the IUSR account shows up as the Internet Guest account.

Bob Barrows
--
Microsoft MVP -- ASP/ASP.NET
Please reply to the newsgroup. The email account listed in my From
header is my spam trap, so I don't check it very often. You will get a
quicker response by posting to the newsgroup.
Jul 19 '05 #4

P: n/a

http://www.microsoft.com/windowsxp/p...esscontrol.asp
IIRC, in XP, the IUSR account shows up as the Internet Guest account.

Bob Barrows
--
Microsoft MVP -- ASP/ASP.NET
Please reply to the newsgroup. The email account listed in my From
header is my spam trap, so I don't check it very often. You will get a
quicker response by posting to the newsgroup.


Thanks for that but it only serves to highlight my problem

In Win2000, when I click properties for a file/folder I get the following
tabs, General, Sharing, Security, Customize. So I could go into Security and
select Usr, Guest etc etc and set read/write permissions.

In XP I dont have this tab..I have General, Sharing, Web sharing and
Customize...there is no security tab!!!

so I'm still stuck

Jul 19 '05 #5

P: n/a
Except you didn't read the very last paragraph which tells you how to get
the security tab. As does my previous post and Randy Rahbar's
"Alistair" <news@*remove*alistairb.co.uk> wrote in message
news:vt************@corp.supernews.com...

http://www.microsoft.com/windowsxp/p...esscontrol.asp

IIRC, in XP, the IUSR account shows up as the Internet Guest account.

Bob Barrows
--
Microsoft MVP -- ASP/ASP.NET
Please reply to the newsgroup. The email account listed in my From
header is my spam trap, so I don't check it very often. You will get a
quicker response by posting to the newsgroup.


Thanks for that but it only serves to highlight my problem

In Win2000, when I click properties for a file/folder I get the following
tabs, General, Sharing, Security, Customize. So I could go into Security

and select Usr, Guest etc etc and set read/write permissions.

In XP I dont have this tab..I have General, Sharing, Web sharing and
Customize...there is no security tab!!!

so I'm still stuck

Jul 19 '05 #6

P: n/a
Alistair wrote:

http://www.microsoft.com/windowsxp/p...esscontrol.asp

IIRC, in XP, the IUSR account shows up as the Internet Guest account.

Bob Barrows
--
Microsoft MVP -- ASP/ASP.NET
Please reply to the newsgroup. The email account listed in my From
header is my spam trap, so I don't check it very often. You will get
a quicker response by posting to the newsgroup.


Thanks for that but it only serves to highlight my problem

In Win2000, when I click properties for a file/folder I get the
following tabs, General, Sharing, Security, Customize. So I could go
into Security and select Usr, Guest etc etc and set read/write
permissions.

In XP I dont have this tab..I have General, Sharing, Web sharing and
Customize...there is no security tab!!!

Read the last paragraph.

Bob Barrows
--
Microsoft MVP -- ASP/ASP.NET
Please reply to the newsgroup. The email account listed in my From
header is my spam trap, so I don't check it very often. You will get a
quicker response by posting to the newsgroup.
Jul 19 '05 #7

P: n/a
and you obviously didn't read my original post, which I would suggest you do
before assuming that I'm ignorant and getting all condescending with your
reply

my whole problem is that I dont have the f****g security tab!!!

thats what I've been trying to tell you....and I had already done everything
in the instructions that bob was kind enough to give me....

NO SECURITY TAB

next bright idea?

my apologies to anyone else reading this, but I prefer not to be treated
like I'm an idiot because someone mis-interprets my post.
"TomB" <sh*****@hotmailXXX.com> wrote in message
news:ur**************@tk2msftngp13.phx.gbl...
Except you didn't read the very last paragraph which tells you how to get
the security tab. As does my previous post and Randy Rahbar's
"Alistair" <news@*remove*alistairb.co.uk> wrote in message
news:vt************@corp.supernews.com...

http://www.microsoft.com/windowsxp/p...esscontrol.asp

IIRC, in XP, the IUSR account shows up as the Internet Guest account.

Bob Barrows
--
Microsoft MVP -- ASP/ASP.NET
Please reply to the newsgroup. The email account listed in my From
header is my spam trap, so I don't check it very often. You will get a
quicker response by posting to the newsgroup.


Thanks for that but it only serves to highlight my problem

In Win2000, when I click properties for a file/folder I get the following tabs, General, Sharing, Security, Customize. So I could go into Security

and
select Usr, Guest etc etc and set read/write permissions.

In XP I dont have this tab..I have General, Sharing, Web sharing and
Customize...there is no security tab!!!

so I'm still stuck


Jul 19 '05 #8

P: n/a
I can't believe how many people are getting pissed off in these groups
lately. It's pretty entertaining. :]

Try entering this at a command prompt (cmd.exe) where C: is the drive with
the issue:

convert c: /fs:ntfs

Ray at work

"Alistair" <news@*remove*alistairb.co.uk> wrote in message
news:vt************@corp.supernews.com...
and you obviously didn't read my original post, which I would suggest you do before assuming that I'm ignorant and getting all condescending with your
reply

my whole problem is that I dont have the f****g security tab!!!

thats what I've been trying to tell you....and I had already done everything in the instructions that bob was kind enough to give me....

NO SECURITY TAB

next bright idea?

my apologies to anyone else reading this, but I prefer not to be treated
like I'm an idiot because someone mis-interprets my post.
"TomB" <sh*****@hotmailXXX.com> wrote in message
news:ur**************@tk2msftngp13.phx.gbl...
Except you didn't read the very last paragraph which tells you how to get
the security tab. As does my previous post and Randy Rahbar's
"Alistair" <news@*remove*alistairb.co.uk> wrote in message
news:vt************@corp.supernews.com...

>
>

http://www.microsoft.com/windowsxp/p...esscontrol.asp
>
> IIRC, in XP, the IUSR account shows up as the Internet Guest account. >
> Bob Barrows
> --
> Microsoft MVP -- ASP/ASP.NET
> Please reply to the newsgroup. The email account listed in my From
> header is my spam trap, so I don't check it very often. You will get a > quicker response by posting to the newsgroup.
>
>

Thanks for that but it only serves to highlight my problem

In Win2000, when I click properties for a file/folder I get the following tabs, General, Sharing, Security, Customize. So I could go into Securi
ty and
select Usr, Guest etc etc and set read/write permissions.

In XP I dont have this tab..I have General, Sharing, Web sharing and
Customize...there is no security tab!!!

so I'm still stuck



Jul 19 '05 #9

P: n/a

"Ray at <%=sLocation%>" <myfirstname at lane34 dot com> wrote in message
news:eU****************@TK2MSFTNGP12.phx.gbl...
I can't believe how many people are getting pissed off in these groups
lately. It's pretty entertaining. :]


'tis the season to be jolly don't you know??
Jul 19 '05 #10

P: n/a
The last paragraph says:

To display the Security tab

a.. Open Folder Options in Control Panel. (Click Start, click Control
Panel, click Appearance and Themes, and then click Folder Options.)

b.. On the View tab, under Advanced settings, clear Use simple file
sharing [Recommended].

Alistair wrote:
and you obviously didn't read my original post, which I would suggest
you do before assuming that I'm ignorant and getting all
condescending with your reply

my whole problem is that I dont have the f****g security tab!!!

thats what I've been trying to tell you....and I had already done
everything in the instructions that bob was kind enough to give me....

NO SECURITY TAB

next bright idea?

my apologies to anyone else reading this, but I prefer not to be
treated like I'm an idiot because someone mis-interprets my post.
"TomB" <sh*****@hotmailXXX.com> wrote in message
news:ur**************@tk2msftngp13.phx.gbl...
Except you didn't read the very last paragraph which tells you how
to get the security tab. As does my previous post and Randy Rahbar's
"Alistair" <news@*remove*alistairb.co.uk> wrote in message
news:vt************@corp.supernews.com...


http://www.microsoft.com/windowsxp/p...esscontrol.asp

IIRC, in XP, the IUSR account shows up as the Internet Guest
account.

Bob Barrows
--
Microsoft MVP -- ASP/ASP.NET
Please reply to the newsgroup. The email account listed in my From
header is my spam trap, so I don't check it very often. You will
get a quicker response by posting to the newsgroup.

Thanks for that but it only serves to highlight my problem

In Win2000, when I click properties for a file/folder I get the
following tabs, General, Sharing, Security, Customize. So I could
go into Security and select Usr, Guest etc etc and set read/write
permissions.

In XP I dont have this tab..I have General, Sharing, Web sharing and
Customize...there is no security tab!!!

so I'm still stuck


--
Microsoft MVP -- ASP/ASP.NET
Please reply to the newsgroup. The email account listed in my From
header is my spam trap, so I don't check it very often. You will get a
quicker response by posting to the newsgroup.
Jul 19 '05 #11

P: n/a
So, is your drive NTFS?

Ray at work
HO HO HO HO HO
"Alistair" <news@*remove*alistairb.co.uk> wrote in message
news:vt************@corp.supernews.com...

"Ray at <%=sLocation%>" <myfirstname at lane34 dot com> wrote in message
news:eU****************@TK2MSFTNGP12.phx.gbl...
I can't believe how many people are getting pissed off in these groups
lately. It's pretty entertaining. :]


'tis the season to be jolly don't you know??

Jul 19 '05 #12

P: n/a
I did read your original post, and I suggested a method that would get you
the security tab.
Bob's post had a link. At the bottom of that page was a method to get the
security tab.
Are you saying that you did try those methods to get the security tab? You
could have mentioned that.
I'm taking time out of my day to offer suggestions. You are obviously
getting frustrated as your system isn't doing what you want/expect it to.
Don't take the frustration out on me.
To ensure i haven't mis-interpreted anything; I've reread your original
posts and all subsequent posts. Your response to Bob's post was that it
highlights your problem-- no security tab. The only reason I could see for
not having the security tab is if you have simple file sharing turned on. I
didn't think of Ray's possible solution which is that your file system is
Fat32.

Good luck
"Alistair" <news@*remove*alistairb.co.uk> wrote in message
news:vt************@corp.supernews.com...
and you obviously didn't read my original post, which I would suggest you do before assuming that I'm ignorant and getting all condescending with your
reply

my whole problem is that I dont have the f****g security tab!!!

thats what I've been trying to tell you....and I had already done everything in the instructions that bob was kind enough to give me....

NO SECURITY TAB

next bright idea?

my apologies to anyone else reading this, but I prefer not to be treated
like I'm an idiot because someone mis-interprets my post.
"TomB" <sh*****@hotmailXXX.com> wrote in message
news:ur**************@tk2msftngp13.phx.gbl...
Except you didn't read the very last paragraph which tells you how to get
the security tab. As does my previous post and Randy Rahbar's
"Alistair" <news@*remove*alistairb.co.uk> wrote in message
news:vt************@corp.supernews.com...

>
>

http://www.microsoft.com/windowsxp/p...esscontrol.asp
>
> IIRC, in XP, the IUSR account shows up as the Internet Guest account. >
> Bob Barrows
> --
> Microsoft MVP -- ASP/ASP.NET
> Please reply to the newsgroup. The email account listed in my From
> header is my spam trap, so I don't check it very often. You will get a > quicker response by posting to the newsgroup.
>
>

Thanks for that but it only serves to highlight my problem

In Win2000, when I click properties for a file/folder I get the following tabs, General, Sharing, Security, Customize. So I could go into
Security and
select Usr, Guest etc etc and set read/write permissions.

In XP I dont have this tab..I have General, Sharing, Web sharing and
Customize...there is no security tab!!!

so I'm still stuck



Jul 19 '05 #13

P: n/a
and the second to last paragraph (or thereabouts) says...

I'VE ALREADY TRIED THAT!!!!

ffs...what is the matter with people???...READ THE ORIINAL POST (and the
others)...it says...

I (meaning me)
do not have (meaning without, not in possession of, devoid of, missing,
lost)
the Security tab

and to answer Ray..yes it is but after a reboot..I've now got a whole bunch
of error boxes popping up and stuff one about partitions and one about
conflict of users something or other...might just redo the whole thing,
luckily I haven't gotten round to installing anything else yet!!
"Bob Barrows" <re******@NOyahoo.SPAMcom> wrote in message
news:uI**************@TK2MSFTNGP11.phx.gbl...
The last paragraph says:

To display the Security tab

a.. Open Folder Options in Control Panel. (Click Start, click Control
Panel, click Appearance and Themes, and then click Folder Options.)

b.. On the View tab, under Advanced settings, clear Use simple file
sharing [Recommended].

Alistair wrote:
and you obviously didn't read my original post, which I would suggest
you do before assuming that I'm ignorant and getting all
condescending with your reply

my whole problem is that I dont have the f****g security tab!!!

thats what I've been trying to tell you....and I had already done
everything in the instructions that bob was kind enough to give me....

NO SECURITY TAB

next bright idea?

my apologies to anyone else reading this, but I prefer not to be
treated like I'm an idiot because someone mis-interprets my post.
"TomB" <sh*****@hotmailXXX.com> wrote in message
news:ur**************@tk2msftngp13.phx.gbl...
Except you didn't read the very last paragraph which tells you how
to get the security tab. As does my previous post and Randy Rahbar's
"Alistair" <news@*remove*alistairb.co.uk> wrote in message
news:vt************@corp.supernews.com...

>
>

http://www.microsoft.com/windowsxp/p...esscontrol.asp
>
> IIRC, in XP, the IUSR account shows up as the Internet Guest
> account.
>
> Bob Barrows
> --
> Microsoft MVP -- ASP/ASP.NET
> Please reply to the newsgroup. The email account listed in my From
> header is my spam trap, so I don't check it very often. You will
> get a quicker response by posting to the newsgroup.
>
>

Thanks for that but it only serves to highlight my problem

In Win2000, when I click properties for a file/folder I get the
following tabs, General, Sharing, Security, Customize. So I could
go into Security and select Usr, Guest etc etc and set read/write
permissions.

In XP I dont have this tab..I have General, Sharing, Web sharing and
Customize...there is no security tab!!!

so I'm still stuck


--
Microsoft MVP -- ASP/ASP.NET
Please reply to the newsgroup. The email account listed in my From
header is my spam trap, so I don't check it very often. You will get a
quicker response by posting to the newsgroup.

Jul 19 '05 #14

P: n/a

"Alistair" <news@*remove*alistairb.co.uk> wrote in message
news:vt************@corp.supernews.com...

and to answer Ray..yes it is but after a reboot..I've now got a whole bunch of error boxes popping up and stuff one about partitions and one about
conflict of users something or other


Cool. It worked. :P

Ray at work
Jul 19 '05 #15

P: n/a
Alistair wrote:
and the second to last paragraph (or thereabouts) says...

I'VE ALREADY TRIED THAT!!!!


Where did you tell us that? You told us that you followed the instructions
to turn off simple file sharing and the Security tab still did not appear? I
just spent the last few minutes re-reading each of your posts and I failed
to see where you provided us with that information.

Why are we supposed to be able to read your mind? GODDAMMIT! WE ARE NOT
LOOKING OVER YOUR SHOULDER AS YOU ATTEMPT TO TROUBLESHOOT ... I'm losing
it. I'm done in this thread. Goodbye good luck

Jul 19 '05 #16

P: n/a
You know that you did something wrong if ever-polite Bob is this pissed. So
many bridge burners around here lately.

Ray at work

"Bob Barrows" <re******@NOyahoo.SPAMcom> wrote in message
news:%2****************@TK2MSFTNGP12.phx.gbl...
Alistair wrote:
and the second to last paragraph (or thereabouts) says...

I'VE ALREADY TRIED THAT!!!!
Where did you tell us that? You told us that you followed the instructions
to turn off simple file sharing and the Security tab still did not appear?

I just spent the last few minutes re-reading each of your posts and I failed
to see where you provided us with that information.

Why are we supposed to be able to read your mind? GODDAMMIT! WE ARE NOT
LOOKING OVER YOUR SHOULDER AS YOU ATTEMPT TO TROUBLESHOOT ... I'm losing
it. I'm done in this thread. Goodbye good luck

Jul 19 '05 #17

P: n/a

"Bob Barrows" <re******@NOyahoo.SPAMcom> wrote in message
news:%2****************@TK2MSFTNGP12.phx.gbl...
Alistair wrote:
and the second to last paragraph (or thereabouts) says...

I'VE ALREADY TRIED THAT!!!!
Where did you tell us that? You told us that you followed the instructions
to turn off simple file sharing and the Security tab still did not appear?

I just spent the last few minutes re-reading each of your posts and I failed
to see where you provided us with that information.

Why are we supposed to be able to read your mind? GODDAMMIT! WE ARE NOT
LOOKING OVER YOUR SHOULDER AS YOU ATTEMPT TO TROUBLESHOOT ... I'm losing
it. I'm done in this thread. Goodbye good luck


My post 11/12/2003 at 19:42

<snip>
I had already done everything in the instructions that bob was kind enough
to give me....
<snip>

those instructions include the bit about turning off simple file
sharing...so...

if I had followed these instructions (as stated) I have turned off simple
file sharing had I not??

to me that looks like I told you that I had done as recommended in the
instructions..or am I missing something..maybe my english isn't as good as
yours??

I'm not asking you to read my mind, just my posts

I am now waiting for my hard drive to be re-formatted and I'll start all
over again

I thank you all for your input.
Jul 19 '05 #18

P: n/a
> I am now waiting for my hard drive to be re-formatted and I'll start all
over again


Once it's reformatted, don't forget to uncheck simple file sharing. :)

Just a little webdev humor....
Jul 19 '05 #19

P: n/a

"Randy Rahbar" <rvrahbar@_JUNK_hotmail.com> wrote in message
news:%2****************@TK2MSFTNGP09.phx.gbl...

Just a little webdev humor....


That's exactly what's needed around here. I think maybe we should schedule
a rumble somewhere to work out all these arguments. Anyone close to Philly?

Ray at work
Jul 19 '05 #20

P: n/a
A rumble?!? You haven't been watching or reading some S.E. Hinton stuff
lately have you?


"Ray at <%=sLocation%>" <myfirstname at lane34 dot com> wrote in message
news:uJ**************@TK2MSFTNGP12.phx.gbl...

"Randy Rahbar" <rvrahbar@_JUNK_hotmail.com> wrote in message
news:%2****************@TK2MSFTNGP09.phx.gbl...

Just a little webdev humor....

That's exactly what's needed around here. I think maybe we should

schedule a rumble somewhere to work out all these arguments. Anyone close to Philly?
Ray at work

Jul 19 '05 #21

P: n/a
> That's exactly what's needed around here. I think maybe we should
schedule
a rumble somewhere to work out all these arguments. Anyone close to

Philly?

Nope, Florida... but I'd pay money to fly up and see that.
Jul 19 '05 #22

P: n/a
LOL. Yeah, I read the Outsiders today in between usenet posts. ;]

Ray at work

"TomB" <sh*****@hotmailXXX.com> wrote in message
news:eM**************@TK2MSFTNGP11.phx.gbl...
A rumble?!? You haven't been watching or reading some S.E. Hinton stuff
lately have you?


"Ray at <%=sLocation%>" <myfirstname at lane34 dot com> wrote in message
news:uJ**************@TK2MSFTNGP12.phx.gbl...

"Randy Rahbar" <rvrahbar@_JUNK_hotmail.com> wrote in message
news:%2****************@TK2MSFTNGP09.phx.gbl...

Jul 19 '05 #23

This discussion thread is closed

Replies have been disabled for this discussion.