469,076 Members | 1,501 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,076 developers. It's quick & easy.

Migration to Windows 2003, Error Messages not shown in Browser

I recently upgraded my servers to 2003. Since then the error-information
shown in the browser has changed.

For example, if under Windows 2000 I executed an SQL statement from within
an ASP, and the SQL statement was syntactically incorrect, the error thrown
by ADO would finally show up in the client browser.

If I do the same with an Windows 2003 Server, only a "HTTP 500, internal
server error" is sent to to client browser. The IIS LogFiles still show the
actual error, but looking there is not that comfortable.

Is this some configuration that can be done on the Windows 2003 server?

Michael G. Schneider
Jul 19 '05 #1
3 2318
Is the browser in question on the same machine as it was before? If not, go
to Tools, Internet Options, Advanced, and make sure that the Show Friendly
messages box is unchecked.

"Michael G. Schneider" <mg**********@mgs-software.de> wrote in message
news:Op*************@tk2msftngp13.phx.gbl...
I recently upgraded my servers to 2003. Since then the error-information
shown in the browser has changed.

For example, if under Windows 2000 I executed an SQL statement from within
an ASP, and the SQL statement was syntactically incorrect, the error thrown by ADO would finally show up in the client browser.

If I do the same with an Windows 2003 Server, only a "HTTP 500, internal
server error" is sent to to client browser. The IIS LogFiles still show the actual error, but looking there is not that comfortable.

Is this some configuration that can be done on the Windows 2003 server?

Michael G. Schneider

Jul 19 '05 #2
"middletree" <mi********@htomail.com> schrieb im Newsbeitrag
news:uQ**************@TK2MSFTNGP09.phx.gbl...
Is the browser in question on the same machine as it was before? If not, go to Tools, Internet Options, Advanced, and make sure that the Show Friendly
messages box is unchecked.


It is the same workstation, same browser. If this browser is used with a
Windows 2000 Server ASP application, the full message is shown. So I suspect
that it is a server-side question.

Michael G. Schneider
Jul 19 '05 #3
"middletree" <mi********@htomail.com> schrieb im Newsbeitrag
news:uQ**************@TK2MSFTNGP09.phx.gbl...
Is the browser in question on the same machine as it was before? If not, go to Tools, Internet Options, Advanced, and make sure that the Show Friendly
messages box is unchecked.


Sorry, my last post, a couple of minutes ago, was wrong.

It was indeed a setting in Internet Explorer. Translated from German the
setting reads "Short HTTP-Error Messages". When unchecked, the error
messages are shown correctly.

Thank's a lot for your help.

Michael G. Schneider
Jul 19 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

6 posts views Thread by Nathan Sokalski | last post: by
3 posts views Thread by Scott | last post: by
2 posts views Thread by Joseph Geretz | last post: by
3 posts views Thread by Lumpierbritches | last post: by
1 post views Thread by Bonggoy Cruz | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.