By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,356 Members | 2,752 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,356 IT Pros & Developers. It's quick & easy.

What is "anonymous web user account"?

P: n/a
CM
Hi, There:
I am working on a commercial ASP web application which use MS Access 2000 as
database.

When configuring the database access, I got an error saying that this
database is a read-only database. I checked the database property, it shows
that this database is archive, not read only (The database property is found
by:open database and then File -> Database properties -> on the General tag.
there is no way to change these property, as these boxes are gray, not
enabled.). I can directly make change on the database using Access, so, my
guess is the problem is not really database related, am I right?

According to the instruction of the software, the database folder must have
read and write permissions given to the "anonymous web user account", I have
set the database folder to share and gave all permissions to "anonymous
logon " and "every one", but the problem is still there. I am just
wondering, what is the "anonymous web user account" in Windows 2000 server
and IIS?

Anyone can help?

CM
Jul 19 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
"CM" <cm***@hotmail.com> wrote in message
news:eq**************@TK2MSFTNGP10.phx.gbl...
Hi, There:
I am working on a commercial ASP web application which use MS Access 2000 as database.

When configuring the database access, I got an error saying that this
database is a read-only database. I checked the database property, it shows that this database is archive, not read only (The database property is found by:open database and then File -> Database properties -> on the General tag. there is no way to change these property, as these boxes are gray, not
enabled.). I can directly make change on the database using Access, so, my
guess is the problem is not really database related, am I right?

According to the instruction of the software, the database folder must have read and write permissions given to the "anonymous web user account", I have set the database folder to share and gave all permissions to "anonymous
logon " and "every one", but the problem is still there. I am just
wondering, what is the "anonymous web user account" in Windows 2000 server
and IIS?


The account is named IUSR_yourservername. See here to learn how IIS uses
the IUSR account for anonymous access:
http://support.microsoft.com/?kbid=264921

Also, the problem is not with "share" permissions, but rather NTFS
permissions.
http://www.aspfaq.com/database.asp
http://www.aspfaq.com/show.asp?id=2009

--
Tom Kaminski IIS MVP
http://www.iistoolshed.com/ - tools, scripts, and utilities for running IIS
http://mvp.support.microsoft.com/
http://www.microsoft.com/windowsserv...y/centers/iis/

Jul 19 '05 #2

P: n/a
CM
Hi, Tom:

Thanks for your reply. It really contains very useful information. However,
I am not familiar with windows administration, could you please tell me how
to grant "Log On Locally" permissions to IUSR_yourservername? In the
property of IUSR_yourservername, I cannot find "Log on locally". Where is
the permission located?

Thanks!
CM

The account is named IUSR_yourservername. See here to learn how IIS uses
the IUSR account for anonymous access:
http://support.microsoft.com/?kbid=264921

Also, the problem is not with "share" permissions, but rather NTFS
permissions.
http://www.aspfaq.com/database.asp
http://www.aspfaq.com/show.asp?id=2009

--
Tom Kaminski IIS MVP
http://www.iistoolshed.com/ - tools, scripts, and utilities for running IIS http://mvp.support.microsoft.com/
http://www.microsoft.com/windowsserv...y/centers/iis/

Jul 19 '05 #3

P: n/a
"CM" <cm***@hotmail.com> wrote in message
news:OC**************@TK2MSFTNGP10.phx.gbl...
Thanks for your reply. It really contains very useful information. However, I am not familiar with windows administration, could you please tell me how to grant "Log On Locally" permissions to IUSR_yourservername? In the
property of IUSR_yourservername, I cannot find "Log on locally". Where is the permission located?


You don't need to do that. It works fine right "out of the box" with
Access if you simply grant the account read/write permissions to the
file and folder it is in.
The less things you change the better off you are, *especially* if you
are not familiar with Windows administration.

--

Phillip Windell [CCNA, MVP, MCP]
WAND-TV (ABC Affiliate)
www.wandtv.com
Jul 19 '05 #4

P: n/a
"CM" <cm***@hotmail.com> wrote in message
news:OC**************@TK2MSFTNGP10.phx.gbl...
Hi, Tom:

Thanks for your reply. It really contains very useful information. However, I am not familiar with windows administration, could you please tell me how to grant "Log On Locally" permissions to IUSR_yourservername? In the
property of IUSR_yourservername, I cannot find "Log on locally". Where is
the permission located?


The account will have that permission by default. To manually assign the
"Log on Locally" right, open Administrative Tools and select Local Security
Policy. In Security settings, expand Local Policies and User Right
Assignment. Click Log on locally, and then click Add.

--
Tom Kaminski IIS MVP
http://www.iistoolshed.com/ - tools, scripts, and utilities for running IIS
http://mvp.support.microsoft.com/
http://www.microsoft.com/windowsserv...y/centers/iis/

Jul 19 '05 #5

P: n/a
CM
Thanks a lot!
The strange thing is, I give even admin's permission to the
IUSR_yourservername, but it still not working. However, after I checked and
debugged the offence asp page (actually, I didn't change any thing), the
error disappeared, even after I tool away the admin permission.
Anywhere, you did give me a lot of useful experience and knowledge. Thank
you!
CM

"Tom Kaminski [MVP]" <tomk (A@T) mvps (D.O.T) org> wrote in message
news:bp*********@kcweb01.netnews.att.com...
"CM" <cm***@hotmail.com> wrote in message
news:OC**************@TK2MSFTNGP10.phx.gbl...
Hi, Tom:

Thanks for your reply. It really contains very useful information. However,
I am not familiar with windows administration, could you please tell me

how
to grant "Log On Locally" permissions to IUSR_yourservername? In the
property of IUSR_yourservername, I cannot find "Log on locally". Where is the permission located?


The account will have that permission by default. To manually assign the
"Log on Locally" right, open Administrative Tools and select Local

Security Policy. In Security settings, expand Local Policies and User Right
Assignment. Click Log on locally, and then click Add.

--
Tom Kaminski IIS MVP
http://www.iistoolshed.com/ - tools, scripts, and utilities for running IIS http://mvp.support.microsoft.com/
http://www.microsoft.com/windowsserv...y/centers/iis/

Jul 19 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.