470,811 Members | 1,144 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,811 developers. It's quick & easy.

problem posting data from asp form

I am running IIS5, Win2k Server, and .Net Framework 1.1.

For some reason asp forms will not post data. So I have
a form with a text box. The form's method is set to post
and I have a submit button.

The weird thing is that the page works fine without using
SSL and/or the FQDN for the server.

So if I access the page using
https://server.blah.com/page.asp it will not work.

If I access the page using https://server/page.asp it
works.

If I access the page using
http://server.blah.com/page.asp it works.

Any help would be appreciated. Here is the source for
default.asp:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0
Transitional//EN">
<html>
<head>
<title></title>
<meta name="GENERATOR"
content="Microsoft Visual Studio .NET 7.1">
<meta name="vs_targetSchema"
content="http://schemas.microsoft.com/intellisense/ie5">
</head>
<body>
<form id="frmMain" name="frmMain"
action="default.asp" method="post">
<input type="text" id="txt"
name="txt" value=<%=Request.Form("txt")%>>
<input type="submit"
value="submit">
</form>
</body>
</html>

Jul 19 '05 #1
3 2055
Are you using NT authentication? If so, there is a known issue with this
and IE, and I can try to find some links about it.

Ray at work

"Logan" <lo***************@cisf.af.mil> wrote in message
news:29****************************@phx.gbl...
I am running IIS5, Win2k Server, and .Net Framework 1.1.

For some reason asp forms will not post data. So I have
a form with a text box. The form's method is set to post
and I have a submit button.

The weird thing is that the page works fine without using
SSL and/or the FQDN for the server.

So if I access the page using
https://server.blah.com/page.asp it will not work.

If I access the page using https://server/page.asp it
works.

If I access the page using
http://server.blah.com/page.asp it works.

Any help would be appreciated. Here is the source for
default.asp:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0
Transitional//EN">
<html>
<head>
<title></title>
<meta name="GENERATOR"
content="Microsoft Visual Studio .NET 7.1">
<meta name="vs_targetSchema"
content="http://schemas.microsoft.com/intellisense/ie5">
</head>
<body>
<form id="frmMain" name="frmMain"
action="default.asp" method="post">
<input type="text" id="txt"
name="txt" value=<%=Request.Form("txt")%>>
<input type="submit"
value="submit">
</form>
</body>
</html>

Jul 19 '05 #2

Some of my pages are using NT Authentication, but others aren't. I
would appreciate any articles that you could dig up.

I am aware of a problen with NT Authentication and FQDNs.

Thank you.
*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Jul 19 '05 #3
Here's the KB article... http://support.microsoft.com/?id=308074

Ray at work

"Logan Schoonmaker" <lo***************@cisf.af.mil> wrote in message
news:ue*************@tk2msftngp13.phx.gbl...

Some of my pages are using NT Authentication, but others aren't. I
would appreciate any articles that you could dig up.

I am aware of a problen with NT Authentication and FQDNs.

Thank you.
*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!

Jul 19 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

7 posts views Thread by Aaron Prohaska | last post: by
1 post views Thread by Lovely Angel For You | last post: by
4 posts views Thread by NohaKhalifa | last post: by
15 posts views Thread by JR | last post: by
1 post views Thread by Frankieboy | last post: by
6 posts views Thread by Robin Bonin | last post: by
reply views Thread by mihailmihai484 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.