By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
429,423 Members | 1,601 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 429,423 IT Pros & Developers. It's quick & easy.

"Object already exists" error when trying to send email

P: n/a
My email application was working a couple of weeks ago,
then all of a sudden I get

Error Type:
(0x8009000F)
Object already exists.

I checked the permissions on the machinekeys directory
like the KB article said it still doesn't work. Does
have any ideas?

Thanks,
David

I am using Windows 2000 server SP4.
Below is the code that I am using
<%
strFrom = "we*******@msn.com"
strTo = "w8****@msn.com"
strSubject = "Email Test"
strBody = "It must have worked"
set myCDONTSMail = CreateObject("CDONTS.NewMail")
myCDONTSMail.Send strFrom, strTo, strSubject, strBody
set myCDONTSMail = Nothing
%>
Jul 19 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Are you sure that is the code in error? Is there a line number indicated?
One thing to try is to add SERVER. before CreateObject:

set myCDONTSMail = SERVER.CreateObject("CDONTS.NewMail")

Also, have a look at http://www.aspfaq.com/2119 and see the Windows XP
section. You should try to start using CDOSYS for e-mail instead of CDONTS.

Ray at work

"David" <w8****@msn.com> wrote in message
news:0b****************************@phx.gbl...
My email application was working a couple of weeks ago,
then all of a sudden I get

Error Type:
(0x8009000F)
Object already exists.

I checked the permissions on the machinekeys directory
like the KB article said it still doesn't work. Does
have any ideas?

Thanks,
David

I am using Windows 2000 server SP4.
Below is the code that I am using
<%
strFrom = "we*******@msn.com"
strTo = "w8****@msn.com"
strSubject = "Email Test"
strBody = "It must have worked"
set myCDONTSMail = CreateObject("CDONTS.NewMail")
myCDONTSMail.Send strFrom, strTo, strSubject, strBody
set myCDONTSMail = Nothing
%>

Jul 19 '05 #2

P: n/a
Perhaps try using a very simple e-mail page for testing. And if that
doesn't work, contact the Web host's tech support.

Best regards,
J. Paul Schmidt, Freelance ASP Web Developer
http://www.Bullschmidt.com
ASP Design Tips, ASP Web Database Demo, Free ASP Bar Chart Tool...
*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Jul 19 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.