By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
458,165 Members | 1,508 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 458,165 IT Pros & Developers. It's quick & easy.

cookie problem

P: n/a
I got several forms on the intranet that require login + some cookie.
I created a central login page with "HTTP_REFERER" so it
redirects the user back to the currect page with a cookie setup.
The redirect works fine, the problem is that the cookie doesn't get set.
If the login is within the same foldre as the form, there is no problem,
but then i can't have a central location for the login.
here is my cookie.

Name = rcset("Firstname")
Response.Cookies("som_userName")=(name)
Response.Cookies("som_userName").Expires = Date + 5

Thanks in adavanced.
Jul 19 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Check in IIS to see if you have any applications defined on subdirectories
in your site.

Also make sure that you are not accessing the intranet by computername and
the computername has an underscore in it. If it does, cane the person who
named it.

Ray at work

"alexz" <al*****@hotmail.com> wrote in message
news:43**************************@posting.google.c om...
I got several forms on the intranet that require login + some cookie.
I created a central login page with "HTTP_REFERER" so it
redirects the user back to the currect page with a cookie setup.
The redirect works fine, the problem is that the cookie doesn't get set.
If the login is within the same foldre as the form, there is no problem,
but then i can't have a central location for the login.
here is my cookie.

Name = rcset("Firstname")
Response.Cookies("som_userName")=(name)
Response.Cookies("som_userName").Expires = Date + 5

Thanks in adavanced.

Jul 19 '05 #2

P: n/a
Ignore what I said about the application thing. I was thinking of session
variables and what not.

Ray at work

"Ray at <%=sLocation%>" <myfirstname at lane34 dot com> wrote in message
news:uw**************@TK2MSFTNGP11.phx.gbl...
Check in IIS to see if you have any applications defined on subdirectories
in your site.

Also make sure that you are not accessing the intranet by computername and
the computername has an underscore in it. If it does, cane the person who
named it.

Ray at work

"alexz" <al*****@hotmail.com> wrote in message
news:43**************************@posting.google.c om...
I got several forms on the intranet that require login + some cookie.
I created a central login page with "HTTP_REFERER" so it
redirects the user back to the currect page with a cookie setup.
The redirect works fine, the problem is that the cookie doesn't get set.
If the login is within the same foldre as the form, there is no problem,
but then i can't have a central location for the login.
here is my cookie.

Name = rcset("Firstname")
Response.Cookies("som_userName")=(name)
Response.Cookies("som_userName").Expires = Date + 5

Thanks in adavanced.


Jul 19 '05 #3

P: n/a
article here :

http://rtfm.atrax.co.uk/infinitemonk...es/asp/910.asp

explains the reason.


________________________________________
Atrax. MVP, IIS
http://rtfm.atrax.co.uk/

newsflash : Atrax.Richedit 1.0 now released.
http://rtfm.atrax.co.uk/infinitemonk...trax.RichEdit/

*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
Jul 19 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.