By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,871 Members | 2,595 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,871 IT Pros & Developers. It's quick & easy.

International character dissapears from FORM

P: n/a
Hi.
I am having problems sending values from a simple FORM to a database.
All is written in ASP, and I am doing some validations before it is
actually saved in my database.

It worked for several years, but now it won't accept international
characters. This means that the Norwegian word for boat "BT" ends up
like "BT" since the "" isn't sent.

I have done several testings, and it actually looks like the error
occurs immidiately after I hit the submit-button.

Does anybody know why this problem has occured?
Looking forward to your answers.
royend...

Jun 21 '06 #1
Share this Question
Share on Google+
7 Replies


P: n/a
use the character codes, not the actual letter. so when the character is
posted.....try to convert it......

<%
varItsStoredIn = Replace(varItsStoredIn, "", "")
%>
hope this helps ya.



<ro****@gmail.com> wrote in message
news:11**********************@r2g2000cwb.googlegro ups.com...
Hi.
I am having problems sending values from a simple FORM to a database.
All is written in ASP, and I am doing some validations before it is
actually saved in my database.

It worked for several years, but now it won't accept international
characters. This means that the Norwegian word for boat "BT" ends up
like "BT" since the "" isn't sent.

I have done several testings, and it actually looks like the error
occurs immidiately after I hit the submit-button.

Does anybody know why this problem has occured?
Looking forward to your answers.
royend...
Jun 21 '06 #2

P: n/a
I have actually tried converting the letters with ASP, but the problem
is that the string is transformed before it reaches the ASP.

In my .asp-file I have
Response.Write(Request.Form("text"))
as my first line, and it still don't contain the international
letters....

I really don't get this one, as I have multiple forms that actually
does send everything perfect.

royend :|
James Jones wrote:
use the character codes, not the actual letter. so when the character is
posted.....try to convert it......

<%
varItsStoredIn = Replace(varItsStoredIn, "", "")
%>


hope this helps ya.


Jun 21 '06 #3

P: n/a
wrote on 21 jun 2006 in microsoft.public.inetserver.asp.general:
James Jones wrote:
use the character codes, not the actual letter. so when the character
is posted.....try to convert it......

<%
varItsStoredIn = Replace(varItsStoredIn, "", "")
%>

I have actually tried converting the letters with ASP, but the problem
is that the string is transformed before it reaches the ASP.

In my .asp-file I have
Response.Write(Request.Form("text"))
as my first line, and it still don't contain the international
letters....

I really don't get this one, as I have multiple forms that actually
does send everything perfect.


I strongly suspect it has to do with the character set used by your
browser. Try rightclicking on the page in IE and try different
"encoding"s.

ASP can set these for you in the header.

Under ASP try different "code-pages":

How?
<http://www.html.dk/dokumentation/objects/asp/iiapmls.htm>

Baltic:
<http://www.microsoft.com/globaldev/reference/iso/28594.mspx>

More:
<http://www.microsoft.com/globaldev/reference/wincp.mspx>
--
Evertjan.
The Netherlands.
(Please change the x'es to dots in my emailaddress)
Jun 21 '06 #4

P: n/a
Thanks for the advice, but still it didn't work. This is a real
challenge as I need this to get working.

Another tips for those looking for their LCID-code:
http://www.microsoft.com/globaldev/r.../lcid-all.mspx

Still looking for the correct answer to my problem though.
Thanks for all your tips so far.
royend:)

Jun 21 '06 #5

P: n/a
wrote on 21 jun 2006 in microsoft.public.inetserver.asp.general:
Thanks for the advice, but still it didn't work. This is a real
challenge as I need this to get working.


Please quote what you are replying to.

If you want to post a followup via groups.google.com, don't use the
"Reply" link at the bottom of the article. Click on "show options" at the
top of the article, then click on the "Reply" at the bottom of the article
headers.

<http://www.safalra.com/special/googlegroupsreply/>

--
Evertjan.
The Netherlands.
(Please change the x'es to dots in my emailaddress)
Jun 21 '06 #6

P: n/a
Thanks for your tip!

Evertjan. wrote:
Please quote what you are replying to.

If you want to post a followup via groups.google.com, don't use the
"Reply" link at the bottom of the article. Click on "show options" at the
top of the article, then click on the "Reply" at the bottom of the article
headers.

<http://www.safalra.com/special/googlegroupsreply/>


I will use this technique from now on.
Still, no solution to the problem though...
royend

Jun 22 '06 #7

P: n/a
wrote on 22 jun 2006 in microsoft.public.inetserver.asp.general:
Thanks for your tip!

Evertjan. wrote:
Please quote what you are replying to.

If you want to post a followup via groups.google.com, don't use the
"Reply" link at the bottom of the article. Click on "show options" at
the top of the article, then click on the "Reply" at the bottom of
the article headers.

<http://www.safalra.com/special/googlegroupsreply/>


I will use this technique from now on.
Still, no solution to the problem though...
royend


What problem? ;-)

--
Evertjan.
The Netherlands.
(Please change the x'es to dots in my emailaddress)
Jun 22 '06 #8

This discussion thread is closed

Replies have been disabled for this discussion.