469,328 Members | 1,316 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,328 developers. It's quick & easy.

IIS 5.1 on XP Pro cannot serve ASP classic

Hi all,

I just got a new laptop, Windows XP Pro SP2. I installed IIS 5.1 using
add/remove Windows Components.
I installed Visual Studio 6 SP6 and Visual Studio .Net (I need both of
them).
Exact same setup was working fine on my old laptop.

On the new laptop:
IIS will serve .aspx and .html pages no problem.
When I try a classic .asp page, I get -2147467259 (0x80004005) as my
only response, and Error 500 in the IIS log. No events in the event
log, no other information anywhere that I can find.
I gave IUSR_computername full permissions to the wwwroot directory: no
luck.
I tried copying the entire inetsrv directory from my old laptop to the
new one (including asp.dll), but IIS goes completely haywire, so I had
to restore the original directory.

Any ideas on how to tackle this? If at least I could find a bit more
information about the actual error somewhere!

Regards,
Assaf

May 30 '06 #1
12 10059
Hi,

Try following steps:

1. Start / Run, type cmd

2. Type cd \wwwroot\adminscripts

3. Run the following command:

Adsutil set /w3svc/Appisolated 0

4. Run iisreset to restart IIS server

5. Try browsing ASP page

If this does not help please provide some information:

-Did you enable ASP pages in IIS 5.1?

-Which version of .NET Framework are you using?

Regards,

Anton Pegan
"spinkysam" <sp*******@gmail.com> wrote in message
news:11**********************@g10g2000cwb.googlegr oups.com...
Hi all,

I just got a new laptop, Windows XP Pro SP2. I installed IIS 5.1 using
add/remove Windows Components.
I installed Visual Studio 6 SP6 and Visual Studio .Net (I need both of
them).
Exact same setup was working fine on my old laptop.

On the new laptop:
IIS will serve .aspx and .html pages no problem.
When I try a classic .asp page, I get -2147467259 (0x80004005) as my
only response, and Error 500 in the IIS log. No events in the event
log, no other information anywhere that I can find.
I gave IUSR_computername full permissions to the wwwroot directory: no
luck.
I tried copying the entire inetsrv directory from my old laptop to the
new one (including asp.dll), but IIS goes completely haywire, so I had
to restore the original directory.

Any ideas on how to tackle this? If at least I could find a bit more
information about the actual error somewhere!

Regards,
Assaf

May 30 '06 #2
Hi Anton,

Not sure what you mean by enabling ASP pages in IIS 5.1. In the past
they were always enabled by default after installing.
Anyway, when I go to IIS manager -> Default Web Site Properties -> Home
Directory -> Configuration... -> Mappings, I see the .asp extension
mapped to c:\Windows\system32\inetsrv\asp.dll, which I assume means ASP
is enabled?

I'm using .Net framework v1.1.4322.2032.
Though I'm not sure why .Net should enter the picture. When you install
the .Net framework, it shouldn't affect the DLLs in charge of serving
classic ASP pages (inetsrv/asp.dll, etc.), should it?

Regards,
Assaf

May 30 '06 #3
Hi Anton,

Not sure what you mean by enabling ASP pages in IIS 5.1. In the past
they were always enabled by default after installing.
Anyway, when I go to IIS manager -> Default Web Site Properties -> Home
Directory -> Configuration... -> Mappings, I see the .asp extension
mapped to c:\Windows\system32\inetsrv\asp.dll, which I assume means ASP
is enabled?

I'm using .Net framework v1.1.4322.2032.
Though I'm not sure why .Net should enter the picture. When you install
the .Net framework, it shouldn't affect the DLLs in charge of serving
classic ASP pages (inetsrv/asp.dll, etc.), should it?

Regards,
Assaf

May 30 '06 #4
On 30 May 2006 00:58:22 -0700, "spinkysam" <sp*******@gmail.com>
wrote:
When I try a classic .asp page, I get -2147467259 (0x80004005) as my
only response, and Error 500 in the IIS log. No events in the event
log, no other information anywhere that I can find.


See:

http://www.aspfaq.com/show.asp?id=2009
http://www.aspfaq.com/show.asp?id=2413

Jeff
May 30 '06 #5
spinkysam wrote:
Hi all,

I just got a new laptop, Windows XP Pro SP2. I installed IIS 5.1 using
add/remove Windows Components.
I installed Visual Studio 6 SP6 and Visual Studio .Net (I need both of
them).
Exact same setup was working fine on my old laptop.

On the new laptop:
IIS will serve .aspx and .html pages no problem.
When I try a classic .asp page, I get -2147467259 (0x80004005) as my
only response, and Error 500 in the IIS log. No events in the event
log, no other information anywhere that I can find.
I gave IUSR_computername full permissions to the wwwroot directory: no
luck.
I tried copying the entire inetsrv directory from my old laptop to the
new one (including asp.dll), but IIS goes completely haywire, so I had
to restore the original directory.

Any ideas on how to tackle this? If at least I could find a bit more
information about the actual error somewhere!

http://www.aspfaq.com/show.asp?id=2147
http://www.aspfaq.com/show.asp?id=2413
http://www.aspfaq.com/show.asp?id=2226
http://www.aspfaq.com/show.asp?id=2109

--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap so I
don't check it very often. If you must reply off-line, then remove the
"NO SPAM"
May 30 '06 #6
Hi all,

Anton - thanks for your suggestions. I did try to unregister and
re-register asp.dll and succeeded, but still no luck on IIS.
I also ran the steps in your previous post - no luck.
Always with iisreset after every step.

For information, the page I'm trying is simply:
<% Response.Write "<h1>Hello world</h1>" %>
When I say I get no other text, I mean literally no other text. The
full response is:
"-2147467259 (0x80004005)" - no ASP error number, no nothing.

Regarding the many suggestions from pages on aspfaq.com:

*http://www.aspfaq.com/show.asp?id=2147*
I tried "cscript synciwam.vbs" as suggested. No luck.
*http://www.aspfaq.com/show.asp?id=2226*
Not getting any events in event viewer (let alone number 36)
*http://www.aspfaq.com/show.asp?id=2109*
Using Firefox, not IE :) (but getting identical behaviour on IE when I
turn off friendly errors)
*http://www.aspfaq.com/show.asp?id=2009*
Not trying to access a database
*http://www.aspfaq.com/show.asp?id=2413*
Since I'm not getting any message at all, the only possible culprit on
this page is setting Server.ScriptTimeout to a negative value - in my
case, it's the default (90 seconds)

Is there any other known reason out there for an 0x80004005 error with
no message at all?

Going a bit crazy here, so any help would be appreciated.

Regards,
Assaf

May 30 '06 #7

spinkysam wrote:
Hi all,

Anton - thanks for your suggestions. I did try to unregister and
re-register asp.dll and succeeded, but still no luck on IIS.
I also ran the steps in your previous post - no luck.
Always with iisreset after every step.

For information, the page I'm trying is simply:
<% Response.Write "<h1>Hello world</h1>" %>
When I say I get no other text, I mean literally no other text. The
full response is:
"-2147467259 (0x80004005)" - no ASP error number, no nothing.

Regarding the many suggestions from pages on aspfaq.com:

*http://www.aspfaq.com/show.asp?id=2147*
I tried "cscript synciwam.vbs" as suggested. No luck.
*http://www.aspfaq.com/show.asp?id=2226*
Not getting any events in event viewer (let alone number 36)
*http://www.aspfaq.com/show.asp?id=2109*
Using Firefox, not IE :) (but getting identical behaviour on IE when I
turn off friendly errors)
*http://www.aspfaq.com/show.asp?id=2009*
Not trying to access a database
*http://www.aspfaq.com/show.asp?id=2413*
Since I'm not getting any message at all, the only possible culprit on
this page is setting Server.ScriptTimeout to a negative value - in my
case, it's the default (90 seconds)

Is there any other known reason out there for an 0x80004005 error with
no message at all?

Going a bit crazy here, so any help would be appreciated.

Regards,
Assaf


In IIS, go to the properties for the web site directory you are trying
to access (probably default) and try setting the application protection
to Low. See if that does the trick.

--
Mike Brind

May 30 '06 #8
Hi Mike,

Amazing, that did the trick! Who would have thought it?
Thank you - I definitely owe you a pint for that one.

Regards,
Assaf

May 30 '06 #9

spinkysam wrote:
Hi Mike,

Amazing, that did the trick! Who would have thought it?
Thank you - I definitely owe you a pint for that one.

Regards,
Assaf


To be fair, it is one of the first suggestions in the first link that
Bob provided (http://www.aspfaq.com/show.asp?id=2147), and it has come
up as a solution on this news group before.

--
Mike Brind

May 30 '06 #10
Mike Brind wrote:
Is there any other known reason out there for an 0x80004005 error
with no message at all?

Going a bit crazy here, so any help would be appreciated.

Regards,
Assaf


In IIS, go to the properties for the web site directory you are trying
to access (probably default) and try setting the application
protection to Low. See if that does the trick.

I've never had to do this. What is the root problem that would make
someone have to do this?

--
Microsoft MVP -- ASP/ASP.NET
Please reply to the newsgroup. The email account listed in my From
header is my spam trap, so I don't check it very often. You will get a
quicker response by posting to the newsgroup.
May 30 '06 #11
Bob Barrows [MVP] wrote:
Mike Brind wrote:
Is there any other known reason out there for an 0x80004005 error
with no message at all?

Going a bit crazy here, so any help would be appreciated.

Regards,
Assaf


In IIS, go to the properties for the web site directory you are
trying to access (probably default) and try setting the application
protection to Low. See if that does the trick.

I've never had to do this. What is the root problem that would make
someone have to do this?

Ah! I had forgotten about IWAM account problems. The answer can be found
here:
http://support.microsoft.com/default.aspx?kbid=309051

--
Microsoft MVP -- ASP/ASP.NET
Please reply to the newsgroup. The email account listed in my From
header is my spam trap, so I don't check it very often. You will get a
quicker response by posting to the newsgroup.
May 30 '06 #12

Bob Barrows [MVP] wrote:
Bob Barrows [MVP] wrote:
Mike Brind wrote:
Is there any other known reason out there for an 0x80004005 error
with no message at all?

Going a bit crazy here, so any help would be appreciated.

Regards,
Assaf

In IIS, go to the properties for the web site directory you are
trying to access (probably default) and try setting the application
protection to Low. See if that does the trick.

I've never had to do this. What is the root problem that would make
someone have to do this?

Ah! I had forgotten about IWAM account problems.


So it's true then... you really have forgotten more than most of us
will ever know!

:-)

--
Mike Brind

May 30 '06 #13

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

11 posts views Thread by Mark J. McGinty | last post: by
8 posts views Thread by Michael | last post: by
1 post views Thread by Jason Chan | last post: by
2 posts views Thread by JimO | last post: by
8 posts views Thread by sgottenyc | last post: by
reply views Thread by Purva khokhar | last post: by
reply views Thread by haryvincent176 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.