By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,489 Members | 1,954 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,489 IT Pros & Developers. It's quick & easy.

Security.Permissions.SecurityPermission

P: n/a
G'day,

I have 2 Win2K servers, 1 is my database server, 1 runs IIS

On the IIS machine I have an ASP.NET 2 application that makes a call to
a proprietry 3rd party COM Object/DLL that makes a call to a database
on server number 2.

When the DLL call is run, I get
"Security.Permissions.SecurityPermission" error and thats all it says.

Does anybody have any idea how I get around this? Im a newbie to ASP
and have full trust set in the web.config file.

Thanks in advance!

May 14 '06 #1
Share this Question
Share on Google+
1 Reply


P: n/a
ha********@gmail.com wrote:
G'day,

I have 2 Win2K servers, 1 is my database server, 1 runs IIS

On the IIS machine I have an ASP.NET 2 application that makes a call
to a proprietry 3rd party COM Object/DLL that makes a call to a
database on server number 2.

When the DLL call is run, I get
"Security.Permissions.SecurityPermission" error and thats all it says.
It sounds like you need to check with the writer of that dll.

Does anybody have any idea how I get around this? Im a newbie to ASP
and have full trust set in the web.config file.


There was no way for you to know it (except maybe by browsing through some
of the previous questions before posting yours - always a recommended
practice) , but this is a classic asp newsgroup. ASP.Net bears very little
resemblance to classic ASP so,
while you may be lucky enough to find a dotnet-knowledgeable person here who
can answer your question, you can eliminate the luck factor by posting your
question to a group where those dotnet-knowledgeable people hang out. I
suggest microsoft.public.dotnet.framework.aspnet.
--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap so I
don't check it very often. If you must reply off-line, then remove the
"NO SPAM"
May 14 '06 #2

This discussion thread is closed

Replies have been disabled for this discussion.