By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,688 Members | 1,226 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,688 IT Pros & Developers. It's quick & easy.

MS Access + ASP + ADO + OpenSchema + error - Unspecified Error

P: n/a
I am using MSAccess 2003 as my DB, ASP page my front end. My access file is
in the temp folder which ahs IUSR_Machine permissions. My asp page works
fine, connects to DB and retrieves what I want. Now, when I open my db file
in Microsoft Access in Exclusive mode my ASP page doest establish a
connection which is correct as exclusive open locks the files and prevents
further connections. Upto here no problem.
Now when I close that opened Microsoft Access instance, my web page resumes
working. If I refresh it, it works. The third time I refresh the page I get
"Unspecified Error". Again if I refresh it works and again if I refresh I
get "Unspecified error" when I debugged it fails at connection open.

Here is my code snippet..

if strConnString <> "" then
objConn.Mode = 3
objConn.ConnectionTimeout = 30
objConn.CursorLocation = 3 'adUseClient
objConn.open strConnString
set oTmpRs.ActiveConnection = objConn
Set oTmpRs = objConn.OpenSchema(4, Array(Empty, Empty,
tmpStrTable,Empty))
Set oTmpRs.ActiveConnection = Nothing
set rsColumns = oTmpRs.Clone
set oTmpRs = nothing
objConn.Close
end if

set objConn = nothing

Can anybody tell me what's wrong here..what could be the root cause of this
problem..

I tried almost all solutions I know and found in search engines..but not yet
solved this issue..

thanks

May 8 '06 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.