By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,159 Members | 1,941 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,159 IT Pros & Developers. It's quick & easy.

just installed IIS on W2k -- new to asp..

P: n/a
I just installed IIS in my W2k machine.. have hardly ever done any asp..
first thing I need to know is how do you change the port once it's
intalled (since http://localhost is address for my Tomcat (JSP
server..)) I see no read-me or config instructions with this install.
Thank you..

Apr 18 '06 #1
Share this Question
Share on Google+
14 Replies


P: n/a

"Frances" <fd***@yahoo.com> wrote in message
news:44***********************@news.sunsite.dk...
I just installed IIS in my W2k machine.. have hardly ever done any asp..
first thing I need to know is how do you change the port once it's
intalled (since http://localhost is address for my Tomcat (JSP
server..)) I see no read-me or config instructions with this install.
Thank you..


Not really an ASP question but...

Open the properties of the Default Web Site using IIS Manager

Next to the IP Address click Advanced...

(All Unassigned) | 80

should already be highlighted click Edit...

Change TCP Port to your chosen port number.
OK out the dialogs.

Anthony.
Apr 18 '06 #2

P: n/a
Anthony Jones wrote:
"Frances" <fd***@yahoo.com> wrote in message
news:44***********************@news.sunsite.dk...
I just installed IIS in my W2k machine.. have hardly ever done any asp..
first thing I need to know is how do you change the port once it's
intalled (since http://localhost is address for my Tomcat (JSP
server..)) I see no read-me or config instructions with this install.
Thank you..

Not really an ASP question but...

Open the properties of the Default Web Site using IIS Manager

Next to the IP Address click Advanced...

(All Unassigned) | 80

should already be highlighted click Edit...

Change TCP Port to your chosen port number.
OK out the dialogs.

Anthony.


thanks.. what is the "Default Web Site"? what is IIS Manger? (as I
said, there's no read-me file or config instructions here..)
since I have wrong port, hence can't view anything in a browser, I can't
open any "web site"..

in c:\Inetpub\wwwroot I see postinfo.html and _vit_inf.html, both of
these contain nothing but this:

The HTML comments in this page contain the configurationinformation that
allows users to edit pages in your web using the Microsoft Web
Publishing Wizard or programs which use the Microsoft Web Publishing
Wizard such as FrontPad using the same username and password they would
use if they were authoring with Microsoft FrontPage. Please refer to the
Microsoft's Internet SDK for more information on the Web Publishing
Wizard APIs.
found some .asp's (localstart.asp, iistart.asp, both in wwwroot and in
wwwroot\_vti_cnf), but can't access them thru browser b/c have to set
proper port for that...;)

does this server have to be "turned on" when you want to use it like you
have to with Tomcat (sorry, am quite familiar with Tomcat, is only ref I
have here.. to start Tomcat you run a batch file called startup.bat..)
thanks..

thank you...
Apr 18 '06 #3

P: n/a

"Frances" <fd***@yahoo.com> wrote in message
news:44***********************@news.sunsite.dk...
Anthony Jones wrote:
"Frances" <fd***@yahoo.com> wrote in message
news:44***********************@news.sunsite.dk...
I just installed IIS in my W2k machine.. have hardly ever done any asp..
first thing I need to know is how do you change the port once it's
intalled (since http://localhost is address for my Tomcat (JSP
server..)) I see no read-me or config instructions with this install.
Thank you..

Not really an ASP question but...

Open the properties of the Default Web Site using IIS Manager

Next to the IP Address click Advanced...

(All Unassigned) | 80

should already be highlighted click Edit...

Change TCP Port to your chosen port number.
OK out the dialogs.

Anthony.


thanks.. what is the "Default Web Site"? what is IIS Manger? (as I
said, there's no read-me file or config instructions here..)
since I have wrong port, hence can't view anything in a browser, I can't
open any "web site"..

in c:\Inetpub\wwwroot I see postinfo.html and _vit_inf.html, both of
these contain nothing but this:

The HTML comments in this page contain the configurationinformation that
allows users to edit pages in your web using the Microsoft Web
Publishing Wizard or programs which use the Microsoft Web Publishing
Wizard such as FrontPad using the same username and password they would
use if they were authoring with Microsoft FrontPage. Please refer to the
Microsoft's Internet SDK for more information on the Web Publishing
Wizard APIs.
found some .asp's (localstart.asp, iistart.asp, both in wwwroot and in
wwwroot\_vti_cnf), but can't access them thru browser b/c have to set
proper port for that...;)

does this server have to be "turned on" when you want to use it like you
have to with Tomcat (sorry, am quite familiar with Tomcat, is only ref I
have here.. to start Tomcat you run a batch file called startup.bat..)
thanks..

thank you...


Start -> control Panel -> Administrative Tools -> Internet Services Manager

Expand computer Tree

Right mouse click on 'Default Web Site' select Properties...
For further help try this:-

http://www.microsoft.com/windows2000...re/iihtmat.htm
Apr 18 '06 #4

P: n/a

Frances wrote:
Anthony Jones wrote:
"Frances" <fd***@yahoo.com> wrote in message
news:44***********************@news.sunsite.dk...
I just installed IIS in my W2k machine.. have hardly ever done any asp..
first thing I need to know is how do you change the port once it's
intalled (since http://localhost is address for my Tomcat (JSP
server..)) I see no read-me or config instructions with this install.
Thank you..

Not really an ASP question but...

Open the properties of the Default Web Site using IIS Manager

Next to the IP Address click Advanced...

(All Unassigned) | 80

should already be highlighted click Edit...

Change TCP Port to your chosen port number.
OK out the dialogs.

Anthony.


thanks.. what is the "Default Web Site"? what is IIS Manger? (as I
said, there's no read-me file or config instructions here..)
since I have wrong port, hence can't view anything in a browser, I can't
open any "web site"..

in c:\Inetpub\wwwroot I see postinfo.html and _vit_inf.html, both of
these contain nothing but this:

The HTML comments in this page contain the configurationinformation that
allows users to edit pages in your web using the Microsoft Web
Publishing Wizard or programs which use the Microsoft Web Publishing
Wizard such as FrontPad using the same username and password they would
use if they were authoring with Microsoft FrontPage. Please refer to the
Microsoft's Internet SDK for more information on the Web Publishing
Wizard APIs.
found some .asp's (localstart.asp, iistart.asp, both in wwwroot and in
wwwroot\_vti_cnf), but can't access them thru browser b/c have to set
proper port for that...;)

does this server have to be "turned on" when you want to use it like you
have to with Tomcat (sorry, am quite familiar with Tomcat, is only ref I
have here.. to start Tomcat you run a batch file called startup.bat..)
thanks..


Programs | Administrative Tools | Internet Information Services = IIS

It's the tool to let you let up all your physical and virtual sites,
ports, security, everything related to your website.

IIS is a service and is set up to start automatically when the box
boots up.

Apr 18 '06 #5

P: n/a
Anthony Jones wrote:
"Frances" <fd***@yahoo.com> wrote in message
news:44***********************@news.sunsite.dk...
Anthony Jones wrote:
"Frances" <fd***@yahoo.com> wrote in message
news:44***********************@news.sunsite.dk. ..
I just installed IIS in my W2k machine.. have hardly ever done any asp..
first thing I need to know is how do you change the port once it's
intalled (since http://localhost is address for my Tomcat (JSP
server..)) I see no read-me or config instructions with this install.
Thank you..

Not really an ASP question but...

Open the properties of the Default Web Site using IIS Manager

Next to the IP Address click Advanced...

(All Unassigned) | 80

should already be highlighted click Edit...

Change TCP Port to your chosen port number.
OK out the dialogs.

Anthony.


thanks.. what is the "Default Web Site"? what is IIS Manger? (as I
said, there's no read-me file or config instructions here..)
since I have wrong port, hence can't view anything in a browser, I can't
open any "web site"..

in c:\Inetpub\wwwroot I see postinfo.html and _vit_inf.html, both of
these contain nothing but this:

The HTML comments in this page contain the configurationinformation that
allows users to edit pages in your web using the Microsoft Web
Publishing Wizard or programs which use the Microsoft Web Publishing
Wizard such as FrontPad using the same username and password they would
use if they were authoring with Microsoft FrontPage. Please refer to the
Microsoft's Internet SDK for more information on the Web Publishing
Wizard APIs.
found some .asp's (localstart.asp, iistart.asp, both in wwwroot and in
wwwroot\_vti_cnf), but can't access them thru browser b/c have to set
proper port for that...;)

does this server have to be "turned on" when you want to use it like you
have to with Tomcat (sorry, am quite familiar with Tomcat, is only ref I
have here.. to start Tomcat you run a batch file called startup.bat..)
thanks..

thank you...

Start -> control Panel -> Administrative Tools -> Internet Services Manager

Expand computer Tree

Right mouse click on 'Default Web Site' select Properties...
For further help try this:-

http://www.microsoft.com/windows2000...re/iihtmat.htm


gosh, this is confusing.. can't find 'Internet Services Manager' under
Administrative Tools... :( looked under stuff that looked similar,
like 'Computer Management', but couldn't find 'Default Web Site'
anywhere.. I went to page you mention, but a search for 'port' came up
empty.. ('search' feature searches entire MS site, not just iis stuff;
and either way found nothing relating to setting port for IIS server..)

thanks again...

Apr 18 '06 #6

P: n/a
Frances wrote:
Anthony Jones wrote:
"Frances" <fd***@yahoo.com> wrote in message
news:44***********************@news.sunsite.dk...
Anthony Jones wrote:

"Frances" <fd***@yahoo.com> wrote in message
news:44***********************@news.sunsite.dk...
> I just installed IIS in my W2k machine.. have hardly ever done any
> asp..
> first thing I need to know is how do you change the port once it's
> intalled (since http://localhost is address for my Tomcat (JSP
> server..)) I see no read-me or config instructions with this install.
> Thank you..
>
Not really an ASP question but...

Open the properties of the Default Web Site using IIS Manager

Next to the IP Address click Advanced...

(All Unassigned) | 80

should already be highlighted click Edit...

Change TCP Port to your chosen port number.
OK out the dialogs.

Anthony.
thanks.. what is the "Default Web Site"? what is IIS Manger? (as I
said, there's no read-me file or config instructions here..)
since I have wrong port, hence can't view anything in a browser, I can't
open any "web site"..

in c:\Inetpub\wwwroot I see postinfo.html and _vit_inf.html, both of
these contain nothing but this:

The HTML comments in this page contain the configurationinformation that
allows users to edit pages in your web using the Microsoft Web
Publishing Wizard or programs which use the Microsoft Web Publishing
Wizard such as FrontPad using the same username and password they would
use if they were authoring with Microsoft FrontPage. Please refer to the
Microsoft's Internet SDK for more information on the Web Publishing
Wizard APIs.
found some .asp's (localstart.asp, iistart.asp, both in wwwroot and in
wwwroot\_vti_cnf), but can't access them thru browser b/c have to set
proper port for that...;)

does this server have to be "turned on" when you want to use it like you
have to with Tomcat (sorry, am quite familiar with Tomcat, is only ref I
have here.. to start Tomcat you run a batch file called startup.bat..)
thanks..

thank you...


Start -> control Panel -> Administrative Tools -> Internet Services
Manager

Expand computer Tree

Right mouse click on 'Default Web Site' select Properties...
For further help try this:-

http://www.microsoft.com/windows2000...re/iihtmat.htm

gosh, this is confusing.. can't find 'Internet Services Manager' under
Administrative Tools... :( looked under stuff that looked similar,
like 'Computer Management', but couldn't find 'Default Web Site'
anywhere.. I went to page you mention, but a search for 'port' came up
empty.. ('search' feature searches entire MS site, not just iis stuff;
and either way found nothing relating to setting port for IIS server..)

thanks again...


this is at work, I also have an XP machnine, installed IIS in XP
machine, found 'Internet Services Manager' no problem (don't have to
change port for that one, though (for now) since don't have Tomcat in
that machine..) am running my first little 'hello world' asp in XP
machine w/no problems.. why can't I find 'Internet Services Manager'
in Windows 2000 (exact version is Windows 2000 Professional) in XP was
able to find 'Internet Services Manager' even before I installed IIS..

thanks again..
Apr 18 '06 #7

P: n/a
Frances wrote:
<please do some snipping, thanks>
this is at work, I also have an XP machnine, installed IIS in XP
machine, found 'Internet Services Manager' no problem (don't have to
change port for that one, though (for now) since don't have Tomcat in
that machine..) am running my first little 'hello world' asp in XP
machine w/no problems.. why can't I find 'Internet Services Manager'
in Windows 2000 (exact version is Windows 2000 Professional) in XP was
able to find 'Internet Services Manager' even before I installed IIS..

Does this help?
http://www.microsoft.com/windows2000...e/iisnapin.htm

--
Microsoft MVP -- ASP/ASP.NET
Please reply to the newsgroup. The email account listed in my From
header is my spam trap, so I don't check it very often. You will get a
quicker response by posting to the newsgroup.
Apr 18 '06 #8

P: n/a
Bob Barrows [MVP] wrote:
Frances wrote:
<please do some snipping, thanks>
this is at work, I also have an XP machnine, installed IIS in XP
machine, found 'Internet Services Manager' no problem (don't have to
change port for that one, though (for now) since don't have Tomcat in
that machine..) am running my first little 'hello world' asp in XP
machine w/no problems.. why can't I find 'Internet Services Manager'
in Windows 2000 (exact version is Windows 2000 Professional) in XP was
able to find 'Internet Services Manager' even before I installed IIS..


Does this help?
http://www.microsoft.com/windows2000...e/iisnapin.htm


unfortunately not, for some very odd reason can't find 'Administrative
Tools' under start -> Programs.. (if I run a search in c:\ for
"Administrative Tools" I see it under Start Menu\Programs, but can't
find it in start menu.. but either way I suspect I wouldn't find
'Internet Services Manager' if I got to 'Administrative Tools' via this
route either, they're the same thing (just like to change environmental
vars you can either go to control panel -> system or my computer ->
right-click -> properties.. they both take you to the same place..)

(installed in XP also, managed to change port no problem.. running a
'hello World' asp at http://localhost:8080/web/index.asp...)

this is very frustrating.. I really need to make this work in Windows
2000...

thanks again..

Apr 18 '06 #9

P: n/a
Frances wrote:
Does this help?
http://www.microsoft.com/windows2000...e/iisnapin.htm


unfortunately not, for some very odd reason can't find 'Administrative
Tools' under start -> Programs.. (if I run a search in c:\ for
"Administrative Tools" I see it under Start Menu\Programs, but can't
find it in start menu.. but either way I suspect I wouldn't find
'Internet Services Manager' if I got to 'Administrative Tools' via
this route either, they're the same thing (just like to change
environmental vars you can either go to control panel -> system or my
computer -> right-click -> properties.. they both take you to the
same place..)


Darn! I was about to suggest going to Administrative Tools in the Control
Panel.
Try posting to the .inetserver.iis group.

--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap so I
don't check it very often. If you must reply off-line, then remove the
"NO SPAM"
Apr 18 '06 #10

P: n/a
Bob Barrows [MVP] wrote:
Frances wrote:
Does this help?
http://www.microsoft.com/windows2000...e/iisnapin.htm


unfortunately not, for some very odd reason can't find 'Administrative
Tools' under start -> Programs.. (if I run a search in c:\ for
"Administrative Tools" I see it under Start Menu\Programs, but can't
find it in start menu.. but either way I suspect I wouldn't find
'Internet Services Manager' if I got to 'Administrative Tools' via
this route either, they're the same thing (just like to change
environmental vars you can either go to control panel -> system or my
computer -> right-click -> properties.. they both take you to the
same place..)

Darn! I was about to suggest going to Administrative Tools in the Control
Panel.
Try posting to the .inetserver.iis group.


I got it to work at home.. where I have practically same machine as at
work (Windows 2000 Professional..) don't get why don't see 'Internet
Services Manager' in machine at work.. on machine at home was able to
change port to 8080 with no problem, and can run both Tomcat and IIS at
the same time no problem..

(can you turn IIS on and off like you can Tomcat? what if you need to
reboot the server? (I hope only way to reboot this server is not to
restart machine..) many thanks again..

Apr 19 '06 #11

P: n/a
On Tue, 18 Apr 2006 17:51:27 -0400, Frances <fd***@yahoo.com> wrote:
Bob Barrows [MVP] wrote:
Frances wrote:
<please do some snipping, thanks>
this is at work, I also have an XP machnine, installed IIS in XP
machine, found 'Internet Services Manager' no problem (don't have to
change port for that one, though (for now) since don't have Tomcat in
that machine..) am running my first little 'hello world' asp in XP
machine w/no problems.. why can't I find 'Internet Services Manager'
in Windows 2000 (exact version is Windows 2000 Professional) in XP was
able to find 'Internet Services Manager' even before I installed IIS..


Does this help?
http://www.microsoft.com/windows2000...e/iisnapin.htm


unfortunately not, for some very odd reason can't find 'Administrative
Tools' under start -> Programs.. (if I run a search in c:\ for
"Administrative Tools" I see it under Start Menu\Programs, but can't
find it in start menu.. but either way I suspect I wouldn't find
'Internet Services Manager' if I got to 'Administrative Tools' via this
route either, they're the same thing (just like to change environmental
vars you can either go to control panel -> system or my computer ->
right-click -> properties.. they both take you to the same place..)

(installed in XP also, managed to change port no problem.. running a
'hello World' asp at http://localhost:8080/web/index.asp...)

this is very frustrating.. I really need to make this work in Windows
2000...


Does your IT department block admin access? Are you running as a
local admin? Is IIS even installed?

Jeff
Apr 19 '06 #12

P: n/a
Jeff Cochran wrote:
On Tue, 18 Apr 2006 17:51:27 -0400, Frances <fd***@yahoo.com> wrote:

Bob Barrows [MVP] wrote:
Frances wrote:
<please do some snipping, thanks>

this is at work, I also have an XP machnine, installed IIS in XP
machine, found 'Internet Services Manager' no problem (don't have to
change port for that one, though (for now) since don't have Tomcat in
that machine..) am running my first little 'hello world' asp in XP
machine w/no problems.. why can't I find 'Internet Services Manager'
in Windows 2000 (exact version is Windows 2000 Professional) in XP was
able to find 'Internet Services Manager' even before I installed IIS..
Does this help?
http://www.microsoft.com/windows2000...e/iisnapin.htm


unfortunately not, for some very odd reason can't find 'Administrative
Tools' under start -> Programs.. (if I run a search in c:\ for
"Administrative Tools" I see it under Start Menu\Programs, but can't
find it in start menu.. but either way I suspect I wouldn't find
'Internet Services Manager' if I got to 'Administrative Tools' via this
route either, they're the same thing (just like to change environmental
vars you can either go to control panel -> system or my computer ->
right-click -> properties.. they both take you to the same place..)

(installed in XP also, managed to change port no problem.. running a
'hello World' asp at http://localhost:8080/web/index.asp...)

this is very frustrating.. I really need to make this work in Windows
2000...

Does your IT department block admin access?


I don't think so... as mentioned above, was able to install IIS in XP
machine with no problems.. this is also at work, same network, same
permissions, etc..

Are you running as a local admin? Is IIS even installed?

oh yes, I see Inetpub folder in C drive and everything, just like XP
machine (& machine at home) were was able to install it

do you think fact that I can't find 'Internet Services Manager' in W2k
machine at work might have to do with permissions, access? ok, again,
many thanks.. will post in m.p.inetserver.iis as someone here suggested..

Frances

Apr 19 '06 #13

P: n/a
What are the privileges of user installed IIS? Admin?
Do you have the same privs?
If you can find the shortcut using Windows Explorer, can you move or copy it to
your username?

Just a dot in the shark.....
Mike
Apr 19 '06 #14

P: n/a
MikeR wrote:
What are the privileges of user installed IIS? Admin?
Do you have the same privs?
If you can find the shortcut using Windows Explorer, can you move or
copy it to your username?

Just a dot in the shark.....
Mike


thank you all very much for your replies.. I finally got it to work: I
had to click 'details' for IIS and check "Internet Information Services
Snap-In" which is very weird b/c at home, where I have exact same
machine, I didn't have to do any of that.. so now running IIS on port
8080 and can run Tomcat (on port 80) at the same time with no problems..

many thanks again..
Apr 20 '06 #15

This discussion thread is closed

Replies have been disabled for this discussion.