469,271 Members | 1,778 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,271 developers. It's quick & easy.

Codepage problems with ASP.net in IIS

hb
Hi,

I have a flat html file which is in the utf-8 codepage. The file is
created with Word.
This code is at the beginning of the page:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
<link href="css/stylesheet.css" rel="stylesheet" type="text/css">
</head>

In my web application I use the <globalization
requestEncoding="utf-8" responseEncoding="utf-8" /> settings in the
web.config file.

However, when I view this html page with IE of mozilla words like
clÔent (with a double dot on the i) are shown as something like
Cli√ęnt. When I open the html page as a file from e.g. c:\ in both IE
as well as mozilla the words are shown correctly.

My conclusion is that IIS or ASP.Net causes this problem. Are there any
other settings I have to make in the web.config, IIS or where ever?

Any suggestions are welcome.

Jan 17 '06 #1
1 2533

hb wrote:
Hi,

I have a flat html file which is in the utf-8 codepage. The file is
created with Word.
This code is at the beginning of the page:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
<link href="css/stylesheet.css" rel="stylesheet" type="text/css">
</head>

In my web application I use the <globalization
requestEncoding="utf-8" responseEncoding="utf-8" /> settings in the
web.config file.

However, when I view this html page with IE of mozilla words like
cl?ent (with a double dot on the i) are shown as something like
CliŽnt. When I open the html page as a file from e.g. c:\ in both IE
as well as mozilla the words are shown correctly.

My conclusion is that IIS or ASP.Net causes this problem. Are there any
other settings I have to make in the web.config, IIS or where ever?

Any suggestions are welcome.


A quick google for "codepage web.config file" gave me this in the
second result:

pg_CodePage

This is an optional entry which can be used to define the code page
when the web pages are read. If this setting is left out, then a
standard code page of 1252 is used which should be correct for Western
character sets.

If you wish to use a different code page, the value is integer of the
form value="950".

In some circumstances you may see ? characters when the pages are
indexed. This is an indication that the code page is incorrect.

If this doesn't solve your problem, you are probably better off asking
in one of the dotnet groups, such as
microsoft.public.dotnet.framework.aspnet

/P.

Jan 17 '06 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

10 posts views Thread by Christopher H. Laco | last post: by
8 posts views Thread by Kim Bundgaard | last post: by
reply views Thread by Guido/RM/ITALY | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by zhoujie | last post: by
reply views Thread by suresh191 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.