469,291 Members | 1,733 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,291 developers. It's quick & easy.

why I can't see mtx.exe in the romote machine?

Hi,
I've set up remote debugging following every step in the manu from
microsoft. However, I can't see mtx.exe process in romote machine,
instead I only see inetinfo.exe. I attached to it and it seem works OK
except that I can't set up any break point in any inc file(include
file). I can use the command stepinto from an asp page to get to inc
code, but I the process never stop at the break point I "set up" before
I start the debugger or in the debugging process.
Can anyone help me what went wrong? or just tell me that is about what
interdev debugger can do.
By the way, I use NT on server and client is a window 2000
professional.
The manu I followed was
http://msdn.microsoft.com/library/en...idebugging.asp

Please help... :(

regards

Donna

Jul 22 '05 #1
3 1371
Hi,

How did you register the component on NT? Did you use the transaction
services applet and have you set it to run as a server?

--
compatible web farm Session replacement for Asp and Asp.Net
http://www.nieropwebconsult.nl/asp_session_manager.htm

"Donna" <te**********@yahoo.com> wrote in message
news:11**********************@g43g2000cwa.googlegr oups.com...
Hi,
I've set up remote debugging following every step in the manu from
microsoft. However, I can't see mtx.exe process in romote machine,
instead I only see inetinfo.exe. I attached to it and it seem works OK
except that I can't set up any break point in any inc file(include
file). I can use the command stepinto from an asp page to get to inc
code, but I the process never stop at the break point I "set up" before
I start the debugger or in the debugging process.
Can anyone help me what went wrong? or just tell me that is about what
interdev debugger can do.
By the way, I use NT on server and client is a window 2000
professional.
The manu I followed was
http://msdn.microsoft.com/library/en...idebugging.asp

Please help... :(

regards

Donna


Jul 22 '05 #2
hello,
thanks for responding to me.
Well. I just installed the frontpage server extension and setup
properties of three Distributed component, machine debug manager, MTS
Client Export and catalog class, grant access and allow lunch to admin
user.
what other component I missed here? What component I suppose to see in
the Transaction services applet?
By the way, physical path of my application locates under wwwroot on
the server so I'm able to see it from interdev when I setup the
solution to debug.
I spent a lot of time figuring the debugber out. I wonder if it worth
my time. But to write each print statement out to debug is very time
consumming as well. In the long run, if I can use the debugger well, I
think it worth the effort I put in. However I don't see many people use
it though. I don't see many people talk about it online.
Anyway, thank you for your response and hope i can resolve this soon.

Regards

Donna

Jul 22 '05 #3
"Donna" <te**********@yahoo.com> wrote in message
news:11**********************@g14g2000cwa.googlegr oups.com...
hello,
thanks for responding to me.
Well. I just installed the frontpage server extension and setup
properties of three Distributed component, machine debug manager, MTS
Client Export and catalog class, grant access and allow lunch to admin
user.
This is 'DCOM' but DCOM does not launch mtx.exe. I think you are mixing up
technologies and get some info about COM+ and transaction manager.
what other component I missed here? What component I suppose to see in
the Transaction services applet?
You should register your component using 'new package' in transaction
manager and within the properties, you set it to be a server package.
Drag and drop your DLL within that package.
After that, you can remotely debug your DLL and connect to mtx.exe
--
compatible web farm Session replacement for Asp and Asp.Net
http://www.nieropwebconsult.nl/asp_session_manager.htm

By the way, physical path of my application locates under wwwroot on
the server so I'm able to see it from interdev when I setup the
solution to debug.
I spent a lot of time figuring the debugber out. I wonder if it worth
my time. But to write each print statement out to debug is very time
consumming as well. In the long run, if I can use the debugger well, I
think it worth the effort I put in. However I don't see many people use
it though. I don't see many people talk about it online.
Anyway, thank you for your response and hope i can resolve this soon.

Regards

Donna


Jul 22 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

12 posts views Thread by Ralf Dieholt | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by zhoujie | last post: by
reply views Thread by suresh191 | last post: by
reply views Thread by harlem98 | last post: by
reply views Thread by harlem98 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.