By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
432,175 Members | 1,710 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 432,175 IT Pros & Developers. It's quick & easy.

Timeout in connection string

P: n/a
stringA= "Provider=SQLOLEDB.1;Persist Security Info=False;User
ID=sa;PWD=password;Initial Catalog=DB;Data Source=127.0.0.1;Connect
Timeout=30"

stringB = "Provider=Microsoft.Jet.OLEDB.4.0; Data Source=" &
Server.MapPath("DB.MDB") & ";Connect Timeout=30"
Hi All,

I have use the above connection string in an ASP application, stringA with
SQL Server, it works!
stringB with MS ACCESS, it doesnt works if I add the "connect timeout"
parameter!!
How can I solve it!? so that I can set the connection timeout when I using
MSACCESS as Database
(I dont want to use ODBC connection).

Thx alot
Jul 22 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
kant wrote:
stringA= "Provider=SQLOLEDB.1;Persist Security Info=False;User
ID=sa;PWD=password;Initial Catalog=DB;Data Source=127.0.0.1;Connect
Timeout=30"

stringB = "Provider=Microsoft.Jet.OLEDB.4.0; Data Source=" &
Server.MapPath("DB.MDB") & ";Connect Timeout=30"
Hi All,

I have use the above connection string in an ASP application, stringA
with SQL Server, it works!
stringB with MS ACCESS, it doesnt works if I add the "connect timeout"
parameter!!
How can I solve it!? so that I can set the connection timeout when I
using MSACCESS as Database
(I dont want to use ODBC connection).

What do you intend to gain by using that parameter. I'm not sure that
parameter is supported by the Jet provider. You can set the property
directly on the Connection object if you must have it:
set cn=createobject("adodb.connection")
cn.CommandTimeout=30

With an Access database, I really don't see what is being gained by the use
of this property.
Bob Barrows
--
Microsoft MVP -- ASP/ASP.NET
Please reply to the newsgroup. The email account listed in my From
header is my spam trap, so I don't check it very often. You will get a
quicker response by posting to the newsgroup.
Jul 22 '05 #2

P: n/a
Hi Bob,

I found the error happened in IIS setting but not DB connection timeout,
here is the error message, what should I modify the Server.scripttimeout !?
Thx
Error Type:
Active Server Pages, ASP 0113 (0x80004005)
The maximum amount of time for a script to execute was exceeded. You can
change this limit by

specifying a new value for the property Server.ScriptTimeout or by changing
the value in the IIS administration tools.
"Bob Barrows [MVP]" wrote:
kant wrote:
stringA= "Provider=SQLOLEDB.1;Persist Security Info=False;User
ID=sa;PWD=password;Initial Catalog=DB;Data Source=127.0.0.1;Connect
Timeout=30"

stringB = "Provider=Microsoft.Jet.OLEDB.4.0; Data Source=" &
Server.MapPath("DB.MDB") & ";Connect Timeout=30"
Hi All,

I have use the above connection string in an ASP application, stringA
with SQL Server, it works!
stringB with MS ACCESS, it doesnt works if I add the "connect timeout"
parameter!!
How can I solve it!? so that I can set the connection timeout when I
using MSACCESS as Database
(I dont want to use ODBC connection).

What do you intend to gain by using that parameter. I'm not sure that
parameter is supported by the Jet provider. You can set the property
directly on the Connection object if you must have it:
set cn=createobject("adodb.connection")
cn.CommandTimeout=30

With an Access database, I really don't see what is being gained by the use
of this property.
Bob Barrows
--
Microsoft MVP -- ASP/ASP.NET
Please reply to the newsgroup. The email account listed in my From
header is my spam trap, so I don't check it very often. You will get a
quicker response by posting to the newsgroup.

Jul 22 '05 #3

P: n/a
fixed...just click ths IIS setting menu, so silly....thx and pls ignore this
question.

"Kant" wrote:
Hi Bob,

I found the error happened in IIS setting but not DB connection timeout,
here is the error message, what should I modify the Server.scripttimeout !?
Thx
Error Type:
Active Server Pages, ASP 0113 (0x80004005)
The maximum amount of time for a script to execute was exceeded. You can
change this limit by

specifying a new value for the property Server.ScriptTimeout or by changing
the value in the IIS administration tools.
"Bob Barrows [MVP]" wrote:
kant wrote:
stringA= "Provider=SQLOLEDB.1;Persist Security Info=False;User
ID=sa;PWD=password;Initial Catalog=DB;Data Source=127.0.0.1;Connect
Timeout=30"

stringB = "Provider=Microsoft.Jet.OLEDB.4.0; Data Source=" &
Server.MapPath("DB.MDB") & ";Connect Timeout=30"
Hi All,

I have use the above connection string in an ASP application, stringA
with SQL Server, it works!
stringB with MS ACCESS, it doesnt works if I add the "connect timeout"
parameter!!
How can I solve it!? so that I can set the connection timeout when I
using MSACCESS as Database
(I dont want to use ODBC connection).

What do you intend to gain by using that parameter. I'm not sure that
parameter is supported by the Jet provider. You can set the property
directly on the Connection object if you must have it:
set cn=createobject("adodb.connection")
cn.CommandTimeout=30

With an Access database, I really don't see what is being gained by the use
of this property.
Bob Barrows
--
Microsoft MVP -- ASP/ASP.NET
Please reply to the newsgroup. The email account listed in my From
header is my spam trap, so I don't check it very often. You will get a
quicker response by posting to the newsgroup.

Jul 22 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.