469,902 Members | 1,815 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,902 developers. It's quick & easy.

ASP Error messages

I'm running asp on MS Server 2000. Running Internet Explorer I used to get a
proper message with page and line number when there was a bug in my asp
code. Suddenly I'm not getting these any more, I just get the standard
HTTP 500 - Internal server error
Internet Explorer
page which is completely useless.

In Tools/Internet Options/Advanced neither "Disable Script Debugging" or
"Disable a notification about every script error" is checked, though I think
these only apply to scripts running in the client e.g. javascript.

Any ideas how I can get my server errors back? This is taking a huge chunk
out of my productivity!

Thanks.
Jul 22 '05 #1
4 1299
Hi Simon,

Those settings you're changing are for client-side code errors. There's
another setting, http://www.aspfaq.com/2109, that tells IE to send the real
response text when it gets a 500 response from the server.

Ray at work

"Simon Wigzell" <si**********@shaw.ca> wrote in message
news:%VQ8e.1062565$Xk.137450@pd7tw3no...
I'm running asp on MS Server 2000. Running Internet Explorer I used to get a proper message with page and line number when there was a bug in my asp
code. Suddenly I'm not getting these any more, I just get the standard
HTTP 500 - Internal server error
Internet Explorer
page which is completely useless.

In Tools/Internet Options/Advanced neither "Disable Script Debugging" or
"Disable a notification about every script error" is checked, though I think these only apply to scripts running in the client e.g. javascript.

Any ideas how I can get my server errors back? This is taking a huge chunk
out of my productivity!

Thanks.

Jul 22 '05 #2

Thanks for replying but the link goes to a bad page. Can you send me the
working link? Thanks.
*** Sent via Developersdex http://www.developersdex.com ***
Jul 22 '05 #3
It's not a bad page. It's pretty nice actually. And the link works for me.
Try this one. http://www.aspfaq.com/show.asp?id=2109

Or, go to aspfaq.com and search for "internal server error."

Ray at work

"Simon Wigzell" <si**********@shaw.ca> wrote in message
news:%2****************@TK2MSFTNGP15.phx.gbl...

Thanks for replying but the link goes to a bad page. Can you send me the
working link? Thanks.
*** Sent via Developersdex http://www.developersdex.com ***

Jul 22 '05 #4
Turn off 'Show Friendly error messages'
http://support.cjwsoft.com/code/moreinfo11-1.htm
"Simon Wigzell" <si**********@shaw.ca> wrote in message
news:%VQ8e.1062565$Xk.137450@pd7tw3no...
I'm running asp on MS Server 2000. Running Internet Explorer I used to get
a proper message with page and line number when there was a bug in my asp
code. Suddenly I'm not getting these any more, I just get the standard
HTTP 500 - Internal server error
Internet Explorer
page which is completely useless.

In Tools/Internet Options/Advanced neither "Disable Script Debugging" or
"Disable a notification about every script error" is checked, though I
think these only apply to scripts running in the client e.g. javascript.

Any ideas how I can get my server errors back? This is taking a huge chunk
out of my productivity!

Thanks.

Jul 22 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

2 posts views Thread by lkrubner | last post: by
10 posts views Thread by Brian Conway | last post: by
reply views Thread by Janning Vygen | last post: by
8 posts views Thread by Brian Tkatch | last post: by
2 posts views Thread by FutureShock | last post: by
1 post views Thread by Waqarahmed | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.