468,483 Members | 2,690 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,483 developers. It's quick & easy.

Pages of website returns a WAMP homepage on my LocalHost?

Using WAMPSERVER for windows 7, smartgit and Safe Search Replace I have done the following steps:

- Pulled a wordpress code from a github repository using smartgit
- Downloaded the database from the server's phpmyadmin
- Imported it to my localhost's phpmyadmin using WAMP.
- Replaced the strings from url.com to 127.0.0.1/url

The home page works on the localhost but when I click on one of the menu links I get the WAMP homepage instead of the actual page. What have I done wrong and what can I check to solve the issue?

On wordpress the URL on pages has been changed to 127.0.0.1/url which is a good sign. Is there a way to check the url that works in my wamp folders?

I have tried the following in WP-Config to use the localhost URL instead of the one saved to the database but it didn't work:

define('WP_HOME','http://127.0.0.1/website');
define('WP_SITEURL','http://127.0.0.1/website');
Mar 3 '13 #1

✓ answered by arthurmani

Go to settings/permalinks in the wordpress dashboard and update permalinks by clicking twice on save changes. That's all.

1 2249
Go to settings/permalinks in the wordpress dashboard and update permalinks by clicking twice on save changes. That's all.
Mar 3 '13 #2

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

5 posts views Thread by jd | last post: by
8 posts views Thread by Maximilian Hofer | last post: by
reply views Thread by Bell, Kevin | last post: by
17 posts views Thread by =?Utf-8?B?Y2F0aGFyaW51cyB2YW4gZGVyIHdlcmY=?= | last post: by
reply views Thread by NPC403 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.