By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
462,949 Members | 689 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 462,949 IT Pros & Developers. It's quick & easy.

ubuntu apache2 bugzilla

Expert 5K+
P: 5,000

I've been trying to set up apache2 to serve my bugzilla page for like a week now and I give up!

Expand|Select|Wrap|Line Numbers
  1. I installed bugzilla:
  3. /srv$ ls -l
  4. drwxr-xr-x www-data www-data bugzilla
  6. I've tried to create a bugzilla site
  8. /etc/apache2/sites-available$ ls
  9. bugzilla default
  11. /etc/apache2/sites-available$ cat bugzilla
  12. NameVirtualHost *
  13. <VirtualHost *>
  14. <Directory /srv/bugzilla>
  15. AddHandler cgi-script .cgi
  16. Options +Indexes +ExecCGI
  17. DirectoryIndex index.cgi
  18. AllowOverride Limit
  19. </Directory>
  20. </VirtualHost>
  22. /etc/apache2/sites-available$sudo a2ensite bugzilla
  23. /etc/apache2/sites-available$/etc/init.d/apache2 reload
  25. Navigate to http://localhost/bugzilla give me an error 404
HELP PLEASE!! What do I put in sites-available/bugzilla to get it to work?!?

Thanks :)
Oct 31 '08 #1
Share this Question
Share on Google+
5 Replies

P: 3

Have you created a link to it in "/etc/apache2/sites-enabled"
Nov 14 '08 #2

Expert 5K+
P: 5,000
Yes .
Nov 14 '08 #3

P: 3
when you restart apache, what does it print?
Nov 14 '08 #4

Expert 5K+
P: 5,000
What does apache print?

It doesn't say anything other than okay or successful or some such.
Nov 14 '08 #5

P: 3
Process of elimination,

If you haven't done this edit /etc/apache/httpd.conf, adding the following lines:

Alias /bugs/ (location of your bugzilla cgi files)

<Directory (location of your bugzilla cgi files)>
AddHandler cgi-script .cgi
Options +Indexes +ExecCGI
DirectoryIndex index.cgi
AllowOverride Limit

Restart apache
Then give it a try
Nov 14 '08 #6

Post your reply

Sign in to post your reply or Sign up for a free account.