473,839 Members | 1,540 Online
Bytes | Software Development & Data Engineering Community
+ Post

Home Posts Topics Members FAQ

install SilverStripe 2, you must add PHP support to your webserver.

5 New Member
this is probably an insanely dumb overlook on my part, as i am very good at those.
i have downloaded, and seemingly succesullly installed wamp server 2.
this wwas done to intall silver stripe.
the silver stripe install only 1/2 worked....i get a directory tree for an index page.
relooking thru the directory, i can pull
file:///C:/wamp/www/silverstripe-v2.2.2/check-php.php
which tells me:
>>>Before I can install SilverStripe 2, you must add PHP support to your webserver.

Try again<<<<

with try again "hot".

i believe i have followed every bit of the instrux properly.

there seems to be no clue in wamp server 2, or elsewhere on the net after an hour of looking as to how to do this.
any and all help based on the idea that you re talking to a compleat idiot who is only reallly happy wth left/right clicks will be appreciated.
thank you.
Aug 27 '08 #1
9 8515
Markus
6,050 Recognized Expert Expert
You should access it by
Expand|Select|Wrap|Line Numbers
  1. http://localhost/directory/file.php
  2.  
Also, you must make sure you have the server started!
Aug 27 '08 #2
jbpublisher
5 New Member
please excse the delay in answering. i didn't get a notification of a reply.
the effort is apprecicated.
http://localhost/directory/file.php
yes sir,
that's in the given guidelines.
it doesn't work.
that's what gave rise to all th searching and finally posting this question here.
Firefox can't establish a connection to the server at localhost

Though the site seems valid, the browser was unable to establish a connection.

* Could the site be temporarily unavailable? Try again later.
this is true with wmp server showingall white in the "guage,"
both offline and online.

the next logical approach after that would be:
file:///C:/wamp/www/index.php
which gives me a page of...code.
a sample from the bottom:
Expand|Select|Wrap|Line Numbers
  1.  {$langues[$langue]['titreConf']}
  2.  
  3. {$langues[$langue]['versa']}
  4.     ${apacheVersion}  
  5. {$langues[$langue]['versp']}
  6.     ${phpVersion}  
  7. {$langues[$langue]['phpExt']}
  8.  
  9.           ${phpExtContents} 
  10.  
  11. {$langues[$langue]['versm']}
  12.     ${mysqlVersion}  
  13.  
  14. {$langues[$langue]['titrePage']}
  15.  
  16.     * phpinfo()
  17.     * phpmyadmin
  18.     * sqlitemanager
  19.  
  20. {$langues[$langue]['txtProjet']}
  21.  
  22.       $projectContents 
  23.  
----------------------
the 3 which show here as * are "hot"---and go nowhere.

Firefox can't find the file at /C:/wamp/www/phpmyadmin/.
Aug 30 '08 #3
Atli
5,058 Recognized Expert Expert
Hi.

If you can't access your files via http://localhost/ or http://127.0.0.1/ then your Apache server is either not running or somehow not working.
Unless you have a firewall or something that is blocking it?

Try doing "net start apache2.2" in a command window. See what it does.

Trying to access the file using anything other than http:// will not work. It would give you the file, exactly like it is, without executing any server-side code.
Aug 30 '08 #4
jbpublisher
5 New Member
thank you.
this is where the illiteracy kicks in.
i understand what u said, but not how to do it.
going idiot step by idiot step i will cheerfully take any instrux, like,
start-->run-->then????
according to the wamp server "gauge" apache is on.
accordin to apache within the wamp interface,
http://localhost/phpmyadmin
ought to get me somewhere. it doesn't.
or, perhaps:
http://localhost/sqlitemanager
which also goes nowhere.
i am thinking...mayb e...in my ignorance...
php.ini
is weird, but i followed th instrux as carefully as i know how..
on firewall block. i am using the windos firewall for xp sp3, with the named ports in the instrux open
apache, mysqk and wamp are all checked by win firewall as having permission to run.
Aug 30 '08 #5
Atli
5,058 Recognized Expert Expert
Ok, try this.

Create a file in the C:\wamp\www\ directory called phpinfo.php
Put this into that file:
Expand|Select|Wrap|Line Numbers
  1. <?php
  2.   phpinfo();
  3. ?>
  4.  
Then type http://localhost/phpinfo.php into your browser.
That should show you a bunch of info on your PHP installation.

If that doesn't work, and your browser tells you something like "Firefox can't establish a connection to the server at localhost.", or something in that direction, try this:

Go to Start -> Run -> type cmd and hit enter.
Type into the command prompt: net start apache2.2
If the Apache server is not running, this should try to start the server. If there are errors, this should tell you about it.

If it starts up now, try opening the URL again. See if anything changes.
Aug 30 '08 #6
jbpublisher
5 New Member
service name invalid.
also...i dunno if this is right...
cmd take e to
c:\documents and settings\(me)>
not to
c:
..which i think it is sposed to...
or at least somethung like it.
entering
c:
or c:\
give me nothing.
Aug 30 '08 #7
Atli
5,058 Recognized Expert Expert
It doesn't matter what directory the command window shows. Just type the command I posted and see what it says.
Aug 30 '08 #8
jbpublisher
5 New Member
as noted:
service name invalid.
Aug 30 '08 #9
Markus
6,050 Recognized Expert Expert
You know, I can't really help with the problem you have, but I could maybe provide a way around said problem.

I would recommend using something like XAMPP; it was so hassle free to install and very user-friendly. But, alas, there will always be a problem, somewhere. On one machine I installed XAMPP on, it refused to work (something about the ports..). So then I decided I'd try and install a different development host, EasyPHP, and this worked without a problem.

My advice is: look around and try different things, because different things work.
Aug 31 '08 #10

Sign in to post your reply or Sign up for a free account.

Similar topics

2
2258
by: Sally | last post by:
I have written a gui application for windows os using Borland C++ Builder. Does anybody know how I would go about automating the installation process - for instance, I would like my executable to start off compressed - I would then like the installation process to 1. automatically create a new directory, uncompress the archive into the new directory, 2. automatically put a shortcut onto the users desktop. I have noticed this seems to be...
5
1554
by: DC Gringo | last post by:
I'm trying to create an installer that will deploy my web application onto a webserver http://www.myserver.com. Instead, it's forcing me to install into a virtual directory of the localhost webserver. What can I do? _____ DC G
3
20684
by: CMan | last post by:
Hi, We are currently trying to install .Net Framework v.1.1 on a server which already has v1.0. We are receiving the following error. Error 1704.An installation for Microsoft .NET Framework SDK (English) is currently suspended. You must undo the changes made by that installation to continue. Do you want to undo those changes?
2
7991
by: Fan Wang | last post by:
Hi All, I wrote a windows service with C# as below. But I can't install it with installutil.exe. I got an error message " Exception occurred while initializing the installation: System.IO.FileNotFoundException: File or assembly name windowsservice1, or one of its dependencies, was not found.. " I am new to C# environment. Any idea any clue will be appreciated. Thanks using System;
2
11581
by: Vayse | last post by:
I published my app in Visual Studio 2005. I'm getting a problem installing on one PC. During the install, the following error appears: "Unable to run or install the application. The application requires that assembly ADODB 7.0.3300.0 be installed in the Global Assembly Cache (GAC) first." The VB6 install used to give you a choice of adding references. The VS 2005 Publish doesn't give any options to include references. What should I be...
4
2195
by: JaiPrakash Sharma | last post by:
Hi All, I have a question regarding Using a Windows based UserControl or Applications on the Web. My question is Must be the .NET Framework to be Installed on Client Machine, When any ASP.NET application using Windows based UserControl ? Please describe me in detail.
3
5745
by: Bruno LIVERNAIS | last post by:
Hi, We are currently installing a DB2 V9 ESE on a Linux server (RHEL4U4-x86_64). Installation runs successfully on each node. Database user environment is OK and the instance is well created. To be sure, we've started the database with db2start =successfull. And then shut it down again successfully too. The tricks appears when we switch the hp MC/ServiceGuard (A.11.16 for Linux) package to the other node... the database does not want...
4
7106
by: Amber | last post by:
The installer tells it faild to config db2inst1, the db2setup.err is as following: /usr/share/themes/Clearlooks/gtk-2.0/gtkrc:60: Engine "clearlooks" is unsupporte d, ignoring Jun 15, 2007 6:32:36 PM java.util.prefs.FileSystemPreferences$3 run INFO: Created system preferences directory in java.home.
1
5262
by: Israel | last post by:
I found it surprisingly unintuitive and difficult to get the installation code to work properly and I found very little help on the google groups so I figured I’d post the things that burned me so someone else doesn’t have to work through the same issues. I created a service using the wizard and then I added an Installer class. On the canvas of the installer class I plopped down an instance of a ServiceInstaller and a...
0
9855
marktang
by: marktang | last post by:
ONU (Optical Network Unit) is one of the key components for providing high-speed Internet services. Its primary function is to act as an endpoint device located at the user's premises. However, people are often confused as to whether an ONU can Work As a Router. In this blog post, we’ll explore What is ONU, What Is Router, ONU & Router’s main usage, and What is the difference between ONU and Router. Let’s take a closer look ! Part I. Meaning of...
0
9697
by: Hystou | last post by:
Most computers default to English, but sometimes we require a different language, especially when relocating. Forgot to request a specific language before your computer shipped? No problem! You can effortlessly switch the default language on Windows 10 without reinstalling. I'll walk you through it. First, let's disable language synchronization. With a Microsoft account, language settings sync across devices. To prevent any complications,...
0
10906
Oralloy
by: Oralloy | last post by:
Hello folks, I am unable to find appropriate documentation on the type promotion of bit-fields when using the generalised comparison operator "<=>". The problem is that using the GNU compilers, it seems that the internal comparison operator "<=>" tries to promote arguments from unsigned to signed. This is as boiled down as I can make it. Here is my compilation command: g++-12 -std=c++20 -Wnarrowing bit_field.cpp Here is the code in...
1
10647
by: Hystou | last post by:
Overview: Windows 11 and 10 have less user interface control over operating system update behaviour than previous versions of Windows. In Windows 11 and 10, there is no way to turn off the Windows Update option using the Control Panel or Settings app; it automatically checks for updates and installs any it finds, whether you like it or not. For most users, this new feature is actually very convenient. If you want to control the update process,...
0
9426
agi2029
by: agi2029 | last post by:
Let's talk about the concept of autonomous AI software engineers and no-code agents. These AIs are designed to manage the entire lifecycle of a software development project—planning, coding, testing, and deployment—without human intervention. Imagine an AI that can take a project description, break it down, write the code, debug it, and then launch it, all on its own.... Now, this would greatly impact the work of software developers. The idea...
0
5682
by: TSSRALBI | last post by:
Hello I'm a network technician in training and I need your help. I am currently learning how to create and manage the different types of VPNs and I have a question about LAN-to-LAN VPNs. The last exercise I practiced was to create a LAN-to-LAN VPN between two Pfsense firewalls, by using IPSEC protocols. I succeeded, with both firewalls in the same network. But I'm wondering if it's possible to do the same thing, with 2 Pfsense firewalls...
1
4482
by: 6302768590 | last post by:
Hai team i want code for transfer the data from one system to another through IP address by using C# our system has to for every 5mins then we have to update the data what the data is updated we have to send another system
2
4064
muto222
by: muto222 | last post by:
How can i add a mobile payment intergratation into php mysql website.
3
3132
bsmnconsultancy
by: bsmnconsultancy | last post by:
In today's digital era, a well-designed website is crucial for businesses looking to succeed. Whether you're a small business owner or a large corporation in Toronto, having a strong online presence can significantly impact your brand's success. BSMN Consultancy, a leader in Website Development in Toronto offers valuable insights into creating effective websites that not only look great but also perform exceptionally well. In this comprehensive...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.