By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,165 Members | 894 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,165 IT Pros & Developers. It's quick & easy.

Make table query not working consistently

P: 1
Tables are created no problem by a set of make table and append queries IF they are run right at the start of application. However, once data were handled by forms and data are changed the same queries are caught in the debugger saying that they cannot be run because the data are handled by another user. That happens despite all the froms are closed when rerun is attempted. I tried all I could but nothing works and it makes no sense. I am tearing hair out.
Feb 7 '17 #1
Share this Question
Share on Google+
1 Reply


Expert Mod 2.5K+
P: 2,545
Access will only lock a table if something bound to that table - a query for instance - is open, or another object such as a form based on that table remains open.

Without seeing the code involved it is difficult to offer an opinion, other than to say the debugger will be telling you the truth - there is something bound to that table which is still open at the time you are attempting to run the make-table query. Are you sure you have no queries on that table open? Are you sure that you have closed any OpenRecordset methods called by the form you tell us you have closed?

Without seeing the code concerned I am unable to comment further at present.

-Stewart
Feb 8 '17 #2

Post your reply

Sign in to post your reply or Sign up for a free account.