By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
459,566 Members | 1,718 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 459,566 IT Pros & Developers. It's quick & easy.

How to get rid off the ("Edit List Items")icon displaying under combobox

P: 17
Hi friends,

The problem which I want to rectify is really small but it seems like I am not able to find the solution for it.

The scenario is like:

I have a form with a bound combobox. Now that combobox displays EmployeeId based on the query fired. But the problem is that user should not be able to edit the combobox details.

What is happening:
When the user clicks on the combobox the user is able to see an icon "Edit List Item", which lead to the form where we can add users. Which should not happen, as per the permissions.

What approaches I used:
I tried setting the Enabled property as "No", but than whenever the user presses "Save & New" the Combobox value is also set as null. As a result the user have to reach out the form every time a new entry has to be made, which is not feasible . ( I tried using Combobox.ListIndex = 0, but nothing helped me out).

Also, Locked and Auto Expand property are set to "No".

Please find the attachment for clear idea.

I hope I am making some sense.

Looking forward for a solution.

Thanks in advance.
Attached Files
File Type: docx Combobox.docx (109.0 KB, 175 views)
May 15 '15 #1

✓ answered by Seth Schrock

Try setting the ComboBox's Limit To List Property to Yes and the Allow Value List Edits to No and clear the List Items Edit Form to nothing.

Share this Question
Share on Google+
2 Replies


Seth Schrock
Expert 2.5K+
P: 2,951
Try setting the ComboBox's Limit To List Property to Yes and the Allow Value List Edits to No and clear the List Items Edit Form to nothing.
May 15 '15 #2

P: 17
Oh great!

I found that List Items Edit Form was not null due to which the form was accessible. Else everything was same.

Thanks a lot :D
May 15 '15 #3

Post your reply

Sign in to post your reply or Sign up for a free account.