469,126 Members | 1,281 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,126 developers. It's quick & easy.

Linked Table Manager says VBA project cannot be read

Hello - I have an issue with Access after upgrading to 2010. It seems to impact all databases and they are working for others.

Whenever I attempt to enter the "Linked Table Manager" either via the External Data tab or by right clicking on a table and selecting "Linked Table Manager" I get the following error...

"The Database cannot be opened because the VBA project contained in it cannot be read. The database can be opened only if the VBA project is first deleted. Deleting the VBA project removes all code from modules, forms and reports. Your should backup your database before attempting to open the database and delete the VBA project.

To create a backup copy, click Cancel and then make a backup copy of your database. To open the database and delete the VBA project without creating a backup copy, click OK."

Ok leads to "Cannot update. Database or object is read only."

then

"The Visual Basic for Applications project in the database is corrupt."

I've tried reinstalling access and this error occurs even with brand new databases created with access 2010 that do not contain any macros. Also Visual Basic opens fine.

Any ideas?
Mar 21 '14 #1
8 2418
zmbd
5,400 Expert Mod 4TB
oh.. so sorry to hear that this is happening to you.

From what version did you upgrade from?

IF ACC2003 then, make a new database in either the mdb or accdb format (be aware the new format strips out userlevel security).

Import your old objects into the new database using the external data.

Do this for the backend too.

BEST OF LUCK
let us know how things go!
Mar 25 '14 #2
Thanks for the reply zmbd, sadly no luck.

It was 2003 I was on previously.
Created a new mdb, called back.mdb, it had one table inside called back1
Created another new mdb, called front.mdb. Imported the back.mdb as a linked table (this worked) and could see the content of the back1 table.
Went to Linked table manager for back1. Same error as above.
Mar 31 '14 #3
zmbd
5,400 Expert Mod 4TB
I'm not following you...

Hopefully you did the following:
1) ACC2010 - Create new MDB file
2) Rename back.mbd
3) Import, not as link, but as data and structure all tables
3a) at this time do not import anything except the tables.
4) Close all files
5) ACC2010 - Create new MDB file
6) Rename Front.mbd
7) Copy all local tables, queries, forms, and modules.
8) Close all files and program
9) Reopen ACC2010 and the new Front.mdb
10) External data ribbon, import, and link to the new back.mdb tables.

At this point you should be good.
If you have forms, queries, or VBA modules in the original back end, I would reconsider this design. The backend should ideally only store unchanging queries and table data, no forms, no code modules.

If this doesn't fix the issue, then try again using the ACCDB format. It will strip your user level security; however, that may the price you have to pay to get your data back.
Mar 31 '14 #4
zmbd
5,400 Expert Mod 4TB
Two more questions:
Did you do a "clean install" of the new office or did you just do the in-place upgrade and what version of windows are you working with?
Mar 31 '14 #5
Hi Zmbd and thanks again,

followed your process and made it through to the end; and had a copy of the database which at least gets me past the initial issue.

Sadly going to Linked Table Manager still gives the same error, so your 10 step guide is the only way to change back end location.

It was a clean install of access 2010 and
OS Name: Microsoft Windows 7 Enterprise
OS Version: 6.1.7601 Service Pack 1 Build 7601
Apr 7 '14 #6
zmbd
5,400 Expert Mod 4TB
hmm...
Check the folder permissions.
If the PC/User you're working with doesn't have read/Write/Modify rights to the folder this can also give you issues; however, I wouldn't expect this to be the issue - but it's the weird things that will bite you...
Apr 7 '14 #7
Found it finally!

http://support.microsoft.com/kb/2581301

Upgrading to SP2 fixed it.
Oct 29 '14 #8
zmbd
5,400 Expert Mod 4TB
I'm glad you found the solution.
I should have also inquired which 32/64BIT-installation you had upgraded to... as you discovered, in the 64BIT installations there was/is a known bug.

Thnx for bringing this back into the light - I'm sure you just helped at least a dozen people!
Oct 29 '14 #9

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

2 posts views Thread by Ian Davies | last post: by
3 posts views Thread by Parasyke | last post: by
1 post views Thread by franc sutherland | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by Mortomer39 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.