By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,466 Members | 1,599 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,466 IT Pros & Developers. It's quick & easy.

MS Access report load from a form having report criteria

P: 19
I have designed a database with many reports of certain importance. Basically a report in my DB is one of two types; a Daily Report (requires a single criteria which is the date) and the second is a History report. To view or print a report, I have designed a Filter form to fill in with the report criteria and clicking a button to open the report.The first type (Daily R) work fine without problems.

The second type (History R)has a problem. In this report, the criteria are two or three because a history report will retrieve data within a period, so I have to input (FromDate) and (ToDate)and may be adding another criteria which is called a company. In all history reports, the report header will accomodate the two input values of date and extract the rest of report items into the reprot detail area.

The problem is, the desigened system doesnot respond well as expected. When I load the filter form to fill in criteria for a history report, I have input the FromDate and ToDate and selected the third criteria (if any), then, the reprot opens without data in it.on the other hand, I tried to load the report directly form opening it, inputing criteria, and it has worked fine without probelms.

Would someone expect a key reason for this problem or dirtecly can solve this problem?

Appreciate youtr support.

Thanks in Advance. mhegazy
Oct 28 '12 #1
Share this Question
Share on Google+
4 Replies


TheSmileyCoder
Expert Mod 100+
P: 2,321
We would need some details as to how you are submitting the selected criterias between the form and the report. There is at least 5 different methods I can think off, of the top of my head, so we need specifics.
Oct 28 '12 #2

NeoPa
Expert Mod 15k+
P: 31,186
Indeed M. We would need to see the code you use to invoke the report that isn't working correctly, as well as an indication of exactly what criteria is sent as the string. My suspicion is that the criteria string is not correctly formatted, but we cannot help much without seeing exactly what that string contains.
Oct 28 '12 #3

P: 19
Dear all,


I have attached copy of the last version of my projects.


You can go to the HRs_Filter form or the DRs_Filter form.


Input the date as for example 12/10/12 or 13/10/12 (means 12-Oct-2012) it will work for the daily reports but not work for the history reports.


You can check this yourself.


Regards,

mhegazy
Attached Files
File Type: zip TanksDatabase.zip (432.2 KB, 71 views)
Nov 8 '12 #4

NeoPa
Expert Mod 15k+
P: 31,186
No thanks. Speaking for myself.

It is your responsibility to post the relevant information. Not ours to spend time digging for it, not to mention the added need on that path to download something from the internet.
Nov 8 '12 #5

Post your reply

Sign in to post your reply or Sign up for a free account.