469,166 Members | 2,189 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,166 developers. It's quick & easy.

Report with subreports that don't show in print preview or printed

2
I have a report that has 4 sub report (all created in design mode not VBA). Individually all of the subreport are visible in Print Preview. When I display them as the final report in print preview two of the subreports do not show (currently they have they have 0 balances for)

I need all of the subreports to show even if they have 0 balances.

Can anyone help me.
Jun 22 '12 #1
1 3412
twinnyfo
3,653 Expert Mod 2GB
behlin,

First check to see that hte Master/Child fields have been properly linked on the main report. there might be something preventing the Master/Child relationship from showing up properly.

Second, do the subreports display properly individually even when there is a zero balance? If not, then they won't show up properly on the main form either. Then that might require tweaking how the RecordSource of the subreport is gathering data. A Null data source will not typically show up.
Jul 25 '12 #2

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

reply views Thread by Htk | last post: by
2 posts views Thread by Martin | last post: by
2 posts views Thread by Brad Pears | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by zhoujie | last post: by
1 post views Thread by Mortomer39 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.