By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,761 Members | 1,878 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,761 IT Pros & Developers. It's quick & easy.

Form showing up blank

P: 28
Hi all

Having had such great help from you guys in the past I'm hoping that someone could shed some light on this issue I've been unable to solve.

I have diluted my database down to the objects nescessary to establish the problem which I believe is a relationship/key issue. For your information though, the relationship should be one-to-one.

From the StudentInfo form you can open up the MedicalForm for that particular student. If a medical record has not already been started for them then it will ask you if you wish to create one. Once this is done the form should open up as normal with the relevant information and allow you to edit. However whenever the MedicalForm opens it opens blank.

After trying various things I thought I'd got it working by changing the table in which the FK was present and allowing a many-to-many relationship. However although this only changed the problem; the record could no longer be deleted.

Anyway, a rather long winded explanation. And apologies if it doesnt all make sense. If you just take a look at the database file though it should become clear what I mean.

Any help would be o so appreciated!
Attached Files
File Type: zip ZacHarvey.zip (285.3 KB, 46 views)
Jun 7 '12 #1
Share this Question
Share on Google+
5 Replies


dsatino
100+
P: 393
Well your relationship were a mess. And there are certainly better ways to do this, but since you said stripped a lot out I tried to keep it intact as possible.

I changed the relationships and some of the code. Mainly, it now check for the existence of the medical on the click of the button rather than on the medical form open.
Attached Files
File Type: zip ZacHarvey .zip (433.7 KB, 52 views)
Jun 7 '12 #2

P: 28
Thanks a lot dsatino. I'll take a look in the morning (GMT) I don't have access on my home PC.
Jun 7 '12 #3

P: 28
Ok I took a look around at the changes you've made and after making sense of what you'd done I implimented it in my origional db. There were a couple of minor problems which I sorted:
  1. When attempting to delete the medical record it came up with Error 2046: The command 'DeleteRecord' isn't available now. So I got rid of the delete command and used a delete action query instead. This solved the problem.
  2. Also a warning box was coming up whenever I attempted to open the medical form telling me the table was about to be appended so I've disabled conformation of action queries in the options.

However I can't type into the medical form. I could in your's but after making the changes in mine it won't let me. I think this is because the form is based on the query and somethings stoping the query from appending the table. Can't figure it out though. I'll upload my full db this time if you are able to take a look into this it would be greatly appreciated.

Since you said things were a mess in my watered down version, I apologise in advance for the state of my full database. I've just done a lot of learning on the go whilst making this system and have things sourced from different places etc
Attached Files
File Type: zip BTG Co-ordinators Database.zip (785.9 KB, 48 views)
Jun 8 '12 #4

dsatino
100+
P: 393
I probably won't have time to get this. But off the top of my head, you need to mimic the relationships in what I gave you and then change the recordsource of your form to what I have in mine.

Basically, your query is either not updatable, or you have relationship rule that's not met.
Jun 8 '12 #5

P: 28
Ahh I didn't check the record source of yours. Thanks, I'll take a look. Other than that though it should all be the same as I exported the module and query and checked my relationships were the same.
Jun 8 '12 #6

Post your reply

Sign in to post your reply or Sign up for a free account.