By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,761 Members | 1,878 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,761 IT Pros & Developers. It's quick & easy.

Subscript out of range - error message

P: 91
I am importing an excel file to the access DB.
The headers in the excel is same as the field names in the access and also the data type is properly defined.
However, I am still getting this error message.


Screen shot of the excel file is attached in a word doc. Sorry, do not have photoeditor to upload this as JPEG.

Any suggestion is much appreciated.
Attached Files
File Type: doc error.doc (246.0 KB, 161 views)
Mar 15 '12 #1

✓ answered by sg2808

I was trying to import manually (no use of any code) and was getting this error message. So, instead of adding the data to the existing table (no data inside), I selected the first option of creating the table with spreadsheet data and I was successful.
Happy for you to delete this post.

Regards,

Share this Question
Share on Google+
3 Replies


NeoPa
Expert Mod 15k+
P: 31,489
As you haven't posted any code showing what you're running to produce this error message, or even explained that you are running code anywhere in your question, I assume you must be running the import manually, but I can't imagine that error message associated with a manual import. It comes from blowing the bounds of an array of similar.

If the problem is actually triggered by a manual import directly then please confirm this and try to explain exactly what you see.

If the error message is actually from running code then please let me know and I will delete this question as nonsense and you can post it again properly.
Mar 15 '12 #2

P: 91
I was trying to import manually (no use of any code) and was getting this error message. So, instead of adding the data to the existing table (no data inside), I selected the first option of creating the table with spreadsheet data and I was successful.
Happy for you to delete this post.

Regards,
Mar 15 '12 #3

NeoPa
Expert Mod 15k+
P: 31,489
No need to delete if that's the case SG. Someone may be able to offer an explanation, which may no longer be necessary for you, but could prove helpful for someone-else looking into the same problem.

Thanks for confirming the situation :-)
Mar 15 '12 #4

Post your reply

Sign in to post your reply or Sign up for a free account.