By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,486 Members | 2,061 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,486 IT Pros & Developers. It's quick & easy.

Lost my "add new record" icon in navigation bar

P: 23
In my form, which contains a subform, I have lost the "add new record" icon for my master form (way at the bottom). I have tried adding a "add new record" command button to fix the situation, but when I try to use this command button, I get the following message: "You can't go to the specified record".
Dec 20 '11 #1
Share this Question
Share on Google+
29 Replies


Rabbit
Expert Mod 10K+
P: 12,315
You probably set the subform to not allow additions.
Dec 20 '11 #2

P: 23
That is not the problem. Remember, I cannot add items to my main form, not the subform.

Thanks anyway.
Dec 21 '11 #3

Rabbit
Expert Mod 10K+
P: 12,315
Then you probably set the main form to not allow additions. Or you're using a non-updateable query as your record source.
Dec 21 '11 #4

P: 23
My main form allows edits/additions. I do not use queries in this database. My record sources are tables. It's very frustrating.
Dec 21 '11 #5

Rabbit
Expert Mod 10K+
P: 12,315
What's the file size of the database?
Dec 21 '11 #6

P: 23
4.6 MB. I just started it. Don't want to add more to it until it works.
Dec 21 '11 #7

Rabbit
Expert Mod 10K+
P: 12,315
Zip and attach your database so we can take a look at it.
Dec 21 '11 #8

P: 23
Cannot send you db because it contains confidential information. Sorry.
Dec 22 '11 #9

NeoPa
Expert Mod 15k+
P: 31,186
It's up to you of course. If you need the help then you will do the work to strip out the sensitive data and replace it with meaningful, but dummy, data. Full instructions can be found at Attach Database (or other work).
Dec 22 '11 #10

P: 23
I tried putting in dummy data yesterday and this morning. It did not work out. So, I guess that's it. Thank you.
Dec 22 '11 #11

Rabbit
Expert Mod 10K+
P: 12,315
Then just delete all the data and attach that.
Dec 22 '11 #12

P: 23
I have removed data and put in some dummy ones. How do I attach to this post??
Dec 22 '11 #13

Rabbit
Expert Mod 10K+
P: 12,315
The instructions are in the link that NeoPa posted.
Dec 22 '11 #14

P: 23
I did see the instructions, but there is no link or option for attaching files.
Dec 22 '11 #15

NeoPa
Expert Mod 15k+
P: 31,186
Larocqgi:
I did see the instructions, but there is no link or option for attaching files.
What did you find when you tried to follow instruction #9 in the list? Many others have managed to follow those instructions and not found a problem.
Dec 22 '11 #16

P: 23
When I post a reply and scroll down to the bottom, I see the following:

Didn't find the answer to your question? Post your Microsoft Access / VBA question on Bytes

You can also browse similar questions: Microsoft Access / VBA None
( Edit Tags )


Copyright 1995-2010 BYTES. All rights Reserved. Formerly "TheScripts.com" from 2005-2008
About Bytes | Advertise on Bytes | Help
Latest Expert Topics
Sitemap | Microsoft Access / VBA Answers Sitemap | Microsoft Access / VBA Insights Sitemap
Dec 22 '11 #17

Seth Schrock
Expert 2.5K+
P: 2,931
Click on the Advanced button next to Post Reply. From there you can click on the Manage Attachments button.
Dec 22 '11 #18

NeoPa
Expert Mod 15k+
P: 31,186
I'll update the linked article as that's not clear (and it really should be).

PS. Done.
Dec 22 '11 #19

P: 23
Here is my problematic database. I cannot see the "add new record" button for the master form. I will take some time off from this after the end of the day today. Will be back on Jan 2.

Thanks your your help.
Attached Files
File Type: zip Problematic Database.zip (262.8 KB, 75 views)
Dec 23 '11 #20

NeoPa
Expert Mod 15k+
P: 31,186
You haven't followed the instructions correctly and I can't look at your database as it's not in a format I can open. I don't know what else I can say at this point. The instructions are all there. If you follow them all will work. If you don't then it won't.
Dec 23 '11 #21

P: 23
I cannot follow the instructions as they do not work. I cannot debug and compile since I don't have that option. I'm using MS Access 2007. So, I surrender; I give up. Merry Xmas and all the best for 2012.
Dec 23 '11 #22

Seth Schrock
Expert 2.5K+
P: 2,931
I tried to save it in .mdb format, but there are features that require the latest version.

@larocqgi In design view of the Product form, I don't see a Add New Record button. This could be part of why you don't see it in form view.

Also, It seems that the database is locked. When I try to get into the vba code, it says that the project is locked and unviewable. I have never seen this before so I don't know how to fix it, but I do think that it could be part of the reason that you can't add new records.
Dec 23 '11 #23

P: 23
How could I have locked my database? I'm lost.
Dec 23 '11 #24

Seth Schrock
Expert 2.5K+
P: 2,931
I'm not sure. Like I said, I've never seen this before. Later today, I'll check into some more and see what I can find and maybe unlock it.
Dec 23 '11 #25

Rabbit
Expert Mod 10K+
P: 12,315
When I said you probably used an unupdateable query as your record source, and you replied with you don't use queries, your record sources are tables, did you double check your record sources?

I'm going to take a shot in the dark and say no, you did not. Because you're using an unupdatable query as your record source. This query is not updateable. And it's the record source of your form.
Expand|Select|Wrap|Line Numbers
  1. SELECT Product.*, Product_List.[Product List]
  2. FROM Product_List
  3. INNER JOIN Product
  4. ON Product_List.[Product List] = Product.Product;
Dec 23 '11 #26

P: 23
I have difficulty following you Rabbit. I have not created queries. I have only tables. So, I don't understand why my record source would be a query.
Dec 23 '11 #27

Rabbit
Expert Mod 10K+
P: 12,315
You don't have to create a query object to use a query as a record source. If you look at the record source property of your form, there is a query definition / SQL string in there.
Dec 23 '11 #28

Seth Schrock
Expert 2.5K+
P: 2,931
That row source is a query. Even though you didn't actually create a query that is listed in the Access Objects, that is SQL code for the query. It is just another way of utilizing a query.
Dec 23 '11 #29

NeoPa
Expert Mod 15k+
P: 31,186
Here's a couple of points that might help :
  1. The MS Access term for a saved query in a database is a QueryDef. Many people think of them as queries, but the technical term is a QueryDef. A Query, on the other hand, is any query, which includes QueryDefs, but also SQL strings which resolve to queries when passed to the SQL engine (Jet). It makes communication awkward and easy to misunderstand, but if you realise that it can help you to deal with such questions more clearly. It seems your form is built using a Query, but not a QueryDef one.
  2. Reasons for a Query to be Non-Updatable is worth checking for any query that a form is built on and where you want to update the underlying data.

PS. If you say when you try to follow instructions that you were unable to follow one of them, and give a reason, then we can deal with that better than if you don't explain this. Dealing with someone who has found a problem is so much easier than dealing with someone who cannot, or will not, follow simple instructions. If we know (as in this case) that you are of the former group then we can make progress. For those in the latter group there is very little we can do.

PPS. Thanks again to Seth for taking the trouble to attempt to do the conversion himself and explaining the problem he encountered. Your efforts are appreciated :-)
Dec 24 '11 #30

Post your reply

Sign in to post your reply or Sign up for a free account.