By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,426 Members | 3,118 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,426 IT Pros & Developers. It's quick & easy.

MSACCESS-Piechart- legend -truncates zeroes

P: 16
My legend in the piechart has values like 004,008 etc but while the report is created,the legend has the preceding
0's truncated and 004 is shown as 4 and 008 is shown as 8. Is there a way to fix that and avoid removal of preceding zeros in the legend. Thanks for the help !
Nov 29 '11 #1
Share this Question
Share on Google+
6 Replies


TheSmileyCoder
Expert Mod 100+
P: 2,321
If you open the chart, you should be able to set the format property for the Legend object to text. Its likely currently set to General.
Nov 29 '11 #2

P: 16
Hello ,Thanks for your response. I am unable to change the format property of the legend object to text .I would really appreciate if you could explain me the steps involved. I dont see a format property for legend at all. Also even if I change the column to text in the datasheet and rerun the query,the legend does not show the leading zeros in the bargraph. Please advise
Nov 29 '11 #3

TheSmileyCoder
Expert Mod 100+
P: 2,321
I dont have the greatest experience in charts, but last time I used it I simply double clicked the chart in my report, and it pretty much looked like it does in excel.

I can't tell you exactly where to click as I dont currently have any databases that includes charts, so I have no sample to work by.
Nov 29 '11 #4

NeoPa
Expert Mod 15k+
P: 31,494
Again, I have little experience (or interest) in Pie Charts, but I suspect it will have a control for showing the title whose properties can be maintained - probably graphically. Try going in to design mode and enlarging the control for the legend.
Nov 30 '11 #5

P: 16
I have no clue if there is an option to change the format of the legend to text .So I reformatted my data and prefixed my data with a colon and by that it forces the data as text and 0004 is written successfully as :0004 into the legend. There may be other solutions but this works...
Nov 30 '11 #6

NeoPa
Expert Mod 15k+
P: 31,494
Oh I see. If that's your problem (It was hard to understand what you were asking about until your latest post gave it away) then use formatting. If you haven't found the object then the better option of setting the object's Format property to "0000" won't help you much, but you can set the value to :
Expand|Select|Wrap|Line Numbers
  1. Format({YourValue}, "0000")
Nov 30 '11 #7

Post your reply

Sign in to post your reply or Sign up for a free account.