469,366 Members | 2,546 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,366 developers. It's quick & easy.

Getting an accde file to work on another computer with RunTime

I am trying to get an accde file to work on a second computer. They are both running Windows 7. The development machine has Access 2010. I use the Save & Publish - Save As functions on the file menu and get an accde file. I test it on this machine and it comes up in a weird mode - i have to right click and play with options in the nav panel on the left. It finally displays the form that i use to control the entire application. I open the form and the application seems to work fine and the design views for the objects are not available, as expected.
I move the file to the second machine. It does not have Access but I have downloaded the 2010 RunTime and installed it. When i open the app with a double click on the file, I get a blank page with only the file tab. The only options on the file tab are print, privacy options, and exit. No nav bar, nothing. On the status bar at the bottom, there is an Access logo and the words Powered by Microsoft Access.

Isn't the app just supposed to open just like it does on my development machine? If so, any ideas on what i am doing wrong? Or am i misunderstanding how this is supposed to work? Any help would be appreciated
cb
Jul 28 '11 #1
5 9210
Narender Sagar
189 100+
You have to enable Macros in Run Time machine. Just go to small drop down button (next to save button) and go to 'more commands' and then go to 'Trust Center' then 'Trust center setting' then 'Macro setting' and there Enable Macros. Close Access and reopen it. Hopefully it will solve the issue.
HTH
Jul 28 '11 #2
Narendar - when i launch ALL that I get is the red File menu tab. There is nowhere to save so the option for Trust Settings isn't available. The only options available are Print, Privacy Options, and Exit. There is not even anything else grayed. I tried downloading Runtime again with no success. I notice at the top bar on my machine with Access it says 2007 but in the Help menu, it says 2010?? I tried online Microsoft help but i can't get through to a human being. Is there something i am doing wrong that is limiting the menu to only show File?
Jul 29 '11 #3
@Narender Sagar
I really appreciate your staying with me on this. I can't ge MS on the phone or get a message through their online "help" system.
There is a small drop down - Customize Quick Access Tool Bar but ALL of its options are grayed. There is a Save on it(grayed) but there is no elipsis (...) after it so it looks like even if it wasn't gray, it wouldn't give me the option to set any trust macro features. On the far right, there is a ^ control that is supposed to affect the ribbon but it toggles from up to down but seems to do nothing.
Jul 30 '11 #4
Rabbit
12,516 Expert Mod 8TB
Did you set the startup options so that the main form opens?
Jul 30 '11 #5
Narender Sagar
189 100+
Hi Chris,
I am sorry, I forgot to mention earlier, there is one more setting you need to do. You have to add location of the application folder to the 'Trusted location' (Now this is bit tricky part, need administrative rights on that machine and bit knowledge of registry editing) You can take help of IT (hardware) person.

Registry settings (be careful!!)
Now remember that messing with the registry can mess up your computer, so unless you know what you are doing leave it alone and let someone who knows what he's doing help you with making the necessary adjustments.

Every trusted location you add to the Trusted Locations in the Trustcenter Settings from within Access is written to the registry. When adding the runtime engine to a certain client pc a set of keys will be created. By adjusting those settings you can set a specific path as an additional trusted location.

Keys
These are the keys you have to add to the trusted locations. As stated earlier, if you are not familiar with the registry don't touch it and ask for help from someone who knows this stuff!
Steps:
1. Click Start button
2. Click run and type : REGEDIT
3. Go to following location:
The Key you have to add is the following:
[HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\A ccess\Security\Trusted Locations\Location1
AllowSubFolders (REG_DWORD) = 1
Path (REG_SZ) "c:\thepathtoyourdatabasefolder"


Explanation
The first line you see is the tree structure you have to follow to get to the designated registry key
The second line is the key you have to add to the settings the 1 indicates that the subfolders should be also allowed as trusted.
The third line is the line where you add the path (don't forget the double quotes here..) to the trusted location to be added. This example set's it to c:\blablabla but this can be another drive letter altogether..

Now every location added from within Access will create an addition location number. It might be that you already have Location1, Location2 etc. In that case you have to add another Location(x) to make sure you don't alter anything existing
Now I am sure this will solve your problem.
Jul 31 '11 #6

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

1 post views Thread by Johnson Bruno | last post: by
8 posts views Thread by b83503104 | last post: by
5 posts views Thread by hntgzr | last post: by
2 posts views Thread by Selen | last post: by
4 posts views Thread by MrDeej | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by suresh191 | last post: by
1 post views Thread by Marylou17 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.