469,352 Members | 2,054 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,352 developers. It's quick & easy.

"Object was saved in invalid format"

doma23
107 100+
I have a big problem.
I was working on a new application with lot of fields.
After I defined all the fields (my hands still hurt) I saved the database. After that, I've added a command button on a main form and used save icon for it.
After I tried to open it in Access 2003 nothing happened. No error messages, I just wasn't able to open the form.
When I tried to the same on my laptop using Access 2007 I got this message:

Run-time Error '6037':
"This object was saved in an invalid format and cannot be read."

Please help, I was working on this whole morning, and it's was the most boring job regarding application. I really don't want to do it again.
Sep 8 '10 #1
5 9906
TheSmileyCoder
2,321 Expert Mod 2GB
As I understand it you can access the database but not the form?

Have you tried to (in this order):
1) Open it in design view?
2) Restarting your computer?
3) Make a backup copy, then try to do a "compact and repair".
4) Recompile the database.


Regarding 4:
Close access
Select Start->Run and type:
Expand|Select|Wrap|Line Numbers
  1. "C:\Program Files\Microsoft Office\OFFICE11\MSACCESS.EXE" /decompile
You may need switch the Office11 with something else depending on your version of access.
Open VBA (Alt-F11), select Debug->Compile
Sep 8 '10 #2
doma23
107 100+
Correct, I can access the database but not the form.
I have 2 forms, one of them works fine, the second I cannot open.

1) Yes. It just won't open.
2) Yes. It doesn't help. I've even tried to open the form on another computer with Access 2007.
3) I've tried. Form still won't open.

4) I've tried. Compilation process pointed to all the code that was somehow connected with the form that doesn't want to open (frmMain). Like it doesn't recognize it. I've put that code in comments. It also pointed to the code inside the frmMain. When I put that code in comments there was the same message "This object was saved in an invalid format and cannot be read". The thing is that I have the code backuped, I only need the design of the form. And I cannot open it.
Sep 8 '10 #3
doma23
107 100+
Btw. Like you've mentioned, I think that switching off references could be helpful. I've tried but didn't notice difference. Some of the references I cannot deselect as they are being in use, the message says.
Sep 8 '10 #4
TheSmileyCoder
2,321 Expert Mod 2GB
I don't recall having encountered that specific error, so don't really know what to say at this point. The only thing more I can think is to create a new blank database, and see if you can import the form into that database, and then open the form in your new database. Other then that, I only see a redesign.
Sep 8 '10 #5
doma23
107 100+
I've tried to export the form also, and unfortunately, I get the same error message.
Sep 8 '10 #6

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

reply views Thread by Richard Arthur | last post: by
reply views Thread by =?Utf-8?B?SkhhbGV5?= | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by zhoujie | last post: by
1 post views Thread by Marylou17 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.