By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,081 Members | 1,885 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,081 IT Pros & Developers. It's quick & easy.

Error: Record is deleted

P: 5
When I run the append query, I get message Record is deleted, I tried to find out and found out it means database is corrupted, but is there any way I can check if there is some particular corrupted record in the database or it must be the whole database. What can be done to get it fixed?
Mar 5 '10 #1
Share this Question
Share on Google+
1 Reply


TheSmileyCoder
Expert Mod 100+
P: 2,321
1) Backup your DB

2) You can try to do a Compact And Repair (repeat it a few times, if the first doesn't work) The problem with this method in my oppinion is that I don't really got told "what" was repaired, so I am unsure of how much data-corruption may have occured, or if its simply clearing teh cache so to speak. However, the Compact and Repair is pretty much the only thing I know of.

3) Create a new blank DB, and import all your modules/forms into that blank DB. You will need to reset the relations, and startup properties. I've heard this can help.
Mar 6 '10 #2

Post your reply

Sign in to post your reply or Sign up for a free account.