By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,475 Members | 1,361 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,475 IT Pros & Developers. It's quick & easy.

Write Conflict error.

100+
P: 111
I have a simple form based on a table which has several controls and subforms.
When I open the form and try to edit things it gives me this trritating error saying "Write Conflict". It has three options saying Save Record, Copy to Clipboard and Drop Changes. I want to overwrite but "Save Record" button is disabled. I forcefully have to select "drop changes."
Please let me know what is wrong here?
Thanks
I already tried this solution, but did not work
1. Form's RecordLocks property set to Edited Record
2. Write this code
Expand|Select|Wrap|Line Numbers
  1. Private Sub Form_Deactivate()
  2. DoCmd.RunCommand acCmdSaveRecord
  3. End Sub
Feb 25 '10 #1
Share this Question
Share on Google+
4 Replies


TheSmileyCoder
Expert Mod 100+
P: 2,321
1) Try compact and repair
2) Are you the only user in the database?
Feb 25 '10 #2

100+
P: 111
I forgot to mention but I already tried it 3 times. Did not work.
I am the only user, yes.
I even tried to make my own Navigation buttons. That did not help either.
Thanks for looking into it.
Please help!!
Feb 25 '10 #3

100+
P: 111
OK I found it
Refer this thread
http://support.microsoft.com/kb/278696
Feb 25 '10 #4

TheSmileyCoder
Expert Mod 100+
P: 2,321
Please when posting provide:
Access version, and in your case I'd find it rather relevant to specify that your working of an SQL server.

Glad you found a solution, and glad you took the time to post it here :)
Feb 25 '10 #5

Post your reply

Sign in to post your reply or Sign up for a free account.