By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,620 Members | 1,512 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,620 IT Pros & Developers. It's quick & easy.

Quick filter on split form

P: 1
I have two separate but similar databases and each has a split form that acts as the main form used. One of these split forms is able to be filtered from the datasheet portion of the split form using Quick Filters at the top of each column.
The other database split form doesn't show any Quick Filter values when the column headers are clicked. Does anybody know what the problem is, or where I would change the parameters to enable Quick Filters?
I appreciate any help that anyone can give me. Thanks in advance.
Oct 14 '09 #1
Share this Question
Share on Google+
9 Replies


NeoPa
Expert Mod 15k+
P: 31,494
I would guess one or other of the form's properties needs to be set to allow filtering. Hang on. I'll check quickly...

I would suggest paying particular attention to the AllowFilter property, but compare both forms for differences and see what allows it to work.
Oct 15 '09 #2

P: 52
Has there been any resolution to this issue?

Leon
Oct 26 '09 #3

NeoPa
Expert Mod 15k+
P: 31,494
Nothing confirmed. Why do you ask (The answer seems fairly obvious)?
Oct 26 '09 #4

P: 52
Sorry let me explain: I tried what was posted above, and still cvant get it to work. I was wondering if anyone found the propertu that was causing this problem. I would appreciate any help, thanks.

Leon
Oct 26 '09 #5

NeoPa
Expert Mod 15k+
P: 31,494
No sorry.

I would need to see the items concerned even to know where to look if it's not the .AllowFilter property..
Oct 26 '09 #6

Megalog
Expert 100+
P: 378
I've seen this happen a lot on columns using multi-value fields, or if there's a complex SQL string as the form's RecordSource. The filtering option isnt turned off, it's just not returning any of the column values when you click the headers, correct?

If the form's RecordSource is a SQL string, try taking that string and creating a new query with it. Save the query, and set the form's RecordSource to that query instead. Normally it wouldnt change anything, but split forms are very strange and I've found this solution works most of the time.
Oct 27 '09 #7

P: 52
That is correct, its not returning the values. Instead of changing the record source to filter the subform, i used filter functions in my VBA. Seems to work fine now. i appreciate the post.

Leon
Oct 27 '09 #8

P: 1
Megalog - this is ancient history for you now, but I just encountered this problem in an Access 2007 split form. After searching far and wide your suggestion was the only one I found that made any sense for my situation. I do have a complex SQL string in the form's RecordSource so creating a new query and referencing that was spot on. All the quick filters are there now! Thanks.
Sep 19 '14 #9

P: 1
@Megalog
- Hi... this was exactly the issue: the "Data Source" of the form had an SQL string instead of a query. This was preventing the display of the quick filter option. I replaced the string for a query and it did the trick. Thank you very much for the tip, saved me a lot of time.
6 Days Ago #10

Post your reply

Sign in to post your reply or Sign up for a free account.