By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
426,234 Members | 1,823 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 426,234 IT Pros & Developers. It's quick & easy.

Access keeps autosaving

P: 24
I am sure I have done something but cannot work out how to undo....

Everytime I go to a new query and create something, when I close it down, it doesn't give me the option of "Do you want to save the query" (or something like this.
Instead, it acts as if I automatically want to save it which is starting to really annoy me now.
Did a quick google search but could not find anything. Does anybody have any ideas how to return my database to normal?
Feb 27 '09 #1
Share this Question
Share on Google+
5 Replies


missinglinq
Expert 2.5K+
P: 3,532
Is it actually saving the query? How can it save a new query, without at least asking for a name? Is the query actually saved? If so, how do you know? What name is it saved under?

Linq ;0)>
Feb 27 '09 #2

P: 24
Sorry yeah, the pop up for a name shows.
But usually, before this pop up it at least asks you if you want to save it. When you click YES, the "What do you want to save as" box appears -i.e. what I am getting.
Feb 27 '09 #3

DonRayner
Expert 100+
P: 489
My guess is that you have the the warnings turned off. Try entering the following in the immediate window of your visual basic editor. If it works you will have to track down where you are actually setting the warnings off.

Expand|Select|Wrap|Line Numbers
  1. docmd.SetWarnings true
Feb 27 '09 #4

P: 24
@DonRayner

Yep, that's done it. I knew exactly where I had that as well. I imported some code from somewhere where that had set. Cheers
Feb 27 '09 #5

missinglinq
Expert 2.5K+
P: 3,532
Code with

DoCmd.SetWarnings False

always, always, always needs

DoCmd.SetWarnings True

It's one of those things Access should do automatically, like an End Sub when you start a writing a sub!

Linq ;0)>
Feb 27 '09 #6

Post your reply

Sign in to post your reply or Sign up for a free account.