By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,483 Members | 1,909 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,483 IT Pros & Developers. It's quick & easy.

Multi Field Update Query

P: 76
tblPrimary has the following fields

ID
mapID
map1
map2
map3
macID
mac1
mac2
mac3
madID
mad1
mad2
mad3

How do I go about having an Update query, set/insert the mapID,macID,madID fields = to the value of the ID field?
Jan 23 '09 #1
Share this Question
Share on Google+
6 Replies


Expert 100+
P: 1,287
  1. Open query designer
  2. Add tblPrimary
  3. Right click the blank design area next to the table and select Query Type->Update Query
  4. Double click each field you want to update
  5. In the Update To: section of each field at the bottom, put [ID]
  6. Execute
Jan 23 '09 #2

P: 76
@ChipR
Thanks!
I did this and got an error?
Will try again and post back error.........thanks again :o)
Jan 23 '09 #3

P: 76
Ok, getting a "Record too large." error.
There are 549 records and I tried to reduce the update to only update one field....error still persists. ???
Jan 23 '09 #4

Expert 100+
P: 1,287
I haven't seen that one before. It may indicate that the ID value doesn't fit into the field you are trying to copy it into. Like trying to copy a long int into a short int. Do you get a specific error number?
Jan 23 '09 #5

NeoPa
Expert Mod 15k+
P: 31,186
I suggest you post here the field types of all the relevant fields ([ID]; [MapID]; [MacID]; [MadID].

I expect this will make the problem clearer
Jan 25 '09 #6

P: 76
Thanks folks! Apparently "something" happened with my linked spreadsheets. I ran the linked table manager and voilą!

I said it before and I'll say it again.........you're all terrific. :o)
Jan 28 '09 #7

Post your reply

Sign in to post your reply or Sign up for a free account.