By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,475 Members | 1,910 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,475 IT Pros & Developers. It's quick & easy.

Linked Table Manager won't manage

prn
Expert 100+
P: 254
Hi folks,

Here's a weird one. We have a fair number of Access applications where the front end sits on a user's desk somewhere, but the data sits on a SQL server. We're in the process of retiring a SQL Server box that contains some of those databases and I've got the responsibility for the Access end of the changes. In most of the cases so far, it's been a matter of trotting over to the remote location and modifying the DSN (Control Panel > Administrative Tools > Data Sources > ...). I change the server name and all's swell. Sometimes I have to go to the application, Tools > Database Utilities > Linked Table Manager, select all, and relink to the reconfigured DSN and then it works.

Today, I had one where I did that and instead of relinking I got a dialog box (titled "Linked Table Manager") with an error message: "The Microsoft Jet database engine could not find the object '______'. Make sure the object exists and that you spell its name and the path name correctly." Where the blank '______' contains an actual linked table name as selected in the Linked Table Manager dialog.

Clearly the object does exist (both on the original database server and on the replacement) and the name is spelled correctly or the application would not have worked at all. Furthermore, when I reconfigured the system DSN I ran the test and it completed successfully. Therefore, I know the DSN works. So why is Access failing to "find" the table and what can I do about it?

Any ideas?

Thanks,
Paul
Nov 12 '08 #1
Share this Question
Share on Google+
1 Reply


prn
Expert 100+
P: 254
prn
Sorry, folks. False alarm. It turned out that the user's default database was not set in the new server. :(

The result apparently was that when that user logged in, it didn't see the right set of tables.

Thanks anyway to anyone who read my question.

Paul
Nov 12 '08 #2

Post your reply

Sign in to post your reply or Sign up for a free account.