By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,456 Members | 1,251 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,456 IT Pros & Developers. It's quick & easy.

Search form on access cant work on different computer

P: 9
Hi... I have a small problem here. I did a database on my School computer with Access 2007. However, when I use the database on my Home computer with Access 2007 there. The search function doesnt work when it could work initially on my School computer. What could be the reason for this?
Oct 25 '08 #1
Share this Question
Share on Google+
4 Replies


missinglinq
Expert 2.5K+
P: 3,532
What exactly does "doesn't work" mean? Do you get error messages? Does nothing happen? Do you get the wrong results?

Was this search function written in code or with en embedded macro? Code does not run in 2007 unless your database resides in a folder that has been declared a “trusted” location.

To trust your folder, click:

Office Button (top left)
Access Options (bottom of dialog)
Trust Center (left)
Trust Center Settings (button)
Trusted Locations (left)
Add new location (button)

If that doesn't work, consider this: When apps run fine on one machine and not on another or run fine in one version and not when run under a newer version, one thing you have to think about are missing references.

Here are Doug Steele's instructions on how to troubleshoot the problem:

*** Quote ***

Any time functions that previously worked suddenly don't, the first thing to suspect is a references problem.

This can be caused by differences in either the location or file version of certain files between the machine where the application was developed, and where it's being run (or the file missing completely from the target machine). Such differences are common when new software is installed.

On the machine(s) where it's not working, open any code module (or open the Debug Window, using Ctrl-G, provided you haven't selected the "keep debug window on top" option). Select Tools | References from the menu bar. Examine all of the selected references.

If any of the selected references have "MISSING:" in front of them, unselect them, and back out of the dialog. If you really need the reference(s) you just unselected (you can tell by doing a Compile All Modules), go back in and reselect them.

If none have "MISSING:", select an additional reference at random, back out of the dialog, then go back in and unselect the reference you just added. If that doesn't solve the problem, try to unselect as many of the selected references as you can (Access may not let you unselect them all), back out of the dialog, then go back in and reselect the references you just unselected. (NOTE: write down what the references are before you delete them, because they'll be in a different order when you go back in)

For far more than you could ever want to know about this problem, check out

http://www.accessmvp.com/djsteele/Ac...nceErrors.html

Just so you know: the problem will occur even if the library that contains the specific function that's failing doesn't have a problem.

**** End Quote ****

Welcome to Bytes!

Linq ;0)>
Oct 25 '08 #2

P: 9
Hi, it runs in an embedded macro... the link to my databse is here https://rcpt.yousendit.com/618768139/046d7d2be3ff1040e7607889c676c702

Possible to help me further. The problem is that when I search using the search form in my sch computer, it will display the correct infomation. However, when i use it at home, it doesnt work at all. No matter what i search, it returns nothing
Oct 25 '08 #3

missinglinq
Expert 2.5K+
P: 3,532
I don't run 2007 and so I can't download the app to look at it. Using an embedded macro knoks out my first suggestion. Have you tried the second suggestion, checking for missing references?

Linq ;0)>
Oct 25 '08 #4

P: 9
hi..nope i tried the 2nd method..doesnt work too...
Oct 26 '08 #5

Post your reply

Sign in to post your reply or Sign up for a free account.